2826 matches found
bentodev (>=0.1.17, <=2018.11.2), confsave (>=0.1.0, <=0.3.0) +3 more potentially affected by CVE-2026-76219 via gitpython (2.1.3)
gitpython PYPI version 2.1.3 is affected by a known vulnerability. The following packages have a transitive dependency on gitpython and may be impacted: - bentodev =0.1.17, =0.1.0, =0.9.0, =0.53.0 - reckoner 1.1.1 Source cves: CVE-2026-76219 Source advisory: OSV:GHSA-4GMW-GG2M-W46P...
arca (>=0.1.0a0, <=0.1.0), mali (>=0.2775.0, <=0.4018.0) +4 more potentially affected by CVE-2026-76219 via gitpython (2.1.7)
gitpython PYPI version 2.1.7 is affected by a known vulnerability. The following packages have a transitive dependency on gitpython and may be impacted: - arca =0.1.0a0, =0.2775.0, =0.2304.0, =0.2304.0, =0.1.0a1, =1.0.0, =1.0.6 Source cves: CVE-2026-76219 Source advisory: OSV:GHSA-4GMW-GG2M-W46P...
elib (>=0.1.55, <=0.1.57), emiz (>=0.1.35, <=2018.4.2.1) +11 more potentially affected by CVE-2026-76219 via gitpython (2.1.8)
gitpython PYPI version 2.1.8 is affected by a known vulnerability. The following packages have a transitive dependency on gitpython and may be impacted: - elib =0.1.55, =0.1.35, =0.2.4a149, =0.0.1, =1.0.0, =0.4233.0, =0.2354.0, =0.2354.0, =0.1.7, =0.2.120, =1.0.0, =0.1.0, =2.1.1 Source cves:...
arca (>=0.1.1, <=0.3.1), epab (>=2018.4.2.1, <=2018.4.2.3) +3 more potentially affected by CVE-2026-76219 via gitpython (2.1.9)
gitpython PYPI version 2.1.9 is affected by a known vulnerability. The following packages have a transitive dependency on gitpython and may be impacted: - arca =0.1.1, =2018.4.2.1, =1.0.3, =0.0.0, =0.4.1 - ubuntudesign-documentation-builder 1.6.0 Source cves: CVE-2026-76219 Source advisory:...
cabrita (>=2.2.2b1, <=2.2.2b2), cico (>=0.1.0, <=0.1.8) +4 more potentially affected by CVE-2026-76219 via gitpython (2.1.10)
gitpython PYPI version 2.1.10 is affected by a known vulnerability. The following packages have a transitive dependency on gitpython and may be impacted: - cabrita =2.2.2b1, =0.1.0, =0.1.0, =3.11.1, =0.9.0, =0.9.7.2 Source cves: CVE-2026-76219 Source advisory: OSV:GHSA-4GMW-GG2M-W46P...
android-category (>=0.0.3, <=0.0.4), ant-cli (0.0.1) +34 more potentially affected by CVE-2026-76219 via gitpython (2.1.11)
gitpython PYPI version 2.1.11 is affected by a known vulnerability. The following packages have a transitive dependency on gitpython and may be impacted: - android-category =0.0.3, =0.0.2, =0.3.0, =0.0.2, =0.12.4rc1, =0.1.26.dev1542857464, =0.2.3, =0.1.0, =0.0.1, =1.2.5, =0.1.0.0b1, =0.1.3 and mo...
sealights-python-agent (>=0.2.213, <=0.2.247) potentially affected by CVE-2026-76219 via gitpython (2.1.13)
gitpython PYPI version 2.1.13 is affected by a known vulnerability. The following packages have a transitive dependency on gitpython and may be impacted: - sealights-python-agent =0.2.213, =0.2.247 Source cves: CVE-2026-76219 Source advisory: OSV:GHSA-4GMW-GG2M-W46P...
bento-cli (>=0.1.0, <=0.1.1), walletlib (0.1.0) potentially affected by CVE-2026-76219 via gitpython (2.1.14)
gitpython PYPI version 2.1.14 is affected by a known vulnerability. The following packages have a transitive dependency on gitpython and may be impacted: - bento-cli =0.1.0, =0.1.1 - walletlib 0.1.0 Source cves: CVE-2026-76219 Source advisory: OSV:GHSA-4GMW-GG2M-W46P...
airflow-indexima (>=1.0.1, <=2.2.1), arcli (>=0.1.0, <=0.1.1) +69 more potentially affected by CVE-2026-76219 via gitpython (2.1.15)
gitpython PYPI version 2.1.15 is affected by a known vulnerability. The following packages have a transitive dependency on gitpython and may be impacted: - airflow-indexima =1.0.1, =0.1.0, =0.3.0rc1, =0.1.0, =0.7.0, =0.2.0, =0.11.0, =0.1.0, =0.6.0, =0.3.0, =2.0.0, =2019.2.3rc0, =2021.7.0 and more...
ac-solver (0.1.0), acedeploy (>=2.4.15, <=2.4.366.dev1) +772 more potentially affected by CVE-2026-76219 via gitpython (>=3.0.0, <=3.1.57)
gitpython PYPI version =3.0.0, =2.4.15, =2025.10.17, =0.4.0, =0.4.0, =1.2.3, =0.4.7, =0.4.7, =0.2.0, =0.1.8, =0.87.2.dev9, =0.5.0, =0.1.0.dev19, =1.3.0, =2.0.3 and more Source cves: CVE-2026-76219 Source advisory: GHSA-4GMW-GG2M-W46P...
ac-solver (0.1.0), acedeploy (>=2.4.15, <=2.4.366.dev1) +772 more potentially affected by CVE-2026-76219 via gitpython (>=3.0.0, <=3.1.57)
gitpython PYPI version =3.0.0, =2.4.15, =2025.10.17, =0.4.0, =0.4.0, =1.2.3, =0.4.7, =0.4.7, =0.2.0, =0.1.8, =0.87.2.dev9, =0.5.0, =0.1.0.dev19, =1.3.0, =2.0.3 and more Source cves: CVE-2026-76219 Source advisory: OSV:GHSA-4GMW-GG2M-W46P...
ac-solver (0.1.0), acedeploy (>=2.4.15, <=2.4.366.dev1) +772 more potentially affected by CVE-2026-76219 via gitpython (>=3.0.0, <=3.1.57)
gitpython PYPI version =3.0.0, =2.4.15, =2025.10.17, =0.4.0, =0.4.0, =1.2.3, =0.4.7, =0.4.7, =0.2.0, =0.1.8, =0.87.2.dev9, =0.5.0, =0.1.0.dev19, =1.3.0, =2.0.3 and more Source cves: CVE-2026-76219 Source advisory: SNYK:PYTHON-GITPYTHON-18592313...
dotcli (>=0.1.4, <=0.1.7), giraumon (0.0.1) +3 more potentially affected by CVE-2026-76219 via gitpython (2.1.5)
gitpython PYPI version 2.1.5 is affected by a known vulnerability. The following packages have a transitive dependency on gitpython and may be impacted: - dotcli =0.1.4, =1.0.1, =1.0.0, =1.0.18 Source cves: CVE-2026-76219 Source advisory: OSV:GHSA-4GMW-GG2M-W46P...
OESA-2026-3249 python-GitPython security update
GitPython is a python library used to interact with git repositories, high-level like git-porcelain, or low-level like git-plumbing. Security Fixes: GitPython before 3.1.52 is vulnerable to environment-variable exfiltration in Repo.clonefrom. The caller-supplied remote URL is passed through...
PT-2026-78399
Name of the Vulnerable Software and Affected Versions GitPython versions prior to 3.1.58 Description Insufficient validation of options passed to the git rm and git checkout commands within the IndexFile.remove and Head.checkout functions allows for arbitrary file reading. An attacker can provide...
PT-2026-78400
Name of the Vulnerable Software and Affected Versions GitPython versions prior to 3.1.58 Description A remote code execution issue exists in the Repo.init function. The software forwards unsafe git options without proper validation, allowing an attacker to provide a template parameter that points...
OPENSUSE-SU-2026:11466-1 python313-GitPython-3.1.58-1.1 on GA media
These are all security issues fixed in the python313-GitPython-3.1.58-1.1 package on the GA media of openSUSE Tumbleweed...
ROOT-APP-PYPI-GHSA-V396-V7Q4-X2QJ GHSA-v396-v7q4-x2qj in GitPython - Patched by Root
Root has patched GHSA-v396-v7q4-x2qj in the GitPython package for Root:PyPI. Multiple fixed versions available...
SUSE CVE-2026-69097
GitPython before 3.1.53 fails to properly escape section names in git config files, allowing attackers to inject arbitrary configuration directives through malicious submodule names. Attackers can inject core.sshCommand or other dangerous config keys into the victim's .git/config via...