26 matches found
CVE-2026-121522
In BuildKit versions v0.26.0 through v0.34.1, a specific build definition that resolves metadata for the same Git source reference twice can cause the BuildKit daemon to panic and crash, interrupting builds handled by that daemon. The issue is fixed in v0.34.2...
CVE-2026-121522
BuildKit versions v0.26.0 through v0.34.1 are vulnerable to a NULL Pointer Dereference (CWE-476) that causes the BuildKit daemon to panic and crash . This occurs when a specific build definition attempts to resolve metadata for the same Git source reference twice. The crash results in the interru...
EUVD-2026-116537
In BuildKit versions v0.26.0 through v0.34.1, a specific build definition that resolves metadata for the same Git source reference twice can cause the BuildKit daemon to panic and crash, interrupting builds handled by that daemon. The issue is fixed in v0.34.2...
CVE-2026-93326
A flaw was found in BuildKit. An attacker with the ability to define build steps can bypass policy validation rules by supplying a specially crafted Git source. During a clone operation, this issue allows the repository to spoof its remote URL, making untrusted source code appear to originate fro...
AZL-106812 CVE-2026-93326 affecting package moby-engine 25.0.18-1
A build step for a Git source, crafted in a specific way, can bypass some policy validation rules. A malicious build definition can make the repository look like it is coming from a different remote URL than it really is when Git clone is happening. If policy is doing more stricter validation, fo...
Malicious code in @chatunity/baileys (npm)
Source: amazon-inspector b6d06d6b516b21b0ac6ed45e5653dca243695a2c17326669ec58498e4c9bcf45 package.json declares the runtime dependency libsignal with the value github:chatunitycenter/libsignal-node, an off-registry git source with no commit SHA or tag pin. On npm install, npm fetches whatever the...
CVE-2026-71259
ESPHome through 2026.7.0-dev contains an operator-precedence bug in the cv.url validator in esphome/configvalidation.py. Because binds tighter than , any file: URI passes validation regardless of netloc. This validator gates the field of the externalcomponents YAML directive's git source schema,...
CVE-2026-71259
ESPHome (up to 2026.7.0-dev) is affected by an operator-precedence bug in the cv.url() validator within esphome/config_validation.py. The condition if parsed.scheme and parsed.netloc or parsed.scheme == "file" incorrectly permits file:// URIs to bypass validation, affecting the url: field of the ...
CVE-2026-71259 ESPHome external_components file:// Scheme Validation Bypass Leading to Remote Code Execution
ESPHome through 2026.7.0-dev contains an operator-precedence bug in the cv.url validator in esphome/configvalidation.py. Because binds tighter than , any file: URI passes validation regardless of netloc. This validator gates the field of the externalcomponents YAML directive's git source schema,...
CVE-2026-71259
ESPHome through 2026.7.0-dev contains an operator-precedence bug in the cv.url validator in esphome/configvalidation.py. Because binds tighter than , any file: URI passes validation regardless of netloc. This validator gates the field of the externalcomponents YAML directive's git source schema,...
CVE-2026-71259 ESPHome external_components file:// Scheme Validation Bypass Leading to Remote Code Execution
ESPHome through 2026.7.0-dev contains an operator-precedence bug in the cv.url validator in esphome/configvalidation.py. Because binds tighter than , any file: URI passes validation regardless of netloc. This validator gates the field of the externalcomponents YAML directive's git source schema,...
CVE-2026-71259
ESPHome through 2026.7.0-dev contains an operator-precedence bug in the cv.url validator in esphome/configvalidation.py. Because binds tighter than , any file: URI passes validation regardless of netloc. This validator gates the field of the externalcomponents YAML directive's git source schema,...
CVE-2026-16493
A flaw was found in ansible-core. The extractcollectionfromgit function in ansible-core's concreteartifactmanager.py constructs git clone commands without a '--' end-of-options separator before user-supplied URLs when installing collections from git sources. An attacker who provides a crafted...
Arbitrary Argument Injection
Overview Affected versions of this package are vulnerable to Arbitrary Argument Injection through gitSourceHandler.checkoutAsBundle in source/git/bundle.go and getDefaultBranch in source/git/source.go. An attacker can trigger crafted host-side git command arguments by supplying a malicious Git...
CVE-2026-15793
BuildKit custom frontends or clients using the raw low-level API can set git.checkoutbundle=true when checking out Git sources. If the Git source is malicious, this could lead to a crafted command invocation on the host...
PT-2026-61986
Name of the Vulnerable Software and Affected Versions BuildKit affected versions not specified Description Custom frontends or clients utilizing the raw low-level API may set the git.checkoutbundle variable to true during the checkout of Git sources. A malicious Git source can exploit this...
CVE-2025-64424 Colify has command injection vulnerability in project git source
Coolify is an open-source and self-hostable tool for managing servers, applications, and databases. In Coolify versions up to and including v4.0.0-beta.434, a command injection vulnerability exists in the git source input fields of a resource, allowing a low privileged user member to execute syst...
CVE-2025-64424 Colify has command injection vulnerability in project git source
Coolify is an open-source and self-hostable tool for managing servers, applications, and databases. In Coolify versions up to and including v4.0.0-beta.434, a command injection vulnerability exists in the git source input fields of a resource, allowing a low privileged user member to execute syst...
CVE-2025-64424 Colify has command injection vulnerability in project git source
Coolify is an open-source and self-hostable tool for managing servers, applications, and databases. In Coolify versions up to and including v4.0.0-beta.434, a command injection vulnerability exists in the git source input fields of a resource, allowing a low privileged user member to execute syst...
CVE-2025-64424
CVE-2025-64424 affects Coolify up to v4.0.0-beta.434, enabling a low-privileged user to run commands as root via a command-injection in the git source input fields of a resource. Several connected sources corroborate the vulnerability class and affected components; remediation notes indicate fixe...