685 matches found
Geoserver - Server-Side Request Forgery
GeoServer through 2.18.5 and 2.19.x through 2.19.2 allows server-side request forgery via the option for setting a proxy host. id: CVE-2021-40822 info: name: Geoserver - Server-Side Request Forgery author: For3stCo1d,aringo-bf severity: high description: GeoServer through 2.18.5 and 2.19.x throug...
GeoServer Demo Request Endpoint - Server Side Request Forgery
It is possible to achieve Server Side Request Forgery SSRF via the Demo request endpoint if Proxy Base URL has not been set. An unauthenticated user can supply a request that will be issued by the server, allowing enumeration of internal networks and, in the case of cloud instances, access to...
GeoServer - Missing Authorization on REST API Index
GeoServer contains a missing authorization vulnerability that allows unauthorized access to the REST API Index page, potentially exposing sensitive configuration information. id: CVE-2025-27505 info: name: GeoServer - Missing Authorization on REST API Index author: securitytaters severity: medium...
CVE-2023-25157-checker
CVE-2023-25157-checker A script, written in golang. POC for CVE-2023-25157 Steps to use 1. git clone https://github.com/7imbitz/CVE-2023-25157-checker.git 2. cd CVE-2023-25157-checker 3. go run CVE-2023-25157.go Replace with the URL of the target server. Google Dork...
CVE-2023-25157
CVE-2023-25157 This is a simple Python Script to Find the Latest GeoServer SQL Injection Vulnerability. You can use the Scripts on hosts to check for infected path. Installation: 1. git clone https://github.com/0x2458bughunt/CVE-2023-25157/ 2. cd CVE-2023-25157 3. chmod +x geoserver.sh Note: You...
CVE-2024-36401
CVE-2024-36401 GeoServer Exploitation Tool Vulnerability Overview CVE-2024-36401 is a remote command execution vulnerability in GeoServer. An attacker can execute arbitrary commands without authorization by crafting a specific WFS Web Feature Service request. Requirements Python 3.x Install...
CVE-2025-58360
CVE-2025-58360 From version 2.26.0 to before 2.26.2 and before 2.25.6, an XML External Entity XXE vulnerability was identified. The application accepts XML input through a specific endpoint /geoserver/wms operation GetMap Exploit1: python3 CVE-2025-58360 -u http://example.com Exploit2: curl -X PO...
geoserver-
GeoServer CVE-2024-36401 Exploitation Tool GeoServer CVE-2024-36401 Environment: JDK8 Disclaimer: For authorized testing only. The author bears no responsibility for any consequences caused by user misuse. Please comply with laws and regulations! 1. Default payload: POST /geoserver/wfs HTTP/1.1...
Blackash-CVE-2025-58360
🔓 🛰️ 'CVE-2025-58360' GeoServer WMS Endpoint Vulnerable to XXE Attack 🌟 🏷️ Basic Information CVE ID : CVE-2025-58360 Published : 📅 November 25, 2025 Last Modified : 📅 November 25, 2025 still fresh as of Nov 26 Vulnerability Type : XML External Entity XXE – CWE-611 Affected Software : GeoServer...
CVE-2024-36401_Geoserver_RCE_POC
Here is the English translation of your README file: ⚠️ Disclaimer: This tool is intended solely for security research and legally authorized testing purposes. Do not use it for any illegal or unauthorized activities. The user assumes full responsibility for any legal consequences. README Version:...
CVE-2023-25157
CVE-2023-25157 GeoServer OGC Filter SQL Injection Vulnerabilities...
CVE-2023-25157-GeoServer-SQLi-Lab
GeoServer & GeoTools SQL Injection CVE-2023-25157 & CVE-2023-25158 — Vulnerability Lab & PoC Report Practical environment Vulnerable Lab and detailed exploitation analysis report for SQL Injection Error-based vulnerability in GeoServer CVE-2023-25157 and the GeoTools library CVE-2023-25158...
CVE-2024-36401
CVE-2024-36401: GeoServer Unauthenticated Remote Code Execution Exploiter a Vulnerability detection and Exploitation tool for GeoServer Unauthenticated Remote Code Execution CVE-2024-36401. Installation git clone https://github.com/RevoltSecurities/CVE-2024-36401.git cd CVE-2024-34102 pip install...
CVE-2023-25157
Vulnerability Description Due to the lack of input filtering, remote unauthenticated attackers can craft malformed filter syntax, bypass GeoServer's lexical parsing, leading to SQL injection, obtaining sensitive information from the server, and possibly gaining database server privileges. Affecte...
CVE-2024-36401
CVE-2024-36401 Remote Code Execution RCE Vulnerability In Evaluating Property Name Expressions GeoServer is an open source server that allows users to share and edit geospatial data. Prior to versions 2.23.6, 2.24.4, and 2.25.2, multiple OGC request parameters allow Remote Code Execution RCE by...
GeoServer jsonArrayContains CQL Filter - SQL Injection
GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. GeoTools FilterToSqlHelper.constructEquality writes the expected argument of the jsonArrayContains CQL function RAW into the SQL string while only escaping the JSON pointer. A single...
GeoServer WFS - XXE Processing Vulnerability
GeoServer Web Feature Service WFS is vulnerable to an XML External Entity XXE processing attack due to improper handling of XML input. This vulnerability allows attackers to perform Out-of-Band OOB data exfiltration and Server-Side Request Forgery SSRF by exploiting the GeoTools library. id:...
GeoServer OGC Filter - SQL Injection
GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. GeoServer includes support for the OGC Filter expression language and the OGC Common Query Language CQL as part of the Web Feature Service WFS and Web Map Service WMS protocols. CQL is...
CVE-2025-58360
CVE-2025-58360 The vulnerability in question is CVE-2025-58360 CVSS score: 8.2, an unauthenticated XML External Entity XXE flaw that affects all versions prior to and including 2.25.5, and from versions 2.26.0 through 2.26.1. It has been patched in versions 2.25.6, 2.26.2, 2.27.0, 2.28.0, and...
CVE-2023-51444
This README helps you getting started with GeoServer development. It will guide you through the process of checking out the source code, compiling it, and running. GeoServer Development requires Java 8, Maven, and git. Due to subtle changes in Java class libraries we require development on Java 8...