80 matches found
Path Traversal
Apache Jena Fuseki is vulnerable to Path Traversal. The vulnerability is due to insufficient validation of file paths, where the server fails to properly restrict directory traversal in request handling and attackers can craft malicious ../ sequences to read arbitrary files on the system...
io.github.sparql-anything:sparql-anything-fuseki (>=1.2.0-rc1, <=1.3.0-rc2), io.telicent.jena.graphql:graphql-fuseki-module (>=0.11.0, <=0.12.2) +18 more potentially affected by CVE-2026-61372 via org.apache.jena:jena-fuseki-main (>=6.0.0, <=6.1.0)
org.apache.jena:jena-fuseki-main MAVEN version =6.0.0, =1.2.0-rc1, =0.11.0, =3.0.0, =2.0.0, =2.0.0, =2.0.0, =0.93.1, =0.93.1, =1.0.0, =1.0.0, =1.0.0, =1.0.0, =1.0.0, =1.0.0, =1.0.5 and more Source cves: CVE-2026-61372 Source advisory: SNYK:JAVA-ORGAPACHEJENA-19432165...
Directory Traversal
Overview org.apache.jena:jena-fuseki is a Fuseki is a SPARQL 1.1 Server which provides the SPARQL query, SPARQL update and SPARQL graph store protocols. Affected versions of this package are vulnerable to Directory Traversal via the SPARQL Update. An attacker can access files outside of the...
CVE-2026-61372
Improper Limitation of a Pathname to a Restricted Directory 'Path Traversal' vulnerability in Apache Jena Fuseki. This issue affects Apache Jena Fuseki: through 6.1.0. Users are recommended to upgrade to version 6.2.0, which fixes the issue...
CVE-2026-61372
Improper Limitation of a Pathname to a Restricted Directory 'Path Traversal' vulnerability in Apache Jena Fuseki. This issue affects Apache Jena Fuseki: through 6.1.0. Users are recommended to upgrade to version 6.2.0, which fixes the issue...
UBUNTU-CVE-2026-61372
Improper Limitation of a Pathname to a Restricted Directory 'Path Traversal' vulnerability in Apache Jena Fuseki. This issue affects Apache Jena Fuseki: through 6.1.0. Users are recommended to upgrade to version 6.2.0, which fixes the issue...
fr.inria.rules:integraal-all (>=3.1.1-rc6, <=3.2.4), fr.inria.rules:integraal-api (>=3.1.1-rc6, <=3.2.4) +77 more potentially affected by CVE-2026-61372 via org.apache.jena:jena-fuseki-core (>=2.0.0, <=6.1.0)
org.apache.jena:jena-fuseki-core MAVEN version =2.0.0, =3.1.1-rc6, =3.1.1-rc6, =3.1.1-rc6, =3.1.1-rc6, =3.1.1-rc6, =3.2.3, =3.1.1-rc6, =3.1.1-rc6, =3.1.1-rc6, =3.1.1-rc6, =3.1.1-rc6, =3.1.1-rc6, =3.1.1-rc6, =2.0.1, =2.0.1, =2.0.7 and more Source cves: CVE-2026-61372 Source advisory:...
CVE-2026-61372
Improper Limitation of a Pathname to a Restricted Directory 'Path Traversal' vulnerability in Apache Jena Fuseki. This issue affects Apache Jena Fuseki: through 6.1.0. Users are recommended to upgrade to version 6.2.0, which fixes the issue...
CVE-2026-61372
Improper Limitation of a Pathname to a Restricted Directory 'Path Traversal' vulnerability in Apache Jena Fuseki. This issue affects Apache Jena Fuseki: through 6.1.0. Users are recommended to upgrade to version 6.2.0, which fixes the issue...
CVE-2026-61372 Apache Jena Fuseki: Web requests using SPARQL Update can escape file restrictions
Improper Limitation of a Pathname to a Restricted Directory 'Path Traversal' vulnerability in Apache Jena Fuseki. This issue affects Apache Jena Fuseki: through 6.1.0. Users are recommended to upgrade to version 6.2.0, which fixes the issue...
CVE-2026-61372
Apache Jena Fuseki is vulnerable to a Path Traversal (Directory Traversal) vulnerability in versions through 6.1.0 . An attacker can exploit the SPARQL Update functionality by crafting malicious web requests using "dot-dot-slash" (../) sequences or absolute file paths. This allows unauthorized ac...
CVE-2026-61372 Apache Jena Fuseki: Web requests using SPARQL Update can escape file restrictions
Improper Limitation of a Pathname to a Restricted Directory 'Path Traversal' vulnerability in Apache Jena Fuseki. This issue affects Apache Jena Fuseki: through 6.1.0. Users are recommended to upgrade to version 6.2.0, which fixes the issue...
CVE-2026-61372 Apache Jena Fuseki: Web requests using SPARQL Update can escape file restrictions
Improper Limitation of a Pathname to a Restricted Directory 'Path Traversal' vulnerability in Apache Jena Fuseki. This issue affects Apache Jena Fuseki: through 6.1.0. Users are recommended to upgrade to version 6.2.0, which fixes the issue...
fr.inria.rules:integraal-all (>=3.1.1-rc6, <=3.2.4), fr.inria.rules:integraal-api (>=3.1.1-rc6, <=3.2.4) +57 more potentially affected by CVE-2026-61372 via org.apache.jena:jena-fuseki-main (>=3.9.0, <=6.1.0)
org.apache.jena:jena-fuseki-main MAVEN version =3.9.0, =3.1.1-rc6, =3.1.1-rc6, =3.1.1-rc6, =3.1.1-rc6, =3.1.1-rc6, =3.2.3, =3.1.1-rc6, =3.1.1-rc6, =3.1.1-rc6, =3.1.1-rc6, =3.1.1-rc6, =3.1.1-rc6, =3.1.1-rc6, =2.0.1, =2.0.1, =2.0.7 and more Source cves: CVE-2026-61372 Source advisory:...
EUVD-2026-52338
Improper Limitation of a Pathname to a Restricted Directory 'Path Traversal' vulnerability in Apache Jena Fuseki. This issue affects Apache Jena Fuseki: through 6.1.0. Users are recommended to upgrade to version 6.2.0, which fixes the issue...
PT-2026-67438
Improper Limitation of a Pathname to a Restricted Directory 'Path Traversal' vulnerability in Apache Jena Fuseki. This issue affects Apache Jena Fuseki: through 6.1.0. Users are recommended to upgrade to version 6.2.0, which fixes the issue...
CVE-2026-61372: Improper Limitation of a Pathname to a Restricted Directory
Improper Limitation of a Pathname to a Restricted Directory 'Path Traversal' vulnerability in Apache Jena Fuseki. This issue affects Apache Jena Fuseki: through 6.1.0. Users are recommended to upgrade to version 6.2.0, which fixes the issue...
Linux Distros Unpatched Vulnerability : CVE-2026-61372
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - Improper Limitation of a Pathname to a Restricted Directory 'Path Traversal' vulnerability in Apache Jena Fuseki. This issue affects Apache Jena Fuseki: through...
GHSA-2FVJ-HGJ9-J2GR vulnerabilities
Vulnerabilities for packages: kafka, traccar, trino, neo4j, jenkins, spark-kubernetes-operator-fips, confluent-kafka, solr-fips, tez, apache-tika-fips, reposilite, kafka-fips, akhq, spark-fips, apache-hop-fips, traccar-fips, spark, apache-tika, automq-fips, strimzi-kafka-operator-fips,...
CVE-2026-10050 vulnerabilities
Vulnerabilities for packages: kafka, traccar, trino, neo4j, jenkins, spark-kubernetes-operator-fips, confluent-kafka, solr-fips, tez, apache-tika-fips, reposilite, kafka-fips, akhq, spark-fips, apache-hop-fips, traccar-fips, spark, apache-tika, automq-fips, strimzi-kafka-operator-fips,...