22568 matches found
GHSA-C6MW-8XH8-GPQ6 CodeWhale: Argument Injection in `git_blame` Tool Allows Arbitrary File Read Without Approval
Maintainer resolution The CodeWhale maintainers validated this report. The affected package ranges are recorded in the advisory metadata. Version 0.8.64 contains the fix in commit 9a34b5034d29f05d1f28fa61b04719ca6a741020. Users should upgrade to 0.8.64 or later. The original reporter analysis is...
NPM: CodeWhale: Argument Injection in `git_blame` Tool Allows Arbitrary File Read Without Approval
NPM: CodeWhale: Argument Injection in gitblame Tool Allows Arbitrary File Read Without Approval vulnerability discovered by ? in WordPress Npm deepseek-tui versions = 0.3.27, 0.8.41...
CodeWhale: Argument Injection in `git_blame` Tool Allows Arbitrary File Read Without Approval
Maintainer resolution The CodeWhale maintainers validated this report. The affected package ranges are recorded in the advisory metadata. Version 0.8.64 contains the fix in commit 9a34b5034d29f05d1f28fa61b04719ca6a741020. Users should upgrade to 0.8.64 or later. The original reporter analysis is...
NPM: CodeWhale: Project config `instructions` override enables arbitrary file read into AI system prompt via cloned repository
NPM: CodeWhale: Project config instructions override enables arbitrary file read into AI system prompt via cloned repository vulnerability discovered by ? in WordPress Npm deepseek-tui versions = 0.8.8, 0.8.41...
NPM: CodeWhale: Project config `instructions` override enables arbitrary file read into AI system prompt via cloned repository
NPM: CodeWhale: Project config instructions override enables arbitrary file read into AI system prompt via cloned repository vulnerability discovered by ? in WordPress Npm codewhale versions = 0.8.41, 0.8.64...
CodeWhale: Project config `instructions` override enables arbitrary file read into AI system prompt via cloned repository
Maintainer resolution The CodeWhale maintainers validated this report. The affected package ranges are recorded in the advisory metadata. Version 0.8.64 contains the fix in commit 43563356b98c6b993085554da82e77370160a31c. Users should upgrade to 0.8.64 or later. The original reporter analysis is...
EUVD-2026-60966
CodeWhale: Project config instructions override enables arbitrary file read into AI system prompt via cloned repository...
GHSA-62F5-CP2P-VQ95 CodeWhale: Project config `instructions` override enables arbitrary file read into AI system prompt via cloned repository
Maintainer resolution The CodeWhale maintainers validated this report. The affected package ranges are recorded in the advisory metadata. Version 0.8.64 contains the fix in commit 43563356b98c6b993085554da82e77370160a31c. Users should upgrade to 0.8.64 or later. The original reporter analysis is...
CVE-2026-17621
IBM Langflow OSS 1.0.0 through 1.10.2 could allow a remote attacker to traverse directories on the system. An attacker could send a specially crafted URL request containing "dot dot " sequences /.. / to view arbitrary files on the system...
CVE-2026-14470
IBM Langflow OSS 1.0.0 through 1.10.2 could allow an authenticated attacker to traverse directories on the system. An attacker could send a specially crafted URL request containing "dot dot" sequences /../ to view arbitrary files on the system...
CVE-2026-14470
IBM Langflow OSS versions 1.0.0 through 1.10.2 is vulnerable to a path traversal flaw (CWE-22) in its file and knowledge base components. An authenticated attacker can send a crafted URL request containing ../ sequences to read arbitrary files on the system. Per the IBM security bulletin, in the ...
CVE-2026-14470 Langflow OSS is affected by arbitrary file read due to path traversal vulnerabilities in file and knowledge base components
IBM Langflow OSS 1.0.0 through 1.10.2 could allow an authenticated attacker to traverse directories on the system. An attacker could send a specially crafted URL request containing "dot dot" sequences /../ to view arbitrary files on the system...
EUVD-2026-71491
IBM Langflow OSS 1.0.0 through 1.10.2 could allow an authenticated attacker to traverse directories on the system. An attacker could send a specially crafted URL request containing "dot dot" sequences /../ to view arbitrary files on the system...
CVE-2026-14470 Langflow OSS is affected by arbitrary file read due to path traversal vulnerabilities in file and knowledge base components
IBM Langflow OSS 1.0.0 through 1.10.2 could allow an authenticated attacker to traverse directories on the system. An attacker could send a specially crafted URL request containing "dot dot" sequences /../ to view arbitrary files on the system...
CVE-2026-17621 Langflow OSS is affected by arbitrary file read due to path traversal vulnerabilities in file and knowledge base components
IBM Langflow OSS 1.0.0 through 1.10.2 could allow a remote attacker to traverse directories on the system. An attacker could send a specially crafted URL request containing "dot dot " sequences /.. / to view arbitrary files on the system...
CVE-2026-17621
IBM Langflow OSS versions 1.0.0 through 1.10.2 are affected by a path traversal vulnerability (CWE-22) in its file and knowledge base components. The root cause involves user-supplied path values not being validated against /../ sequences in the Directory component, the Knowledge Base connector i...
CVE-2026-17621 Langflow OSS is affected by arbitrary file read due to path traversal vulnerabilities in file and knowledge base components
IBM Langflow OSS 1.0.0 through 1.10.2 could allow a remote attacker to traverse directories on the system. An attacker could send a specially crafted URL request containing "dot dot " sequences /.. / to view arbitrary files on the system...
EUVD-2026-71464
IBM Langflow OSS 1.0.0 through 1.10.2 could allow a remote attacker to traverse directories on the system. An attacker could send a specially crafted URL request containing "dot dot " sequences /.. / to view arbitrary files on the system...
CVE-2026-17622 Langflow OSS is affected by arbitrary file read due to path traversal vulnerabilities in file and knowledge base components
IBM Langflow OSS 1.0.0 through 1.10.2 could allow a remote authenticated attacker to obtain sensitive information due to improper limitation of a pathname to a restricted directory...
CVE-2026-17622
IBM Langflow OSS versions 1.0.0 through 1.10.2 are affected by path traversal (CWE-22) vulnerabilities across three components: the Directory component, the Knowledge Base connector ingestion endpoint, and the Knowledge Base flow component. In the Directory component, user-supplied paths are not ...