4230 matches found
CVE-2026-112908
A flaw was found in filelock. When creating strict file locks on POSIX-compliant systems, coordination and claim directories are created without applying the caller's restrictive file permission settings. In environments with permissive file creation masks or default access control lists ACLs, a...
linux-basics-for-hackers-notes
Linux Basics for Hackers — Course A structured course built from personal study notes of the book Linux Basics for Hackers by OccupyTheWeb. Each module breaks down the core concepts, commands, and practical examples in plain English — straightforward enough for beginners, detailed enough to...
cockpit-files: cockpit-files: Arbitrary file ownership and permission modification via symlink race condition
A flaw was found in cockpit-files. This vulnerability allows a local attacker to exploit a timing issue, known as a symlink race condition, during privileged file operations such as changing file ownership or permissions. By manipulating directory entries and winning this race, the attacker can...
CVE-2026-63499
The zt-zip Java library (prior to version 1.18.1 ) contains a vulnerability in ZipUtil.unpack(...) where an attacker can manipulate directory permissions. Because path traversal checks allow self-referencing entries like / or ./, an attacker can craft a ZIP archive that causes the unpacker to app...
CVE-2023-46870
CVE-2023-46870 Nordic Semiconductor nRF Sniffer for Bluetooth LE versions 3.0.0, 3.1.0, 4.0.0, 4.1.0, and 4.1.1 have incorrect file permissions set, which allows adversaries to perform privilege escalation and code execution by modifying bash and python scripts. Keywords: Local Privilege Escalati...
CVE-2025-27581
CVE-2025-27581 Exploit scripts for CVE-2025-27581 BasicExploit.sh This just points the exploit to a file of your choice, it should set your target file to 0666 permissions but it can fail on certain files depending on applocker policies or selinux. CreateFakeRoot.sh This points the exploit to...
CVE-2021-4034
CVE-2021-4034 Exploit Usage $ git clone https://github.com/Anonymous-Family/CVE-2021-4034.git $ cd CVE-2021-4034 $ make ! CVE-2021-4034 Exploit By whokilleddb ! Initializing Setup + Setup Done :D ! Setting Root Privileges ! Launching Root Shell /bin/whoami root Rough Patch chmod 0755 which pkexec...
CVE-2025-2502
Discovered by chance while learning about local privilege escalation. In any version of Lenovo PC Manager, the tools in Lenovo PC Manager have permission flaws. Any downloaded tool grants ordinary users F full control permissions. Since tools in all versions have permission issues, ordinary users...
CVE-2022-0847-Docker
Dirty Pipe CVE-2022-0847: A Hands-On Exploit Demonstration in Docker This repository provides a self-contained, interactive Docker environment to safely demonstrate and analyze the "Dirty Pipe" privilege escalation vulnerability. It is designed as an educational tool for security professionals to...
ansible-mysql-cve-2016-6662
ansible-mysql-cve-2016-6662 Simple ansible playbook to patch mysql servers against CVE-2016-6662. UPDATE 20160915.2347.CEST: Kenny informed me of Patrick Forsberg's catch that the original patch did not safeguard against ../ abuse. I've now replaced the patch with one that is more stringent based...
CVE-2022-3328
CVE-2022-3328 CVE-2022-3328 with CVE-2022-41974 and CVE-2022-41973 from: https://www.qualys.com/2022/11/30/cve-2022-3328/advisory-snap.txt https://blog.qualys.com/vulnerabilities-threat-research/2022/11/30/race-condition-in-snap-confines-mustmkdirandopenwithperms-cve-2022-3328...
Mohnad-AL-saif-CVE-2020-11107-XAMPP-Local-Privilege-Escalation
🧨 CVE-2020-11107 – XAMPP Local Privilege Escalation Windows 📌 Overview CVE-2020-11107 is a Local Privilege Escalation LPE vulnerability affecting Apache Friends XAMPP on Windows. An unprivileged user can modify the XAMPP Control Panel configuration file xampp-control.ini and replace the default...
CLEANSTART-2024-XL27484 flaw was found in the way samba handled file and directory permissions
Security vulnerability affects the samba package. A flaw was found in the way samba handled file and directory permissions...
CVE-2022-0997
Fidelis Network and Deception - CVE-2022-0997 - Insecure File Permissions Privilege Escalation Releasability and Acknowledgements The exploit was approved for public release by the United States Government. Special thanks to the servicemen and government liaisons tasked with approving the...
CVE-2026-85300
CVE-2026-85300 — camel-pqc: private key written with permissive file permissions Runnable proof-of-concept reproducer for the Apache Camel vulnerability where camel-pqc's FileBasedKeyLifecycleManager wrote generated key material to disk with the permissions the process default umask produced ,...
CVE-2022-0486
Fidelis Network and Deception - CVE-2022-0486 - Insecure File Permissions Privilege Escalation - Multiple Releasability and Acknowledgements All exploits were approved for public release by the United States Government. Special thanks to the servicemen and government liaisons tasked with approvin...
CVE-2025-57392
CVE-2025-57392 🔒 Security Vulnerability Report Product: BenimPOS Desktop V3.0 Vulnerability Type: Insecure File Permissions Affected Components: BenimPOS.exe, unins000.exe, System.Data.SQLite.dll Vulnerability Class: CWE-276: Incorrect Default Permissions Proof of Concept by: Fatih Bülbül Test...
Medium: awscli
Issue Overview: Overly permissive file permissions in AWS CLI before 1.44.78 v1 and 2.34.29 v2 on Unix-like systems where the umask has not been configured to restrict file permissions the default on most systems may allow other local users on the same host to read credentials written by certain...
Amazon Linux 2 : awscli (ALASAWSCLI1-2026-002)
The version of awscli installed on the remote host is prior to 1.27.51-1. It is, therefore, affected by a vulnerability as referenced in the ALAS2AWSCLI1-2026-002 advisory. Overly permissive file permissions in AWS CLI before 1.44.78 v1 and 2.34.29 v2 on Unix-like systems where the umask has not...
Amazon Linux 2 : awscli (ALAS-2026-4052)
The version of awscli installed on the remote host is prior to 1.18.147-1. It is, therefore, affected by a vulnerability as referenced in the ALAS2-2026-4052 advisory. Overly permissive file permissions in AWS CLI before 1.44.78 v1 and 2.34.29 v2 on Unix-like systems where the umask has not been...