12940 matches found
CVE-2024-52304 aiohttp vulnerable to request smuggling due to incorrect parsing of chunk extensions
aiohttp is an asynchronous HTTP client/server framework for asyncio and Python. Prior to version 3.10.11, the Python parser parses newlines in chunk extensions incorrectly which can lead to request smuggling vulnerabilities under certain conditions. If a pure Python version of aiohttp is installe...
WordPress Extensions for Elementor plugin <= 2.0.40 - Reflected Cross Site Scripting (XSS) vulnerability
Reflected Cross Site Scripting XSS vulnerability discovered by Le Ngoc Anh Patchstack Alliance in WordPress Plugin Extensions for Elementor versions = 2.0.40...
CVE-2024-52304: Inconsistent Interpretation of HTTP Requests
aiohttp is an asynchronous HTTP client/server framework for asyncio and Python. Prior to version 3.10.11, the Python parser parses newlines in chunk extensions incorrectly which can lead to request smuggling vulnerabilities under certain conditions. If a pure Python version of aiohttp is installe...
WordPress Extensions for Elementor Plugin <= 2.0.40 is vulnerable to Cross Site Scripting (XSS)
Software Extensions for Elementor Type Plugin Vulnerable versions = 2.0.40 Fixed in N/A OWASP Top 10 A3: Injection Classification Cross Site Scripting XSS CVE CVE-2024-52471 Patch priority Medium CVSS severity Medium 7.1 Developer Claim ownership PSID 37895dfd43f1 Credits Le Ngoc Anh Required...
[SECURITY] Fedora 41 Update: php-bartlett-PHP-CompatInfo-7.1.4-3.fc41
PHPCompatInfo will parse a file/folder/array to find out the minimum version and extensions required for it to run. CLI version has many reports extension, interface, class, function, constant to display and ability to show content of dictionary references...
[SECURITY] Fedora 40 Update: php-bartlett-PHP-CompatInfo-7.1.4-3.fc40
PHPCompatInfo will parse a file/folder/array to find out the minimum version and extensions required for it to run. CLI version has many reports extension, interface, class, function, constant to display and ability to show content of dictionary references...
[SECURITY] Fedora 39 Update: php-bartlett-PHP-CompatInfo-7.1.4-3.fc39
PHPCompatInfo will parse a file/folder/array to find out the minimum version and extensions required for it to run. CLI version has many reports extension, interface, class, function, constant to display and ability to show content of dictionary references...
PT-2025-35799
Name of the Vulnerable Software and Affected Versions Google Chrome versions prior to 140.0.7339.80 Description An inappropriate implementation in Extensions in Google Chrome allows a remote attacker to bypass the content security policy via a crafted HTML page. Recommendations Update Google Chro...
Malicious code in rn-i18n-extensions (npm)
--- -= Per source details. Do not edit below this line.=- Source: ghsa-malware ec389a5953658ea1bda762a714a07855e1761843aef44b99159036fe37c81523 Any computer that has this package installed or running should be considered fully compromised. All secrets and keys stored on that computer should be...
MAL-2024-10781 Malicious code in rn-i18n-extensions (npm)
--- -= Per source details. Do not edit below this line.=- Source: ghsa-malware ec389a5953658ea1bda762a714a07855e1761843aef44b99159036fe37c81523 Any computer that has this package installed or running should be considered fully compromised. All secrets and keys stored on that computer should be...
SUSE CVE-2024-21820
Incorrect default permissions in some IntelR XeonR processor memory controller configurations when using IntelR SGX may allow a privileged user to potentially enable escalation of privilege via local access...
SUSE CVE-2024-23918
Improper conditions check in some IntelR XeonR processor memory controller configurations when using IntelR SGX may allow a privileged user to potentially enable escalation of privilege via local access...
org.jenkins-ci.plugins:pipeline-graph-analysis (>=1.7, <=1.9), org.jenkinsci.plugins:pipeline-model-definition (>=1.2.5, <=1.2.7) +1 more potentially affected by CVE-2024-52550 via org.jenkins-ci.plugins.workflow:workflow-cps (2.41)
org.jenkins-ci.plugins.workflow:workflow-cps MAVEN version 2.41 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.plugins.workflow:workflow-cps and may be impacted: - org.jenkins-ci.plugins:pipeline-graph-analysis =1.7, =1.2.5, =1.2.5,...
org.jenkinsci.plugins:pipeline-model-definition (>=1.1.5, <=1.2-beta-3), org.jenkinsci.plugins:pipeline-model-extensions (>=1.1.5, <=1.2-beta-3) potentially affected by CVE-2024-52550 via org.jenkins-ci.plugins.workflow:workflow-cps (2.33)
org.jenkins-ci.plugins.workflow:workflow-cps MAVEN version 2.33 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.plugins.workflow:workflow-cps and may be impacted: - org.jenkinsci.plugins:pipeline-model-definition =1.1.5, =1.1.5,...
io.jenkins.blueocean:blueocean (>=1.0.0-b25, <=1.1.0-beta-9), io.jenkins.blueocean:blueocean-dashboard (>=1.0.0-b25, <=1.0.1) +11 more potentially affected by CVE-2024-52550 via org.jenkins-ci.plugins.workflow:workflow-cps (2.29)
org.jenkins-ci.plugins.workflow:workflow-cps MAVEN version 2.29 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.plugins.workflow:workflow-cps and may be impacted: - io.jenkins.blueocean:blueocean =1.0.0-b25, =1.0.0-b25, =1.0.0-b25,...
org.jenkins-ci.plugins.workflow:workflow-cps (>=2.40, <=2.41), org.jenkins-ci.plugins:claim (>=2.10, <=2.15) +3 more potentially affected by CVE-2024-52549 via org.jenkins-ci.plugins:script-security (1.34)
org.jenkins-ci.plugins:script-security MAVEN version 1.34 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.plugins:script-security and may be impacted: - org.jenkins-ci.plugins.workflow:workflow-cps =2.40, =2.10, =1.7, =1.2.5, =1.2.5,...
io.jenkins.plugins:opentelemetry (3.1391.vcb_a_a_b_9779d75), org.jenkinsci.plugins:pipeline-model-definition (2.2214.vb_b_34b_2ea_9b_83) +1 more potentially affected by CVE-2024-52550 via org.jenkins-ci.plugins.workflow:workflow-cps (3953.v19f11da_8d2fa)
org.jenkins-ci.plugins.workflow:workflow-cps MAVEN version 3953.v19f11da8d2fa is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.plugins.workflow:workflow-cps and may be impacted: - io.jenkins.plugins:opentelemetry 3.1391.vcbaab9779d75 -...
ALPINE-CVE-2024-23918
Improper conditions check in some IntelR XeonR processor memory controller configurations when using IntelR SGX may allow a privileged user to potentially enable escalation of privilege via local access...
DEBIAN-CVE-2024-23918
Improper conditions check in some IntelR XeonR processor memory controller configurations when using IntelR SGX may allow a privileged user to potentially enable escalation of privilege via local access...
UBUNTU-CVE-2024-23918
Improper conditions check in some IntelR XeonR processor memory controller configurations when using IntelR SGX may allow a privileged user to potentially enable escalation of privilege via local access...