13410 matches found
Elasticsearch 8.19.22, 9.4.8, and 9.5.5 Security Update (ESA-2026-189)
Inefficient Regular Expression Complexity in Elasticsearch Leading to Denial of Service Inefficient Regular Expression Complexity CWE-1333 in Elasticsearch can lead to denial of service via Regular Expression Exponential Blowup CAPEC-492. The ES|QL CHUNK function's recursive chunking strategy...
Exploit for Improper Handling of Exceptional Conditions in Apache Struts
Struts Patch-Gap Auditor A small Python tool that finds Apach...
[SECURITY] Fedora 45 Update: ocaml-re-1.14.0-7.fc45
A pure OCaml regular expression library. Supports Perl-style regular expressions, Posix extended regular expressions, Emacs-style regular expressions, and shell-style file globbing. It is also possible to build regular expressions by combining simpler regular expressions. There is also a subset o...
Linux Distros Unpatched Vulnerability : CVE-2026-104711
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - Improper neutralization of special elements used in an expression language statement 'Expression Language Injection' vulnerability in Apache Struts. If the...
CVE-2026-102408: Inefficient Regular Expression Complexity
Inefficient Regular Expression Complexity CWE-1333 in Elasticsearch can lead to denial of service via Regular Expression Exponential Blowup CAPEC-492. The ES|QL CHUNK function's recursive chunking strategy accepts a list of user-supplied regular expressions used as text-splitting separators,...
CVE-2026-104711
Apache Struts has an OGNL expression-injection vulnerability in the legacy RESTful action mapper. A crafted request to an application configured to use this mapper may lead to remote code execution. Applications using the default action mapper, the restful2 mapper, or the Struts REST plugin are n...
Improper Neutralization of Special Elements used in an Expression Language Statement ('Expression Language Injection')
Overview org.apache.struts:struts2-core is a popular open-source framework for developing web applications in the Java programming language. Affected versions of this package are vulnerable to Improper Neutralization of Special Elements used in an Expression Language Statement 'Expression Languag...
Security Bulletin: Due to the use of Spring Expression Language (SpEL), IBM Sterling Control Center is vulnerable to Uncontrolled Resource Consumption (CVE-2026-47886)
Summary Spring Expression Language SpEL is used by IBM Sterling Control Center as part of dependency in spring-expression-6.2.12.jar. Vulnerability Details CVEID:CVE-2026-47886 DESCRIPTION: Applications that evaluate user-supplied Spring Expression Language SpEL expressions may be vulnerable to a...
CVE-2026-104711
Improper neutralization of special elements used in an expression language statement 'Expression Language Injection' vulnerability in Apache Struts. If the application is configured to use the legacy RESTful action mapper, a crafted request can inject an OGNL expression that may lead to remote co...
CVE-2026-105646 Ghost: Regular Expression Denial of Service in Content Import
Ghost is a Node.js content management system. From 4.0.0 until 6.67.0, a crafted content import file could cause excessive CPU usage, making the Ghost server unresponsive. Exploiting this requires Administrator access. This issue is fixed in version 6.67.0...
CVE-2026-105646
The Ghost Node.js content management system is vulnerable to a Regular Expression Denial of Service (ReDoS) in its content import functionality. Specifically, versions 4.0.0 through 6.67.0 allow a crafted content import file to cause excessive CPU usage , potentially rendering the server unrespon...
CVE-2026-105645 Ghost: Regular Expression Denial of Service in External Media Inliner
Ghost is a Node.js content management system. From 5.37.0 until 6.67.0, a crafted request to the external media inliner could cause excessive CPU usage, making the Ghost server unresponsive. Exploiting this requires Administrator access. This issue is fixed in version 6.67.0...
CVE-2026-105645
The Ghost Node.js content management system is vulnerable to a Regular Expression Denial of Service (ReDoS) in its external media inliner component. Versions from 5.37.0 until 6.67.0 are affected, where a crafted request can trigger excessive CPU usage, leading to server unresponsiveness. Exploit...
CVE-2026-105645 Ghost: Regular Expression Denial of Service in External Media Inliner
Ghost is a Node.js content management system. From 5.37.0 until 6.67.0, a crafted request to the external media inliner could cause excessive CPU usage, making the Ghost server unresponsive. Exploiting this requires Administrator access. This issue is fixed in version 6.67.0...
EUVD-2026-92622
Improper neutralization of special elements used in an expression language statement 'Expression Language Injection' vulnerability in Apache Struts. If the application is configured to use the legacy RESTful action mapper, a crafted request can inject an OGNL expression that may lead to remote co...
CVE-2026-104711
Improper neutralization of special elements used in an expression language statement 'Expression Language Injection' vulnerability in Apache Struts. If the application is configured to use the legacy RESTful action mapper, a crafted request can inject an OGNL expression that may lead to remote co...
GeoServer-CVE-2024-36401
GeoServer-CVE-2024-36401 GeoServer CVE-2024-36401: Remote Code Execution RCE Vulnerability In Evaluating Property Name Expressions GetPropertyValue POST /geoserver/wfs HTTP/1.1 Host: PunitDarji Content-Type: application/xml User-Agent: Mozilla/5.0 Windows NT 10.0; Win64; x64 AppleWebKit/537.36...
Astra Linux – Vulnerability in node-minimatch
Minimatch is a minimal matching utility for converting glob expressions into JavaScript RegExp objects. Versions 10.2.0 and earlier are vulnerable to Regular Expression Denial of Service ReDoS when a glob pattern contains many consecutive wildcards followed by a literal character that does not...
Astra Linux – Vulnerability in Ruby 2.5
In the date gem for Ruby, from version 3.2.0 onwards, Date.parse can cause ReDoS Regular Expression Denial of Service attacks due to the use of a long string. The fixed versions are 3.2.1, 3.1.2, 3.0.2, and 2.0.1...
Astra Linux – Vulnerability in pillow
Packages with version numbers 5.2.0 and earlier, as well as 8.3.2, are vulnerable to Regular Expression Denial of Service ReDoS attacks through the getrgb function...