13192 matches found
Moderate: Red Hat Security Advisory: jackson-core security update
An update for jackson-core is now available for Red Hat Enterprise Linux 9. Red Hat Product Security has rated this update as having a security impact of Moderate. A Common Vulnerability Scoring System CVSS base score, which gives a detailed severity rating, is available for each vulnerability fr...
CVE-2026-114117
Vyper 0.3.8 through 0.5.0b1 contains an optimizer miscompilation in which msg.value | K or lenmsg.data | K, where K is any nonzero integer literal, is compiled to the constant 1 when used as a ternary expression branch under -O gas the default or -O codesize. Affected contracts use the wrong valu...
EUVD-2026-106920
Vyper 0.3.8 through 0.5.0b1 contains an optimizer miscompilation in which msg.value | K or lenmsg.data | K, where K is any nonzero integer literal, is compiled to the constant 1 when used as a ternary expression branch under -O gas the default or -O codesize. Affected contracts use the wrong valu...
PT-2026-120243
Vyper 0.3.8 through 0.5.0b1 contains an optimizer miscompilation in which msg.value | K or lenmsg.data | K, where K is any nonzero integer literal, is compiled to the constant 1 when used as a ternary expression branch under -O gas the default or -O codesize. Affected contracts use the wrong valu...
ALSA-2026:86706 Moderate: jackson-core security update
Core part of Jackson that defines Streaming API as well as basic shared abstractions. Security Fixes: com.fasterxml.jackson/jackson-core: tools.jackson.core/jackson-core: Jackson-core: Denial of Service via regular expression backtracking CVE-2026-89407 com.fasterxml.jackson.core/jackson-core:...
GitLab 7.0 < 18.11.13 / 19.0 < 19.0.10 / 19.1 < 19.1.9 / 19.2 < 19.2.9 / 19.3 < 19.3.6 / 19.4 < 19.4.3 / 19.5 < 19.5.1 (CVE-2026-110264)
The version of GitLab installed on the remote host is affected by a vulnerability, as follows: - An issue has been discovered in GitLab CE/EE affecting all versions from 7.0 before 18.11.13, 19.0 before 19.0.10, 19.1 before 19.1.9, 19.2 before 19.2.9, 19.3 before 19.3.6, 19.4 before 19.4.3, and...
SUSE CVE-2026-112300
A vulnerability was identified in DiffSK configobj up to 5.0.9. Affected by this vulnerability is the function sectionmarker of the file configobj/init.py. The manipulation leads to inefficient regular expression complexity. Remote exploitation of the attack is possible. The project was informed ...
SUSE CVE-2026-112366
Picomatch through 4.0.7 contains a regular expression denial of service vulnerability that allows attackers to block the event loop by supplying single-branch repeated extglob patterns. Attackers can provide globs like + or +a, which analyzeRepeatedExtglob in lib/parse.js skips, causing exponenti...
CLSA-2026-1792520497 TuxCare security update for @babel/helper-skip-transparent-expression-wrappers (2 CVEs)
TuxCare rebuilt @babel/helper-skip-transparent-expression-wrappers to address 2 CVEs. Fixed in 7.16.7-tuxcare.2...
CLSA-2026-1792520495 TuxCare security update for @babel/helper-skip-transparent-expression-wrappers (1 CVE)
TuxCare rebuilt @babel/helper-skip-transparent-expression-wrappers to address 1 CVE. Fixed in 7.21.0-tuxcare.4...
CLSA-2026-1792520492 TuxCare security update for @babel/helper-skip-transparent-expression-wrappers (1 CVE)
TuxCare rebuilt @babel/helper-skip-transparent-expression-wrappers to address 1 CVE. Fixed in 7.18.9-tuxcare.3...
CLSA-2026-1792520491 TuxCare security update for @babel/helper-skip-transparent-expression-wrappers (1 CVE)
TuxCare rebuilt @babel/helper-skip-transparent-expression-wrappers to address 1 CVE. Fixed in 7.21.5-tuxcare.1...
CLSA-2026-1792512832 TuxCare security update for @babel/helper-optimise-call-expression (2 CVEs)
TuxCare rebuilt @babel/helper-optimise-call-expression to address 2 CVEs. Fixed in 7.16.7-tuxcare.2...
CLSA-2026-1792512829 TuxCare security update for @babel/helper-optimise-call-expression (1 CVE)
TuxCare rebuilt @babel/helper-optimise-call-expression to address 1 CVE. Fixed in 7.21.0-tuxcare.4...
CLSA-2026-1792512826 TuxCare security update for @babel/helper-optimise-call-expression (1 CVE)
TuxCare rebuilt @babel/helper-optimise-call-expression to address 1 CVE. Fixed in 7.18.9-tuxcare.3...
CLSA-2026-1792512825 TuxCare security update for @babel/helper-optimise-call-expression (1 CVE)
TuxCare rebuilt @babel/helper-optimise-call-expression to address 1 CVE. Fixed in 7.21.5-tuxcare.1...
Expression Language Injection
Apache Camel is vulnerable to Expression Language Injection. The vulnerability is due to improper validation of expression language inputs, where DynamicRouterControlService resolves the language from the CamelContext and compiles the expression into a Predicate without any allow‑list, and an...
CLSA-2026-1792455098 TuxCare security update for @babel/helper-member-expression-to-functions (2 CVEs)
TuxCare rebuilt @babel/helper-member-expression-to-functions to address 2 CVEs. Fixed in 7.16.7-tuxcare.2...