Lucene search
+L

110 matches found

Cvelist
Cvelist
•added 2026/09/15 3:44 p.m.•43 views

CVE-2026-55770 OpenBao: LDAPi ldaputil (wrong escape func)

OpenBao is an open source identity-based secrets management system. Prior to 2.5.5, OpenBao used EscapeLDAPValue, an RFC 4514 distinguished-name escaping function, where RFC 4515 LDAP search-filter escaping was required in sdk/helper/ldaputil/client.go GetUserDN. With the LDAP authentication...

6.8CVSS0.00525EPSS
SaveExploits0References7
OSV
OSV
•added 2026/09/15 3:44 p.m.•7 views

CVE-2026-55770 OpenBao: LDAPi ldaputil (wrong escape func)

OpenBao is an open source identity-based secrets management system. Prior to 2.5.5, OpenBao used EscapeLDAPValue, an RFC 4514 distinguished-name escaping function, where RFC 4515 LDAP search-filter escaping was required in sdk/helper/ldaputil/client.go GetUserDN. With the LDAP authentication...

6.8CVSS5.7AI score
SaveExploits0References9
OSV
OSV
•added 2026/09/04 11:18 p.m.•9 views

AZL-99945 CVE-2026-86098 affecting package ntopng 5.2.1-6

ntop nDPI versions before 6.0 contain a heap buffer overflow vulnerability in the ndpijsonstringescape function that writes beyond caller-supplied buffer boundaries. Attackers can trigger the overflow by supplying crafted network packet data including TLS SNI, HTTP headers, or DNS names that reac...

8.3CVSS6.1AI score0.00592EPSS
SaveExploits0References1
OSV
OSV
•added 2026/09/04 11:18 p.m.•12 views

DEBIAN-CVE-2026-86098

ntop nDPI versions before 6.0 contain a heap buffer overflow vulnerability in the ndpijsonstringescape function that writes beyond caller-supplied buffer boundaries. Attackers can trigger the overflow by supplying crafted network packet data including TLS SNI, HTTP headers, or DNS names that reac...

8.3CVSS6.1AI score0.00592EPSS
SaveExploits0References1
NVD
NVD
•added 2026/08/21 10:16 a.m.•29 views

CVE-2026-47080

XML Injection vulnerability in joshnuss xmlbuilder XmlBuilder module allows Content Spoofing, XML Injection. This vulnerability is associated with program files lib/xmlbuilder.ex and program routines XmlBuilder.generate/1, XmlBuilder.generate/2, XmlBuilder.escape/1. The escape/1 clause for :cdata...

2.1CVSS0.00222EPSS
SaveExploits0References5
EUVD
EUVD
•added 2026/08/21 9:49 a.m.•19 views

EUVD-2026-63878

XML Injection vulnerability in joshnuss xmlbuilder XmlBuilder module allows Content Spoofing, XML Injection. This vulnerability is associated with program files lib/xmlbuilder.ex and program routines XmlBuilder.generate/1, XmlBuilder.generate/2, XmlBuilder.escape/1. The escape/1 clause for :cdata...

2.1CVSS6.1AI score0.00222EPSS
SaveExploits0References4
CVE
CVE
•added 2026/08/21 9:49 a.m.•23 views

CVE-2026-47080

CVE-2026-47080 is an XML Injection vulnerability in the joshnuss xml_builder Elixir library (versions 0.0.7 through before 2.4.1 ). The root cause is in XmlBuilder.escape/1 within lib/xml_builder.ex: when handling {:cdata, data}, the data is placed verbatim between without splitting on embedded ...

2.1CVSS6.1AI score0.00222EPSS
SaveExploits0References5
Cvelist
Cvelist
•added 2026/08/21 9:49 a.m.•37 views

CVE-2026-47080 CDATA Section Breakout via Unsanitised ]]> in xml_builder

XML Injection vulnerability in joshnuss xmlbuilder XmlBuilder module allows Content Spoofing, XML Injection. This vulnerability is associated with program files lib/xmlbuilder.ex and program routines XmlBuilder.generate/1, XmlBuilder.generate/2, XmlBuilder.escape/1. The escape/1 clause for :cdata...

2.1CVSS0.00222EPSS
SaveExploits0References4
Positive Technologies
Positive Technologies
•added 2026/08/21 12:00 a.m.•43 views

PT-2026-79347

XML Injection vulnerability in joshnuss xml builder XmlBuilder module allows Content Spoofing, XML Injection. This vulnerability is associated with program files lib/xml builder.ex and program routines XmlBuilder.generate/1, XmlBuilder.generate/2, XmlBuilder.escape/1. The escape/1 clause for...

2.1CVSS6AI score0.00222EPSS
SaveExploits0References5
Positive Technologies
Positive Technologies
•added 2026/08/12 12:00 a.m.•11 views

PT-2026-71289

Shescape is a simple shell escape library for JavaScript. Prior to 2.1.14 and 3.0.1, getEscapeFunction in src/internal/unix/dash.js fails to escape after : or = when applications use the escape or escapeAll APIs on Unix with shell set to dash, or with shell set to true when Dash is the default, a...

6.3CVSS5.2AI score0.0059EPSS
SaveExploits0References8
BDU FSTEC
BDU FSTEC
•added 2026/08/05 12:00 a.m.•15 views

The vulnerability of the escape() function in the sql-string.js ORM library by Sequelize allows a attacker to execute arbitrary SQL code.

The vulnerability of the escape function in the sql-string.js ORM library by Sequelize is related to the lack of security measures taken to protect the SQL query structure when processing TODATE and TOTIMESTAMP parameters. Exploiting this vulnerability could allow an attacker to execute arbitrary...

10CVSS6.1AI score0.0054EPSS
SaveExploits0References4Affected Software1
Snyk
Snyk
•added 2026/08/03 8:29 p.m.•11 views

SQL Injection

Overview sequelize is a promise-based Node.js ORM for Postgres, MySQL, MariaDB, SQLite and Microsoft SQL Server. Affected versions of this package are vulnerable to SQL Injection via the escape function. An attacker can execute arbitrary SQL commands by supplying specially crafted input values th...

9.8CVSS8.3AI score0.0054EPSS
SaveExploits0References2
Github Security Blog
Github Security Blog
•added 2026/08/03 8:29 p.m.•19 views

Sequelize: SQL Injection (Oracle DB)

Summary SQL Injection is possible with strings only if dialect is set to oracle. The vulnerability was confirmed on Sequelize v6.37.3. Details The escape function defined in sql-string.js does not escape quotes if the value starts with TOTIMESTAMP or TODATE. javascript else if dialect === 'oracle...

9.8CVSS5.9AI score0.0054EPSS
SaveExploits0References4Affected Software1
Snyk
Snyk
•added 2026/08/03 8:29 p.m.•9 views

SQL Injection

Overview org.webjars.npm:sequelize is a promise-based Node.js ORM for Postgres, MySQL, MariaDB, SQLite and Microsoft SQL Server. Affected versions of this package are vulnerable to SQL Injection via the escape function. An attacker can execute arbitrary SQL commands by supplying specially crafted...

9.8CVSS9.1AI score0.0054EPSS
SaveExploits0References2
OSV
OSV
•added 2026/08/03 8:28 p.m.•39 views

CVE-2026-69240 Sequelize: SQL Injection (Oracle DB)

Sequelize is a Node.js ORM tool. Prior to 6.37.4, SQL injection is possible with strings only if dialect is set to oracle. The escape function defined in sql-string.js does not escape quotes if the value starts with TOTIMESTAMP or TODATE. In the Oracle dialect, when val is a string and starts wit...

9.8CVSS5.8AI score
SaveExploits0References5
Positive Technologies
Positive Technologies
•added 2026/07/29 12:00 a.m.•30 views

PT-2026-67508

Name of the Vulnerable Software and Affected Versions Sequelize versions prior to 6.37.4 Description SQL injection is possible when the dialect is set to oracle. The escape function in sql-string.js fails to escape single quotes if the input string starts with TO TIMESTAMP or TO DATE, returning t...

9.8CVSS5.8AI score0.0054EPSS
SaveExploits0References10
Github Security Blog
Github Security Blog
•added 2026/07/28 10:19 p.m.•24 views

@hypequery/clickhouse has SQL Injection in parameter escaping that allows arbitrary SQL execution

A SQL injection vulnerability exists in the escapeValue function used for parameter substitution. escapeValue dispatches on the type of the parameter value, and two of its branches failed to escape safely. An attacker who can control a parameter value can terminate the enclosing string literal an...

9.8CVSS5.8AI score0.00816EPSS
SaveExploits0References10Affected Software1
Github Security Blog
Github Security Blog
•added 2026/07/24 10:34 p.m.•23 views

Shescape: Shell injection via unescaped parentheses on Windows with CMD

Impact This impacts users of Shescape on Windows that explicitly configure shell to CMD, or true with the default shell being CMD, using the escape and escapeAll APIs. An attacker may be able to achieve shell injection depending on the original command. javascript import as cp from...

9.2CVSS5.8AI score0.00889EPSS
SaveExploits0References9Affected Software1
CVE
CVE
•added 2026/07/07 8:55 p.m.•77 views

CVE-2026-46672

The CVE-2026-46672 entry describes a local CSV formula-injection flaw in the @actual-app/cli before version 26.6.0. The CLI uses a hand-rolled CSV serializer in packages/cli/src/output.ts with an escapeCsv that only neutralizes RFC 4180 delimiters (comma, quote, newline) and does not neutralize c...

4.6CVSS6AI score0.00187EPSS
SaveExploits0References4
OSV
OSV
•added 2026/06/25 6:43 p.m.•18 views

GO-2026-5182 OpenBao: LDAPi ldaputil (wrong escape func) in github.com/openbao/openbao

OpenBao: LDAPi ldaputil wrong escape func in github.com/openbao/openbao...

6.8CVSS5.8AI score0.00525EPSS
SaveExploits0References4
Rows per page
Query Builder