63 matches found
CVE-2026-120639
The perl-cgi component (versions before 5.00 ) is vulnerable to HTTP header injection and HTTP response splitting . The root cause is that when autoEscape is off, the header function decodes HTML entities after performing newline checks, allowing encoded CR or LF characters to reach the response....
CVE-2026-120639 CGI versions before 5.00 for Perl allow HTTP header injection via entity decoding after the newline check in header and unchecked values in multipart_start and do_push
CGI versions before 5.00 for Perl allow HTTP header injection via entity decoding after the newline check in header and unchecked values in multipartstart and dopush. With autoEscape off, header decodes HTML entities in extra header values after its newline check, so an encoded CR or LF reaches t...
CVE-2026-120638 CGI versions before 5.00 for Perl allow open redirects via HTML entity decoding of the URL after application validation in redirect
CGI versions before 5.00 for Perl allow open redirects via HTML entity decoding of the URL after application validation in redirect. redirect decodes HTML entities in its URL before writing the Location header, so a URL the application has already validated can change meaning. For example,...
CVE-2026-120638
A vulnerability exists in perl-cgi (CGI versions before 5.00) where the redirect function decodes HTML entities in target URLs after the application has performed validation. This allows a remote attacker to supply a specially crafted URLβsuch as //evil.example/βwhich becomes //evil.example/ ...
jquery-cve-2022-31160
jQuery UI CVE-2022-31160 Vulnerability Demonstration This project demonstrates the jQuery UI Checkboxradio Widget Refresh Vulnerability CVE-2022-31160 , which allows HTML entity decoding during widget refresh operations, potentially leading to Cross-Site Scripting XSS attacks. π¨ Security Warning ...
PHPOffice PhpSpreadsheet input validation error vulnerability
A security vulnerability exists in PHPOffice PhpSpreadsheet versions prior to 3.10.8 and 4.0.0 up to 5.10.0. This vulnerability stems from improper entity decoding of SpreadsheetML XML by Reader\Xml. The double-encoded ββ becomes a literal ββ after two callbacks, allowing SimpleXML to receive...
CVE-2026-61812
The t:htmlEntityDecode transformation in OWASP ModSecurity decodes only five named HTML entities and in v3 matches entity-name prefixes, e.g. decodes to , so payloads using other entities such as evade rules. Affects v2 2.1.0-rc7 through 2.9.14 fixed 2.9.15 and v3 3.0.0-rc1 through 3.0.16 fixed...
PT-2026-89752
The Floating Chat Widget: Contact Chat Icons, Telegram Chat, Line Messenger, WeChat, Email, SMS, Call Button β Chaty plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 's' parameter in all versions up to, and including, 3.5.9 due to insufficient input sanitization and...
EUVD-2026-72065
The Kirki WordPress plugin before 6.3.0 does not hold back every spelling of the HTML entities it decodes when rendering, allowing unauthenticated users to store JavaScript in a comment which then runs in the session of anyone viewing a page that displays it, including an administrator, and on...
CVE-2026-84219
The Kirki WordPress plugin (versions before 6.3.0 , specifically identified as 6.2.1-6.2.5 in some records) is vulnerable to Unauthenticated Stored XSS . The root cause is that the plugin fails to restrict the various spellings of HTML entities it decodes during rendering. This allows an unauthen...
CVE-2026-84219 Kirki 6.2.1 - 6.2.5 - Unauthenticated Stored XSS via HTML Entity Decoding
The Kirki WordPress plugin before 6.3.0 does not hold back every spelling of the HTML entities it decodes when rendering, allowing unauthenticated users to store JavaScript in a comment which then runs in the session of anyone viewing a page that displays it, including an administrator, and on...
CVE-2026-84219 Kirki 6.2.1 - 6.2.5 - Unauthenticated Stored XSS via HTML Entity Decoding
The Kirki WordPress plugin before 6.3.0 does not hold back every spelling of the HTML entities it decodes when rendering, allowing unauthenticated users to store JavaScript in a comment which then runs in the session of anyone viewing a page that displays it, including an administrator, and on...
CVE-2026-85593
phpMyFAQ versions before 4.1.8 contain a stored cross-site scripting vulnerability in FaqHelper::convertOldInternalLinks that calls htmlentitydecode on sanitized FAQ content, reversing entity-encoding protection. Authenticated users with FAQ editing privileges can inject JavaScript payloads that...
CVE-2026-85593
phpMyFAQ versions before 4.1.8 are affected by a stored XSS vulnerability in FaqHelper::convertOldInternalLinks(). The root cause is a call to html_entity_decode() on already-sanitized FAQ content, which reverses the entity-encoding protection that was applied during sanitization. Any authenticat...
CVE-2026-85593 phpMyFAQ before 4.1.8 Stored XSS via html_entity_decode
phpMyFAQ versions before 4.1.8 contain a stored cross-site scripting vulnerability in FaqHelper::convertOldInternalLinks that calls htmlentitydecode on sanitized FAQ content, reversing entity-encoding protection. Authenticated users with FAQ editing privileges can inject JavaScript payloads that...
CVE-2026-75980
CVE-2026-75980 is a Stored Cross-Site Scripting (XSS) vulnerability in the BetterDocs WordPress plugin (versions β€ 4.8.1), discovered by Wordfence PRISM . The flaw resides in the Heading 'id' attribute within post content: entity-encoded quotes bypass wp_kses_post at save time, and the payload ma...
CVE-2026-77353 Wallos: iCalendar Injection via CRLF in Subscription Name/Notes Export
Wallos is an open-source, self-hostable personal subscription tracker. Prior to version 5.0.0, Wallos allows authenticated users to inject arbitrary iCalendar properties and events into their exported .ics feed by embedding raw CRLF sequences in subscription names or notes. Because the input...
CVE-2026-47079 Round-trip Corruption via Improper Entity Escaping in xml_builder
Inappropriate Encoding for Output Context vulnerability in joshnuss xmlbuilder XmlBuilder module allows Content Spoofing, Cross-site Scripting. This vulnerability is associated with program files lib/xmlbuilder.ex and program routines XmlBuilder.generate/1, XmlBuilder.generate/2,...
PT-2026-85493
Name of the Vulnerable Software and Affected Versions phpMyFAQ versions prior to 4.1.8 Description A stored cross-site scripting issue exists where the convertOldInternalLinks function in FaqHelper calls html entity decode on sanitized FAQ content. This process reverses the entity-encoding...
PT-2026-78653
Wekan is open source kanban built with Meteor. From 8.72 until 10.23, addBoardHTMLToZip in client/lib/exportHTML.js read a card title and body through textContent, which decoded entity-encoded markup, and then interpolated titleText and allText into content.innerHTML in the exported index.html. A...