14694 matches found
ACRN code issue vulnerabilities
ACRN is an open source project released by the Linux Foundation, which is a hypervisor designed for IoT and embedded devices. A null pointer dereference vulnerability exists in devicemodel/hw/pci/xhci.c in versions prior to ACRN 2.5. No details of the vulnerability are provided at this time...
Exploit for Cross-site Scripting in Akcp Sensorprobe2_Firmware
CVE-2021-35956. Proof of Concept Exploit for CVE-2021-35956,...
CVE-2021-35956
Stored cross-site scripting XSS in the embedded webserver of AKCP sensorProbe before SP480-20210624 enables remote authenticated attackers to introduce arbitrary JavaScript via the Sensor Description, Email from/to/cc, System Name, and System Location fields...
AKCP SensorProbe cross-site scripting vulnerability
The AKCP sensorProbe is a platform-independent environmental and safety monitoring device from AKCP USA. Simply assign an IP address and connect to the embedded web server. A cross-site scripting vulnerability exists in versions prior to SP480-20210624 of the AKCP sensorProbe Embedded Web Server...
CVE-2021-35956: Improper Neutralization of Input During Web Page Generation
Stored cross-site scripting XSS in the embedded webserver of AKCP sensorProbe before SP480-20210624 enables remote authenticated attackers to introduce arbitrary JavaScript via the Sensor Description, Email from/to/cc, System Name, and System Location fields...
PT-2021-21077
Name of the Vulnerable Software and Affected Versions: AKCP sensorProbe versions prior to SP480-20210624 Description: The issue is related to stored cross-site scripting XSS in the embedded webserver. Remote authenticated attackers can introduce arbitrary JavaScript via specific fields, including...
RLSA-2021:2591 Moderate: edk2 security update
EDK Embedded Development Kit is a project to enable UEFI support for Virtual Machines. This package contains a sample 64-bit UEFI firmware for QEMU and KVM. Security Fixes: edk2: possible heap corruption with LzmaUefiDecompressGetInfo CVE-2021-28211 For more details about the security issues,...
CVE-2021-32723
Prism is a syntax highlighting library. Some languages before 1.24.0 are vulnerable to Regular Expression Denial of Service ReDoS. When Prism is used to highlight untrusted user-given text, an attacker can craft a string that will take a very very long time to highlight. This problem has been fix...
EulerOS 2.0 SP8 : java-1.8.0-openjdk (EulerOS-SA-2021-1982)
According to the versions of the java-1.8.0-openjdk packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : - Vulnerability in the Java SE, Java SE Embedded product of Oracle Java SE component: Serialization. Supported versions that are...
org.eclipse.jetty:jetty-ajp (7.0.0.m0), org.eclipse.jetty:jetty-annotations (7.0.0.m0) +13 more potentially affected by CVE-2021-34428 via org.eclipse.jetty:jetty-server (7.0.0.m0)
org.eclipse.jetty:jetty-server MAVEN version 7.0.0.m0 is affected by a known vulnerability. The following packages have a transitive dependency on org.eclipse.jetty:jetty-server and may be impacted: - org.eclipse.jetty:jetty-ajp 7.0.0.m0 - org.eclipse.jetty:jetty-annotations 7.0.0.m0 -...
CVE-2021-21422 XSS Vulnerability in mongo-express
mongo-express is a web-based MongoDB admin interface, written with Node.js and express. 1: As mentioned in this issue: https://github.com/mongo-express/mongo-express/issues/577, when the content of a cell grows larger than supported size, clicking on a row will show full document unescaped, howev...
[SECURITY] Fedora 33 Update: mosquitto-1.6.15-1.fc33
Mosquitto is an open source message broker that implements the MQ Telemetry Transport protocol version 3.1 and 3.1.1 MQTT provides a lightweight method of carrying out messaging using a publish/subscribe model. This makes it suitable for "machine to machine" messaging such as with low power senso...
[SECURITY] Fedora 34 Update: mosquitto-2.0.11-1.fc34
Mosquitto is an open source message broker that implements the MQ Telemetry Transport protocol version 3.1 and 3.1.1 MQTT provides a lightweight method of carrying out messaging using a publish/subscribe model. This makes it suitable for "machine to machine" messaging such as with low power senso...
io.undertow:undertow-servlet (1.0.0.cr5), io.undertow:undertow-websockets-jsr (1.0.0.cr5) +2 more potentially affected by CVE-2021-20220 via io.undertow:undertow-core (1.0.0.cr5)
io.undertow:undertow-core MAVEN version 1.0.0.cr5 is affected by a known vulnerability. The following packages have a transitive dependency on io.undertow:undertow-core and may be impacted: - io.undertow:undertow-servlet 1.0.0.cr5 - io.undertow:undertow-websockets-jsr 1.0.0.cr5 -...
CVE-2021-24357
In the Best Image Gallery & Responsive Photo Gallery – FooGallery WordPress plugin before 2.0.35, the Custom CSS field of each gallery is not properly sanitised or validated before being being output in the page where the gallery is embed, leading to a stored Cross-Site Scripting issue...
org.eclipse.jetty.aggregate:jetty-all (7.5.0.v20110901), org.eclipse.jetty.aggregate:jetty-all-server (7.5.0.v20110901) +5 more potentially affected by CVE-2021-28169 via org.eclipse.jetty:jetty-servlets (7.5.0.v20110901)
org.eclipse.jetty:jetty-servlets MAVEN version 7.5.0.v20110901 is affected by a known vulnerability. The following packages have a transitive dependency on org.eclipse.jetty:jetty-servlets and may be impacted: - org.eclipse.jetty.aggregate:jetty-all 7.5.0.v20110901 -...
org.eclipse.jetty.aggregate:jetty-all (7.0.0.rc1), org.eclipse.jetty.aggregate:jetty-all-server (7.0.0.rc1) +3 more potentially affected by CVE-2021-28169 via org.eclipse.jetty:jetty-servlets (7.0.0.rc1)
org.eclipse.jetty:jetty-servlets MAVEN version 7.0.0.rc1 is affected by a known vulnerability. The following packages have a transitive dependency on org.eclipse.jetty:jetty-servlets and may be impacted: - org.eclipse.jetty.aggregate:jetty-all 7.0.0.rc1 -...
org.eclipse.jetty.aggregate:jetty-all (7.0.0.rc2), org.eclipse.jetty.aggregate:jetty-all-server (7.0.0.rc2) +3 more potentially affected by CVE-2021-28169 via org.eclipse.jetty:jetty-servlets (7.0.0.rc2)
org.eclipse.jetty:jetty-servlets MAVEN version 7.0.0.rc2 is affected by a known vulnerability. The following packages have a transitive dependency on org.eclipse.jetty:jetty-servlets and may be impacted: - org.eclipse.jetty.aggregate:jetty-all 7.0.0.rc2 -...
org.eclipse.jetty.aggregate:jetty-all (7.0.0.rc3), org.eclipse.jetty.aggregate:jetty-all-server (7.0.0.rc3) +3 more potentially affected by CVE-2021-28169 via org.eclipse.jetty:jetty-servlets (7.0.0.rc3)
org.eclipse.jetty:jetty-servlets MAVEN version 7.0.0.rc3 is affected by a known vulnerability. The following packages have a transitive dependency on org.eclipse.jetty:jetty-servlets and may be impacted: - org.eclipse.jetty.aggregate:jetty-all 7.0.0.rc3 -...
org.eclipse.jetty.aggregate:jetty-all (7.0.0.rc4), org.eclipse.jetty.aggregate:jetty-all-server (7.0.0.rc4) +3 more potentially affected by CVE-2021-28169 via org.eclipse.jetty:jetty-servlets (7.0.0.rc4)
org.eclipse.jetty:jetty-servlets MAVEN version 7.0.0.rc4 is affected by a known vulnerability. The following packages have a transitive dependency on org.eclipse.jetty:jetty-servlets and may be impacted: - org.eclipse.jetty.aggregate:jetty-all 7.0.0.rc4 -...