76 matches found
CVE-2024-23731
The OpenAPI loader in Embedchain before 0.1.57 allows attackers to execute arbitrary code, related to the openapi.py yaml.load function argument...
CVE-2024-23732
The JSON loader in Embedchain before 0.1.57 allows a ReDoS regular expression denial of service via a long string to json.py...
CVE-2024-23731
The OpenAPI loader in Embedchain before 0.1.57 allows attackers to execute arbitrary code, related to the openapi.py yaml.load function argument...
CVE-2024-23732
The JSON loader in Embedchain before 0.1.57 allows a ReDoS regular expression denial of service via a long string to json.py...
CVE-2024-23731
The OpenAPI loader in Embedchain before 0.1.57 allows attackers to execute arbitrary code, related to the openapi.py yaml.load function argument...
CVE-2024-23732
The JSON loader in Embedchain before 0.1.57 allows a ReDoS regular expression denial of service via a long string to json.py...
CVE-2024-23731: Improper Neutralization of Argument Delimiters in a Command
The OpenAPI loader in Embedchain before 0.1.57 allows attackers to execute arbitrary code, related to the openapi.py yaml.load function argument...
CVE-2024-23732: Inefficient Regular Expression Complexity
The JSON loader in Embedchain before 0.1.57 allows a ReDoS regular expression denial of service via a long string to json.py...
CVE-2024-23731
The OpenAPI loader in Embedchain before 0.1.57 allows attackers to execute arbitrary code, related to the openapi.py yaml.load function argument...
CVE-2024-23732
The JSON loader in Embedchain before 0.1.57 allows a ReDoS regular expression denial of service via a long string to json.py...
PT-2024-20041
Name of the Vulnerable Software and Affected Versions Embedchain versions prior to 0.1.57 Description The issue allows attackers to execute arbitrary code, related to the yaml.load function argument in the openapi.py file. Recommendations For versions prior to 0.1.57, update to version 0.1.57 or...
traia-tools (>=0.1.25, <=0.1.26) potentially affected by CVE-2024-23731 via embedchain (0.0.18)
embedchain PYPI version 0.0.18 is affected by a known vulnerability. The following packages have a transitive dependency on embedchain and may be impacted: - traia-tools =0.1.25, =0.1.26 Source cves: CVE-2024-23731 Source advisory: MEND:CVE-2024-23731...
traia-tools (>=0.1.25, <=0.1.26) potentially affected by CVE-2024-23732 via embedchain (0.0.18)
embedchain PYPI version 0.0.18 is affected by a known vulnerability. The following packages have a transitive dependency on embedchain and may be impacted: - traia-tools =0.1.25, =0.1.26 Source cves: CVE-2024-23732 Source advisory: MEND:CVE-2024-23732...
PT-2024-20042 · Unknown · Embedchain
Name of the Vulnerable Software and Affected Versions: Embedchain versions prior to 0.1.57 Description: The issue allows a ReDoS regular expression denial of service via a long string to json.py. This occurs in the JSON loader of Embedchain. Recommendations: For versions prior to 0.1.57, update t...
Embedchain Security Breach
Embedchain is an open source RAG framework from Embedchain Open Source. A security vulnerability exists in Embedchain versions prior to 0.1.57. An attacker can exploit this vulnerability to execute arbitrary code related to the parameters of the openapi.py yaml.load function...
Embedchain Security Breach
Embedchain is an open source RAG framework from Embedchain Open Source. A security vulnerability exists in Embedchain versions prior to 0.1.57. An attacker exploited the vulnerability to conduct a regular expression denial of service attack via a long string in json.py...