Lucene search
+L

565 matches found

Kitploit
Kitploit
•added 2026/10/31 6:31 a.m.•51 views

http-desync-guardian

Overview HTTP/1.1 went through a long evolution since 1991 to 2014: HTTP/0.9 – 1991 HTTP/1.0 – 1996 HTTP/1.1 RFC 2068 – 1997 RFC 2616 - 1999 RFC 7230 - 2014 This means there is a variety of servers and clients, which might have different views on request boundaries, creating opportunities for...

5.9AI score
SaveExploits0References11
Kitploit
Kitploit
•added 2026/10/31 5:09 a.m.•76 views

smuggler

/ | | | | \ | | | | |/ |/ | || |/ | | | || | | | || | | /||||/ \ |\ || | @defparam Smuggler An HTTP Request Smuggling / Desync testing tool written in Python 3 Acknowledgements A special thanks to James Kettle for his research and methods into HTTP desyncs And a special thanks to Ben Sadeghipour...

6.1AI score
SaveExploits0References3
Kitploit
Kitploit
•added 2026/10/31 1:34 a.m.•27 views

SilentMoonwalk

SilentMoonwalk PoC Implementation of a fully dynamic call stack spoofer TL;DR SilentMoonwalk is a PoC implementation of a fully dynamic call stack spoofer, implementing a technique to remove the original caller from the call stack, using ROP to desynchronize unwinding from control flow. Authors...

6.2AI score
SaveExploits0References3
Cvelist
Cvelist
•added 2026/10/30 9:57 p.m.•16 views

CVE-2026-55613 uhttpd: HTTP request smuggling via ubus POST body parse-error desync

uhttpd is a small HTTP server. In unpatched repository snapshots, uhubusdatasend in ubus.c can desynchronize HTTP request boundaries when a POST /ubus JSON body arrives in multiple TCP segments. An initial segment completing a JSON object sets du-jsobj; a later segment takes the existing-object...

6.9CVSS
SaveExploits0References3
Kitploit
Kitploit
•added 2026/10/30 7:38 p.m.•31 views

echteeteepee

HTTP/1 Desync Vulnerability Testing Tools This repository contains defensive security tools for detecting HTTP/1 request smuggling desync vulnerabilities based on groundbreaking research by James Kettle of PortSwigger. Research Attribution This work is directly inspired by and implements techniqu...

6.1AI score
SaveExploits0
Kitploit
Kitploit
•added 2026/10/30 7:28 p.m.•60 views

http-request-smuggler

HTTP Request Smuggler This Burp Suite extension automatically detects and exploits HTTP Request Smuggling vulnerabilities using advanced desynchronization techniques developed by PortSwigger researcher James Kettle. It supports comprehensive scanning for HTTP/1.1 and HTTP/2-downgrade desync...

6AI score
SaveExploits0References1
Kitploit
Kitploit
•added 2026/10/30 4:33 p.m.•42 views

CTT-Apple-Silicon-Refraction

CTT-Apple-Silicon-Refraction webkitrefraction.js The 33-Layer WebGL Payload ​This JavaScript payload uses the \alpha constant to create a high-frequency "Memory Shiver." It induces the Use-After-Free UAF in CVE-2025-43529 by desynchronizing the WebKit garbage collector from the GPU's Metal comman...

8.8CVSS8.1AI score0.2565EPSS
SaveExploits8References1
Kitploit
Kitploit
•added 2026/10/30 2:58 p.m.•36 views

wordpress-batch-rce-lab

wp2shell: WordPress Batch RCE A technical breakdown of CVE-2026-63030, a logic bug in WordPress core's REST API batch endpoint that lets an anonymous request dispatch under a different request's route and permission check, chaining into CVE-2026-60137 SQL injection for unauthenticated remote code...

9.8CVSS9.2AI score0.10649EPSS
SaveExploits91References5
Kitploit
Kitploit
•added 2026/10/30 2:35 p.m.•23 views

CVE-2022-22536_SAP_Request_Smuggling_Scanner

CVE-2022-22536 SAP Rquest Smuggling Scanner This is a fast, socket-level batch scanner for CVE-2022-22536 , a critical request smuggling vulnerability in SAP Internet Communication Manager ICM and SAP Web Dispatcher. It tests multiple hosts in parallel for protocol desynchronization behavior...

10CVSS8.9AI score0.97945EPSS
SaveExploits8
Kitploit
Kitploit
•added 2026/10/30 2:52 a.m.•33 views

SAPGateBreaker-Exploit

CVE-2022-22536: HTTP Smuggling Through SAP's Front Door SAP NetWeaver Application Server ABAP, SAP NetWeaver Application Server Java, ABAP Platform, SAP Content Server 7.53 and SAP Web Dispatcher are vulnerable for request smuggling and request concatenation. An unauthenticated attacker can prepe...

10CVSS9AI score0.97945EPSS
SaveExploits8
Kitploit
Kitploit
•added 2026/10/29 3:54 p.m.•23 views

crlf-desyncs

CRLF Desyncs This is a repository containing useful tools and resources for detecting and exploiting CRLF-based Desyncs, presented at BlackHat USA 2026 and DEFCON 34. Contents cdn-origin/ - contains aggregated origin-to-edge headers useful for fuzzing a CRLF injection on a response...

6AI score
SaveExploits0
Kitploit
Kitploit
•added 2026/10/29 3:32 p.m.•39 views

wp2shell

wp2shell — Pre-Auth RCE in WordPress core Unauthenticated WordPress core RCE PoC chaining CVE-2026-63030 + CVE-2026-60137. Authorized testing only. wp2shell.py is a single-file, standard-library-only proof of concept that chains two WordPress core vulnerabilities into unauthenticated remote code...

9.8CVSS9.2AI score0.10649EPSS
SaveExploits94
Kitploit
Kitploit
•added 2026/10/29 3:22 p.m.•32 views

wp2shell-checker

\ \ / / \ / || | | | | | | | \ \ /\ / /| | | \ | || | | | | | | \ V V / | // / | | || || | // || ||/|| ||||| wp2shell-checker | WordPress Batch API Desync Detector Checker detector for the WordPress Core REST Batch API pre-auth RCE Created by 0xjessie21 — Cybersecurity ILCS Overview | ---|---...

6.2AI score
SaveExploits0References2
Kitploit
Kitploit
•added 2026/10/29 2:32 p.m.•24 views

CVE-2022-29361_Werkzeug_Client-Side-Desync-to-XSS

Credits to @kevin-mizu https://github.com/kevin-mizu/Werkzeug-CVE-2022-29361-PoC/tree/main for details read: https://mizu.re/post/abusing-client-side-desync-on-werkzeug Tested On Chromium 119.0.6045.123 built on Debian trixie/sid, running on Debian kali-rolling...

9.8CVSS8.5AI score0.08067EPSS
SaveExploits0References1
Kitploit
Kitploit
•added 2026/10/29 11:53 a.m.•42 views

crlf-powered-desync-scanner

CRLF-Powered Desync Scanner This is the Burp Extension we used to detect all cases from our research CRLF-Powered Desync Attacks: Beheading HTTP Streams. It's a research-first scanner built using BulkScan similar to HTTP Request Smuggler and others. Implementation Request Header Injection probe...

6.1AI score
SaveExploits0References2
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2026/10/28 12:00 a.m.•4 views

CVE-2026-116531: Improper Handling of Length Parameter Inconsistency

HTTP::Body versions before 1.2301 for Perl lose track of chunk boundaries in chunked request bodies when a read ends inside a chunk. In chunked mode, used when no content length is given, add treats a chunk as complete once the buffer is as long as the chunk's declared size, but the buffer still...

6.1AI score0.00288EPSS
SaveExploits0References2
KittySploit
KittySploit
•added 2026/10/26 5:01 p.m.•15 views

HFS CVE-2014-6287 search macro RCE

CVE-2014-6287 HttpFileServer 2.3–2.3c: NUL-byte desync in the search handler allows .exec|cmd. macro execution without authentication. !/usr/bin/env python3 -- coding: utf-8 -- """Rejetto HFS CVE-2014-6287 unauthenticated search macro command execution.""" from future import annotations from...

10CVSS8.6AI score0.99323EPSS
SaveExploits25References3
GithubExploit
GithubExploit
•added 2026/10/24 4:39 p.m.•30 views

cve-2026-nextjs-use-cache-rce-poc

Next.js use cache typed-array desync → RCE GHSA-673q-mjm6-r...

6.3AI score
SaveExploits0
osv_ghsa
osv_ghsa
•added 2026/10/23 9:37 p.m.•15 views

GHSA-WJR9-J795-JXCR fast-uri vulnerable to host confusion via unchecked WHATWG host canonicalization

Impact fast-uri versions = 2.4.2, = 3.1.3, = 4.0.1, = 4.2.2 can silently rewrite the host of an HTTP-family URL http, https, ws, wss, or any scheme with domainHost: true. For those schemes canonicalizeHost passes the parsed host to the WHATWG URL parser and adopts its .hostname without checking...

4.8CVSS5.7AI score0.00255EPSS
SaveExploits0References10
Github Security Blog
Github Security Blog
•added 2026/10/23 9:37 p.m.•19 views

fast-uri vulnerable to host confusion via unchecked WHATWG host canonicalization

Impact fast-uri versions = 2.4.2, = 3.1.3, = 4.0.1, = 4.2.2 can silently rewrite the host of an HTTP-family URL http, https, ws, wss, or any scheme with domainHost: true. For those schemes canonicalizeHost passes the parsed host to the WHATWG URL parser and adopts its .hostname without checking...

4.8CVSS5.7AI score0.00255EPSS
SaveExploits0References10Affected Software1
Rows per page
Query Builder