9550 matches found
Linux Distros Unpatched Vulnerability : CVE-2026-98030
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - net: dsa: bcmsf2: bound the CFP rule dump by the caller's buffer size bcmsf2cfprulegetall walks the whole cfp.unique bitmap into rulelocs without consulting...
Linux Distros Unpatched Vulnerability : CVE-2026-98027
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - net: dsa: mv88e6xxx: bound the policy rule dump by the caller's buffer size mv88e6xxxgetrxnfc uses rxnfc-rulecnt as the write index while dumping the policy IDR...
CVE-2026-97614: Undefined Security Weakness
In the Linux kernel, the following vulnerability has been resolved: net: dsa: tagbrcm: legacy FCS: request needed tailroom The legacy FCS tagger calculates the CRC over skb-len bytes starting at skb-data. When a nonlinear skb reaches the tagger, this reads past the linear head into unrelated slab...
CVE-2026-98027
In the Linux kernel, the following vulnerability has been resolved: net: dsa: mv88e6xxx: bound the policy rule dump by the caller's buffer size mv88e6xxxgetrxnfc uses rxnfc-rulecnt as the write index while dumping the policy IDR, clobbering the input value before it has been looked at. That input...
Linux Distros Unpatched Vulnerability : CVE-2026-97614
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - net: dsa: tagbrcm: legacy FCS: request needed tailroom The legacy FCS tagger calculates the CRC over skb-len bytes starting at skb-data. When a nonlinear skb...
SUSE CVE-2026-97435
In the Linux kernel, the following vulnerability has been resolved: net: dsa: sja1105: flower: reject cross-chip redirect dsaportfromnetdev may return a valid port from a different switch chip. Programming another chip's port index into the local hardware causes redirection to the wrong port, or ...
CVE-2026-97435
In the Linux kernel, the following vulnerability has been resolved: net: dsa: sja1105: flower: reject cross-chip redirect dsaportfromnetdev may return a valid port from a different switch chip. Programming another chip's port index into the local hardware causes redirection to the wrong port, or ...
AZL-103799 CVE-2026-97435 affecting package kernel 6.6.157.1-1
In the Linux kernel, the following vulnerability has been resolved: net: dsa: sja1105: flower: reject cross-chip redirect dsaportfromnetdev may return a valid port from a different switch chip. Programming another chip's port index into the local hardware causes redirection to the wrong port, or ...
UBUNTU-CVE-2026-97435
In the Linux kernel, the following vulnerability has been resolved: net: dsa: sja1105: flower: reject cross-chip redirect dsaportfromnetdev may return a valid port from a different switch chip. Programming another chip's port index into the local hardware causes redirection to the wrong port, or ...
CVE-2026-97435
The Linux kernel contains a vulnerability in the net: dsa: sja1105: flower driver where the dsa_port_from_netdev() function may return a valid port index from a different switch chip. This allows an attacker or process to program another chip's port index into the local hardware, leading to redir...
EUVD-2026-86048
In the Linux kernel, the following vulnerability has been resolved: net: dsa: sja1105: flower: reject cross-chip redirect dsaportfromnetdev may return a valid port from a different switch chip. Programming another chip's port index into the local hardware causes redirection to the wrong port, or ...
CVE-2026-97435 net: dsa: sja1105: flower: reject cross-chip redirect
In the Linux kernel, the following vulnerability has been resolved: net: dsa: sja1105: flower: reject cross-chip redirect dsaportfromnetdev may return a valid port from a different switch chip. Programming another chip's port index into the local hardware causes redirection to the wrong port, or ...
CVE-2026-97435 net: dsa: sja1105: flower: reject cross-chip redirect
In the Linux kernel, the following vulnerability has been resolved: net: dsa: sja1105: flower: reject cross-chip redirect dsaportfromnetdev may return a valid port from a different switch chip. Programming another chip's port index into the local hardware causes redirection to the wrong port, or ...
CVE-2026-97435
In the Linux kernel, the following vulnerability has been resolved: net: dsa: sja1105: flower: reject cross-chip redirect dsaportfromnetdev may return a valid port from a different switch chip. Programming another chip's port index into the local hardware causes redirection to the wrong port, or ...
CVE-2026-97435: Undefined Security Weakness
In the Linux kernel, the following vulnerability has been resolved: net: dsa: sja1105: flower: reject cross-chip redirect dsaportfromnetdev may return a valid port from a different switch chip. Programming another chip's port index into the local hardware causes redirection to the wrong port, or ...
PT-2026-98069
In the Linux kernel, the following vulnerability has been resolved: net: dsa: sja1105: flower: reject cross-chip redirect dsa port from netdev may return a valid port from a different switch chip. Programming another chip's port index into the local hardware causes redirection to the wrong port, ...
Linux Distros Unpatched Vulnerability : CVE-2026-97435
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - net: dsa: sja1105: flower: reject cross-chip redirect dsaportfromnetdev may return a valid port from a different switch chip. Programming another chip's port...
wolfCOSE v2.0.0
wolfCOSE wolfCOSE is a lightweight C library implementing CBOR RFC 8949, COSE RFC 9052/9053, and post-quantum ML-DSA for COSE RFC 9964 using wolfSSL as the crypto backend. Main Features Complete RFC 9052 message set : all six COSE message types, including multi-signer COSESign and multi-recipient...
golang.org/x/crypto/ssh: golang.org/x/crypto/ssh: Denial of Service via crafted public key with excessive parameters
A flaw was found in golang.org/x/crypto/ssh. The RSA and DSA public key parsers in the affected component did not enforce size limits on key parameters. This vulnerability allows an unauthenticated client to provide a crafted public key with an excessively large modulus or DSA parameter during...
Astra Linux – Vulnerability in Linux 5.10
In the Linux kernel, the following vulnerabilities have been resolved: net: dsa: bcmsf2: do not use devres for mdiobus As explained in the commits: 74b6d7d13307 "net: dsa: realtek: register the MDIO bus using devres" 5135e96a3dd2 "net: dsa: do not allocate the slavemiibus using devres" The...