Lucene search
+L

5095 matches found

Vulnrichment
Vulnrichment
•added 2026/07/16 2:38 p.m.•21 views

CVE-2026-59862 Kiota: Code Generation Literal Injection in the Python Generator

Kiota is an OpenAPI based HTTP Client code generator. Prior to 1.29.1 and 1.32.0, Kiota's Python generator let attacker-controlled enum value descriptions from x-ms-enum.values.description flow through KiotaBuilder.SetEnumOptions into Documentation.DescriptionTemplate and...

7.5CVSS6AI score0.01376EPSS
SaveExploits0References2
Vulnrichment
Vulnrichment
•added 2026/07/16 2:34 p.m.•18 views

CVE-2026-59860 Kiota: XML Doc-Comment Newline Breakout Code Injection

Kiota is an OpenAPI based HTTP Client code generator. Prior to 1.29.1 and 1.32.3, Kiota is affected by a code-generation injection vulnerability in the C XML documentation-comment sink the description, externalDocs label, and externalDocs link fields emitted as /// … comments. When text from an...

8.7CVSS5.9AI score0.01381EPSS
SaveExploits0References4
CVE
CVE
•added 2026/07/16 2:34 p.m.•58 views

CVE-2026-59860

Kiota is an OpenAPI-based HTTP client code generator. Prior to 1.32.3, it is affected by a code-generation injection in the C# XML documentation-comment sink when OpenAPI descriptions are written into single-line /// comments without stripping newline/Unicode terminators, allowing injection into ...

8.7CVSS5.9AI score0.01381EPSS
SaveExploits0References4
OSV
OSV
•added 2026/07/16 2:34 p.m.•15 views

CVE-2026-59860 Kiota: XML Doc-Comment Newline Breakout Code Injection

Kiota is an OpenAPI based HTTP Client code generator. Prior to 1.29.1 and 1.32.3, Kiota is affected by a code-generation injection vulnerability in the C XML documentation-comment sink the description, externalDocs label, and externalDocs link fields emitted as /// … comments. When text from an...

8.7CVSS5.6AI score
SaveExploits0References6
OSV
OSV
•added 2026/07/16 1:33 p.m.•13 views

MINI-HPRP-M653-QVQ7

Bulletin has no description...

7.5CVSS6AI score0.00793EPSS
SaveExploits0
RedHat Linux
RedHat Linux
•added 2026/07/16 11:17 a.m.•19 views

Important: Red Hat Security Advisory: RHTAS 1.3.6 - Red Hat Trusted Artifact Signer Release

The 1.3.6 release of Red Hat Trusted Artifact Signer OpenShift Operator. For more details please visit the product documentation at https://access.redhat.com/documentation/en-us/redhattrustedartifactsigner/1.3 The RHTAS Operator can be used with OpenShift Container Platform 4.16, 4.17, 4.18, 4.19...

9.1CVSS6.6AI score0.00662EPSS
SaveExploits0References9
Oracle linux
Oracle linux
•added 2026/07/16 12:00 a.m.•16 views

cockpit security update

356.2-1.0.1 - Storage: Enable btrfs support Orabug: 37464632 - Replaced upstream urls in documentation with oracle links Orabug: 36528753 - Drop subscription-manager-cockpit requirement for ol Orabug: 34681110 - Remove duplicate reference to server in cockpit Orabug: 34030494 - Update documentati...

8CVSS7.4AI score0.0119EPSS
SaveExploits0
Tenable Nessus
Tenable Nessus
•added 2026/07/16 12:00 a.m.•19 views

Linux Distros Unpatched Vulnerability : CVE-2026-59084

The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - Insufficient Technical Documentation vulnerability in Apache Tomcat since the requirements to securely configure the EncryptInterceptor were not clearly...

9.1CVSS7.7AI score0.00506EPSS
SaveExploits0References4
Oracle linux
Oracle linux
•added 2026/07/16 12:00 a.m.•19 views

cockpit-image-builder security update

94.3-1.0.1 - Switch to old frotend Orabug: 38011073 Orabug: 37856296 Orabug: 37856375 - Replaced additional upstream url Orabug: 37856187 - Replaced upstream urls in documentation with oracle links Orabug: 37856187 94.3-1 - New upstream release 94.2-1 - New upstream release 94.1-1 - Resolve...

9.8CVSS6.5AI score0.02618EPSS
SaveExploits0
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2026/07/16 12:00 a.m.•1 views

CVE-2026-59860: Improper Control of Generation of Code

Kiota is an OpenAPI based HTTP Client code generator. Prior to 1.29.1 and 1.32.3, Kiota is affected by a code-generation injection vulnerability in the C XML documentation-comment sink the description, externalDocs label, and externalDocs link fields emitted as /// … comments. When text from an...

8.7CVSS5.9AI score0.01381EPSS
SaveExploits0References2
Positive Technologies
Positive Technologies
•added 2026/07/16 12:00 a.m.•33 views

PT-2026-60481

Name of the Vulnerable Software and Affected Versions Kiota versions prior to 1.32.0 Description Kiota is an OpenAPI based HTTP Client code generator. The Python generator fails to sanitize newlines in enum value descriptions provided via x-ms-enum.values.description. This data flows through...

7.5CVSS6.1AI score0.01376EPSS
SaveExploits0References8
OSV
OSV
•added 2026/07/15 9:58 p.m.•22 views

GHSA-XGCH-X3MX-CM3C safeurl is Missing IPv6 CIDR Ranges in Blocklist

The privateNetworks blocklist was found to be missing newly added CIDR ranges. More specifically, the following CIDR ranges were not being blocked: - 64:ff9b:1::/48: NAT64 local-use prefix RFC 8215 - 5f00::/16: Segment Routing SRv6 SIDs RFC 9602 - 3fff::/20: documentation prefix RFC 9637 -...

6.9CVSS6.1AI score0.00521EPSS
SaveExploits0References3
EUVD
EUVD
•added 2026/07/15 8:34 p.m.•16 views

EUVD-2026-44806

n8n-MCP is an MCP server that provides AI assistants access to n8n node documentation, properties, and operations. Prior to 2.56.1, in HTTP mode with multi-tenancy enabled through ENABLEMULTITENANT=true, n8n-mcp's local workflow version history backups were not isolated per tenant, allowing an...

9.9CVSS6.1AI score0.00388EPSS
SaveExploits0References2
GithubExploit
GithubExploit
•added 2026/07/15 8:17 p.m.•90 views

labs

Security Labs !Licensehttps://img.shields.io/github/licen...

10CVSS7.9AI score0.96184EPSS
SaveExploits57
OSV
OSV
•added 2026/07/15 10:56 a.m.•13 views

MINI-3WQ6-CC62-3F79

Bulletin has no description...

6.1AI score
SaveExploits0
SUSE CVE
SUSE CVE
•added 2026/07/15 5:01 a.m.•17 views

SUSE CVE-2026-59084

Insufficient Technical Documentation vulnerability in Apache Tomcat since the requirements to securely configure the EncryptInterceptor were not clearly documented. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.23, from 10.1.0-M1 through 10.1.56, from 9.0.13 through 9.0.119, from...

7.3CVSS7.8AI score0.00506EPSS
SaveExploits0References7
Cvelist
Cvelist
•added 2026/07/14 9:15 p.m.•47 views

CVE-2026-46627 Twig: Sandbox resource exhaustion via unbounded `for` / `range()`

Twig is a template language for PHP. Prior to 3.26.0, the Twig sandbox does not prevent a template from consuming CPU, memory, or wall-clock time, even under the strictest allow-list, allowing untrusted templates to cause resource exhaustion. This issue is addressed in version 3.26.0 by documenti...

7.1CVSS0.00542EPSS
SaveExploits0References3
OSV
OSV
•added 2026/07/14 9:15 p.m.•16 views

CVE-2026-46627 Twig: Sandbox resource exhaustion via unbounded `for` / `range()`

Twig is a template language for PHP. Prior to 3.26.0, the Twig sandbox does not prevent a template from consuming CPU, memory, or wall-clock time, even under the strictest allow-list, allowing untrusted templates to cause resource exhaustion. This issue is addressed in version 3.26.0 by documenti...

7.1CVSS6.1AI score
SaveExploits0References5
Snyk
Snyk
•added 2026/07/14 10:52 a.m.•20 views

Insecure Default Initialization of Resource

Overview org.apache.tomcat:tomcat is an implementation of the Java Servlet, JavaServer Pages, Java Expression Language and Java WebSocket technologies. Affected versions of this package are vulnerable to Insecure Default Initialization of Resource due to unclear documentation regarding the secure...

9.1CVSS7.8AI score0.00506EPSS
SaveExploits0References2
OSV
OSV
•added 2026/07/14 9:16 a.m.•13 views

DEBIAN-CVE-2026-59084

Insufficient Technical Documentation vulnerability in Apache Tomcat since the requirements to securely configure the EncryptInterceptor were not clearly documented. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.23, from 10.1.0-M1 through 10.1.56, from 9.0.13 through 9.0.119, from...

9.1CVSS7.8AI score0.00506EPSS
SaveExploits0References1
Rows per page
Query Builder