Lucene search
+L

201 matches found

OSV
OSV
•added 2024/02/14 12:00 a.m.•85 views

CVE-2023-50387

Certain DNSSEC aspects of the DNS protocol in RFC 4033, 4034, 4035, 6840, and related RFCs allow remote attackers to cause a denial of service CPU consumption via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG...

7.5CVSS7.4AI score
SaveExploits0References38
AlpineLinux
AlpineLinux
•added 2024/02/14 12:00 a.m.•118 views

CVE-2023-50387

Certain DNSSEC aspects of the DNS protocol in RFC 4033, 4034, 4035, 6840, and related RFCs allow remote attackers to cause a denial of service CPU consumption via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG...

7.5CVSS8AI score0.99988EPSS
SaveExploits0
Code423n4
Code423n4
•added 2023/04/28 12:00 a.m.•18 views

length OF THE BYTES ARRAY IS NOT CHECKED BEFORE SUBSTRING IS EXTRACTED FROM IT, WHICH COULD LEAD TO SUBSTRING OF bytes(0)

Lines of code Vulnerability details Impact In RRUtils.readDNSKEY function, if the length == 4 then the self.publicKey will be an empty bytes array. No check is performed to validata the length variable. This will return the public key of the DNSKEY as an empty bytes array. Check should be perform...

6.8AI score
SaveExploits0
Code423n4
Code423n4
•added 2023/04/26 12:00 a.m.•23 views

verifySignatureWithKey - RRSIG RR's Signer's Name is never checked if it matches owner name

Lines of code Vulnerability details Impact According to RFC 4035 and as mentioned in the comments in function "verifySignatureWithKey" , the Signer's name should also be checked if it matches the owner name. If the Signer's Name field of an RRSIG record does not match the owner name of a DNSKEY...

6.7AI score
SaveExploits0
OpenVAS
OpenVAS
•added 2023/01/12 12:00 a.m.•38 views

Huawei EulerOS: Security Advisory for unbound (EulerOS-SA-2023-1156)

The remote host is missing an update for the Huawei EulerOS SPDX-FileCopyrightText: 2023 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...

7.5CVSS7.7AI score0.01636EPSS
SaveExploits0References2
UbuntuCve
UbuntuCve
•added 2022/09/26 12:00 a.m.•59 views

CVE-2022-3204

A vulnerability named 'Non-Responsive Delegation Attack' NRDelegation Attack has been discovered in various DNS resolving software. The NRDelegation Attack works by having a malicious delegation with a considerable number of non responsive nameservers. The attack starts by querying a resolver for...

7.5CVSS6.9AI score0.01636EPSS
SaveExploits0References3
RedhatCVE
RedhatCVE
•added 2022/05/20 10:30 p.m.•32 views

CVE-2017-15090

An issue has been found in the DNSSEC validation component of PowerDNS Recursor from 4.0.0 and up to and including 4.0.6, where the signatures might have been accepted as valid even if the signed data was not in bailiwick of the DNSKEY used to sign it. This allows an attacker in position of...

6.1CVSS4AI score0.03302EPSS
SaveExploits0References1
Oracle linux
Oracle linux
•added 2022/02/03 12:00 a.m.•220 views

bind security update

32:9.8.2-0.68.rc1.0.3.8 - Backport fix for CVE-2018-5741 Orabug: 33496185 32:9.8.2-0.68.rc1.0.2.8 - Backport possible assertion failure on DNAME processing CVE-2021-25215 32:9.8.2-0.68.rc1.0.1.8 - Backport the fix for buffer overflow CVE-2020-8625 Orabug: 32588749 32:9.8.2-0.68.rc1.8 - Fix...

10CVSS6.5AI score0.99409EPSS
SaveExploits67
Tenable Nessus
Tenable Nessus
•added 2018/08/29 12:00 a.m.•37 views

OracleVM 3.3 / 3.4 : bind (OVMSA-2018-0252)

The remote OracleVM system is missing necessary patches to address critical security updates : - Fix CVE-2018-5740 - Fix CVE-2017-3145 - Change EDNS flags only after successful query 1416035 - Fix crash in ldap driver at bind-sdb stop 1426626 - Fix CVE-2017-3142, CVE-2017-3143 - Update root serve...

7.5CVSS6.6AI score0.5962EPSS
SaveExploits2References8
Debian CVE
Debian CVE
•added 2018/01/23 3:00 p.m.•61 views

CVE-2017-15090

An issue has been found in the DNSSEC validation component of PowerDNS Recursor from 4.0.0 and up to and including 4.0.6, where the signatures might have been accepted as valid even if the signed data was not in bailiwick of the DNSKEY used to sign it. This allows an attacker in position of...

5.9CVSS6.2AI score0.00709EPSS
SaveExploits0
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2018/01/23 12:00 a.m.•5 views

CVE-2017-15090: Improper Verification of Cryptographic Signature

An issue has been found in the DNSSEC validation component of PowerDNS Recursor from 4.0.0 and up to and including 4.0.6, where the signatures might have been accepted as valid even if the signed data was not in bailiwick of the DNSKEY used to sign it. This allows an attacker in position of...

5.9CVSS6.4AI score0.00709EPSS
SaveExploits0References3
Tenable Nessus
Tenable Nessus
•added 2017/11/17 12:00 a.m.•24 views

Fedora 26 : knot / knot-resolver (2017-31519ecf40)

"Major updates for Knot DNS and Knot Resolver: Knot Resolver 1.5.0 2017-11-02 ================================ Bugfixes -------- - fix loading modules on Darwin Improvements ------------ - new module tasignalquery supporting Signaling Trust Anchor Knowledge using Keytag Query RFC 8145 section 5...

5.4AI score
SaveExploits0References1
Tenable Nessus
Tenable Nessus
•added 2017/05/10 12:00 a.m.•41 views

OracleVM 3.3 / 3.4 : bind (OVMSA-2017-0100)

The remote OracleVM system is missing necessary patches to address critical security updates : - Fix DNSKEY that encountered a CNAME 1447869, ISC change 3391 - Fix CVE-2017-3136 ISC change 4575 - Fix CVE-2017-3137 ISC change 4578 - Fix and test caching CNAME before DNAME ISC change 4558 - Fix...

7.5CVSS6.8AI score0.38733EPSS
SaveExploits0References6
Oracle linux
Oracle linux
•added 2017/05/08 12:00 a.m.•36 views

bind security update

32:9.8.2-0.62.rc1.2 - Fix DNSKEY that encountered a CNAME 1447869, ISC change 3391...

7.5CVSS1.2AI score0.01675EPSS
SaveExploits0
Hacker One
Hacker One
•added 2016/09/16 1:05 a.m.•44 views

Skyliner: DNSSEC misconfiguration

First of all I will start with some theory. DNS is a system to translate a domain name to an ip address. Normally a computer automatically trust a DNS server and connects to the IP provided by the DNS server. This is prone to security issues because a malicious wifi network, an attacker on your...

6.5AI score
SaveExploits0
Tenable Nessus
Tenable Nessus
•added 2013/01/24 12:00 a.m.•52 views

AIX 6.1 TL 4 : bind9 (IV01118)

The security status of an NS RRset is not properly determined during a DNSKEY algorithm rollover which can allow a remote attacker to cause a denial of service. Signed negative responses and corresponding RRSIG records in the cache are not properly handled which can allow a remote attacker to cau...

6.4CVSS7.2AI score0.14503EPSS
SaveExploits0References3
Tenable Nessus
Tenable Nessus
•added 2013/01/24 12:00 a.m.•52 views

AIX 5.3 TL 12 : bind9 (IZ99391)

The security status of an NS RRset is not properly determined during a DNSKEY algorithm rollover which can allow a remote attacker to cause a denial of service. Signed negative responses and corresponding RRSIG records in the cache are not properly handled which can allow a remote attacker to cau...

6.4CVSS7.2AI score0.14503EPSS
SaveExploits0References3
Debian
Debian
•added 2010/12/10 8:27 p.m.•46 views

[SECURITY] [DSA-2130-1] New BIND packages fix denial of service

------------------------------------------------------------------------ Debian Security Advisory DSA-2130-1 [email protected] http://www.debian.org/security/ Florian Weimer December 10, 2010 http://www.debian.org/security/faq -...

6.4CVSS7.2AI score0.14503EPSS
SaveExploits0
OSV
OSV
•added 2010/12/06 1:44 p.m.•11 views

DEBIAN-CVE-2010-3614

named in ISC BIND 9.x before 9.6.2-P3, 9.7.x before 9.7.2-P3, 9.4-ESV before 9.4-ESV-R4, and 9.6-ESV before 9.6-ESV-R3 does not properly determine the security status of an NS RRset during a DNSKEY algorithm rollover, which might allow remote attackers to cause a denial of service DNSSEC validati...

6.4CVSS7.2AI score0.14503EPSS
SaveExploits0References1
OSV
OSV
•added 2010/12/06 1:44 p.m.•14 views

CVE-2010-3614

named in ISC BIND 9.x before 9.6.2-P3, 9.7.x before 9.7.2-P3, 9.4-ESV before 9.4-ESV-R4, and 9.6-ESV before 9.6-ESV-R3 does not properly determine the security status of an NS RRset during a DNSKEY algorithm rollover, which might allow remote attackers to cause a denial of service DNSSEC validati...

6.4AI score
SaveExploits0References30
Rows per page
Query Builder