202 matches found
ilcdirac (>=34.0.0a1, <=34.0.0a3) potentially affected by CVE-2024-24825 via dirac (7.3.34)
dirac PYPI version 7.3.34 is affected by a known vulnerability. The following packages have a transitive dependency on dirac and may be impacted: - ilcdirac =34.0.0a1, =34.0.0a3 Source cves: CVE-2024-24825 Source advisory: OSV:PYSEC-2024-125...
comdirac (>=0.22.0, <=1.3.3), ctadirac (>=2.0.0a7, <=2.0.6) +3 more potentially affected by CVE-2024-24825 via dirac (7.3.38)
dirac PYPI version 7.3.38 is affected by a known vulnerability. The following packages have a transitive dependency on dirac and may be impacted: - comdirac =0.22.0, =2.0.0a7, =34.0.0, =10.3.0a3, =10.4.23 - lhcbwebdirac 5.3.0a2 Source cves: CVE-2024-24825 Source advisory: OSV:PYSEC-2024-125...
lhcbdirac (>=10.2.5, <=10.2.16) potentially affected by CVE-2024-24825 via dirac (7.2.52)
dirac PYPI version 7.2.52 is affected by a known vulnerability. The following packages have a transitive dependency on dirac and may be impacted: - lhcbdirac =10.2.5, =10.2.16 Source cves: CVE-2024-24825 Source advisory: OSV:PYSEC-2024-125...
DIRAC Information Disclosure Vulnerability
DIRAC is an open source software framework for distributed computing from the DIRAC Project. An information disclosure vulnerability exists in DIRAC versions prior to 8.0.0 through 8.0.37, which stems from the presence of an information disclosure vulnerability...
CVE-2024-24825
DIRAC is a distributed resource framework. In affected versions any user could get a token that has been requested by another user/agent. This may expose resources to unintended parties. This issue has been addressed in release version 8.0.37. Users are advised to upgrade. There are no known...
CVE-2024-24825
DIRAC’s TokenManager vulnerability (CVE-2024-24825) affects DIRAC before version 8.0.37, allowing any user to obtain a token requested by another user/agent and potentially expose resources. The issue is fixed in 8.0.37; upg rade to that release. Other sources (GitHub advisory GHSA-59qj-jcjv-662j...
comdirac (>=0.22.0, <=1.3.3), ctadirac (>=2.0.0a0, <=2.2.35) +3 more potentially affected by CVE-2024-24825 via dirac (>=7.2.30, <=8.0.30)
dirac PYPI version =7.2.30, =0.22.0, =2.0.0a0, =33.0.0a1, =10.2.5, =10.4.23 - lhcbwebdirac 5.3.0a2 Source cves: CVE-2024-24825 Source advisory: MEND:CVE-2024-24825...
CVE-2024-24825 TokenManager not checking permissions on cached tokens in DIRAC
DIRAC is a distributed resource framework. In affected versions any user could get a token that has been requested by another user/agent. This may expose resources to unintended parties. This issue has been addressed in release version 8.0.37. Users are advised to upgrade. There are no known...
CVE-2024-24825 TokenManager not checking permissions on cached tokens in DIRAC
DIRAC is a distributed resource framework. In affected versions any user could get a token that has been requested by another user/agent. This may expose resources to unintended parties. This issue has been addressed in release version 8.0.37. Users are advised to upgrade. There are no known...
ilcdirac (>=34.0.0a1, <=34.0.0a3) potentially affected by CVE-2024-24825 via dirac (7.3.34)
dirac PYPI version 7.3.34 is affected by a known vulnerability. The following packages have a transitive dependency on dirac and may be impacted: - ilcdirac =34.0.0a1, =34.0.0a3 Source cves: CVE-2024-24825 Source advisory: OSV:GHSA-59QJ-JCJV-662J...
comdirac (>=0.22.0, <=1.3.3), ctadirac (>=2.0.0a0, <=2.2.35) +3 more potentially affected by CVE-2024-24825 via dirac (>=7.2.30, <=8.0.30)
dirac PYPI version =7.2.30, =0.22.0, =2.0.0a0, =33.0.0a1, =10.2.5, =10.4.23 - lhcbwebdirac 5.3.0a2 Source cves: CVE-2024-24825 Source advisory: GHSA-59QJ-JCJV-662J...
ilcdirac (>=34.0.0a4, <=34.0.0a8) potentially affected by CVE-2024-24825 via dirac (7.3.36)
dirac PYPI version 7.3.36 is affected by a known vulnerability. The following packages have a transitive dependency on dirac and may be impacted: - ilcdirac =34.0.0a4, =34.0.0a8 Source cves: CVE-2024-24825 Source advisory: OSV:GHSA-59QJ-JCJV-662J...
ctadirac (>=2.0.33, <=2.1.13) potentially affected by CVE-2024-24825 via dirac (7.3.23)
dirac PYPI version 7.3.23 is affected by a known vulnerability. The following packages have a transitive dependency on dirac and may be impacted: - ctadirac =2.0.33, =2.1.13 Source cves: CVE-2024-24825 Source advisory: OSV:GHSA-59QJ-JCJV-662J...
GHSA-59QJ-JCJV-662J DIRAC's TokenManager does not check permissions on cached tokens
Impact Any user could get a token that has been requested by another user/agent Patches The vulnerability is fixed in version 8.0.37. Workarounds None References...
ilcdirac (33.0.0a1) potentially affected by CVE-2024-24825 via dirac (7.2.30)
dirac PYPI version 7.2.30 is affected by a known vulnerability. The following packages have a transitive dependency on dirac and may be impacted: - ilcdirac 33.0.0a1 Source cves: CVE-2024-24825 Source advisory: OSV:GHSA-59QJ-JCJV-662J...
lhcbdirac (>=10.2.5, <=10.2.16) potentially affected by CVE-2024-24825 via dirac (7.2.52)
dirac PYPI version 7.2.52 is affected by a known vulnerability. The following packages have a transitive dependency on dirac and may be impacted: - lhcbdirac =10.2.5, =10.2.16 Source cves: CVE-2024-24825 Source advisory: OSV:GHSA-59QJ-JCJV-662J...
ctadirac (>=2.2.0a1, <=2.2.35) potentially affected by CVE-2024-24825 via dirac (>=8.0.0, <=8.0.30)
dirac PYPI version =8.0.0, =2.2.0a1, =2.2.35 Source cves: CVE-2024-24825 Source advisory: OSV:GHSA-59QJ-JCJV-662J...
comdirac (>=0.22.0, <=1.3.3), ctadirac (>=2.0.0a7, <=2.0.6) +3 more potentially affected by CVE-2024-24825 via dirac (7.3.38)
dirac PYPI version 7.3.38 is affected by a known vulnerability. The following packages have a transitive dependency on dirac and may be impacted: - comdirac =0.22.0, =2.0.0a7, =34.0.0, =10.3.0a3, =10.4.23 - lhcbwebdirac 5.3.0a2 Source cves: CVE-2024-24825 Source advisory: OSV:GHSA-59QJ-JCJV-662J...
ilcdirac (33.0.0a2) potentially affected by CVE-2024-24825 via dirac (7.2.40)
dirac PYPI version 7.2.40 is affected by a known vulnerability. The following packages have a transitive dependency on dirac and may be impacted: - ilcdirac 33.0.0a2 Source cves: CVE-2024-24825 Source advisory: OSV:GHSA-59QJ-JCJV-662J...
ctadirac (>=2.0.0a0, <=2.0.31) potentially affected by CVE-2024-24825 via dirac (7.3.12)
dirac PYPI version 7.3.12 is affected by a known vulnerability. The following packages have a transitive dependency on dirac and may be impacted: - ctadirac =2.0.0a0, =2.0.31 Source cves: CVE-2024-24825 Source advisory: OSV:GHSA-59QJ-JCJV-662J...