95453 matches found
EUVD-2026-42092
DataEase is an open source data visualization and analysis tool. Prior to 2.10.24, the H2 database JDBC URL validation logic can be bypassed with special Unicode characters whose case-conversion behavior differs between DataEase validation and H2 parsing, allowing attackers to smuggle dangerous...
CVE-2026-53751 DataEase: H2 JDBC URL Filter Bypass Leads to Remote Code Execution (RCE)
DataEase is an open source data visualization and analysis tool. Prior to 2.10.24, the H2 database JDBC URL validation logic can be bypassed with special Unicode characters whose case-conversion behavior differs between DataEase validation and H2 parsing, allowing attackers to smuggle dangerous...
CVE-2026-53730 DataEase: Unauthorized Access to Engine Database via previewSql Endpoint
DataEase is an open source data visualization and analysis tool. Prior to 2.10.24, the /de2api/datasetData/previewSql endpoint lacks the mandatory @DePermit permission validation annotation, allowing any authenticated user to specify datasourceId=-1, access the built-in engine database, execute...
CVE-2026-53730 DataEase: Unauthorized Access to Engine Database via previewSql Endpoint
DataEase is an open source data visualization and analysis tool. Prior to 2.10.24, the /de2api/datasetData/previewSql endpoint lacks the mandatory @DePermit permission validation annotation, allowing any authenticated user to specify datasourceId=-1, access the built-in engine database, execute...
CVE-2026-53730 DataEase: Unauthorized Access to Engine Database via previewSql Endpoint
DataEase is an open source data visualization and analysis tool. Prior to 2.10.24, the /de2api/datasetData/previewSql endpoint lacks the mandatory @DePermit permission validation annotation, allowing any authenticated user to specify datasourceId=-1, access the built-in engine database, execute...
CVE-2026-53730
CVE-2026-53730 — DataEase : Affected product is DataEase (open source data visualization/analysis tool). Before version 2.10.24, the /de2api/datasetData/previewSql endpoint lacks the mandatory @DePermit permission validation, allowing any authenticated user to specify datasourceId=-1, access the ...
records-mover Injection vulnerability
A weakness has been identified in bluelabsio records-mover up to 1.5.4. The affected element is an unknown function of the component Table Object Handler. This manipulation causes SQL Injection. The attack needs to be launched locally. Upgrading to version 1.6.0 is sufficient to fix this issue...
libsodium has Incomplete List of Disallowed Inputs
libsodium before ad3004e, in atypical use cases involving certain custom cryptography or untrusted data to cryptocoreed25519isvalidpoint, mishandles checks for whether an elliptic curve point is valid because it sometimes allows points that aren't in the main cryptographic group.This advisoory...
PYSEC-2026-1530 LangGraph's SQLite is vulnerable to SQL injection via metadata filter key in SQLite checkpointer list method
Context A SQL injection vulnerability exists in LangGraph's SQLite checkpoint implementation that allows attackers to manipulate SQL queries through metadata filter keys. This affects applications that accept untrusted metadata filter keys not just filter values in checkpoint search operations...
PYSEC-2026-1762 Arbitrary Code Execution in pdfminer.six via Crafted PDF Input
Summary pdfminer.six will execute arbitrary code from a malicious pickle file if provided with a malicious PDF file. The CMapDB.loaddata function in pdfminer.six uses pickle.loads to deserialize pickle files. These pickle files are supposed to be part of the pdfminer.six distribution stored in th...
PYSEC-2026-1205 AWS Advanced Python Wrapper: Privilege Escalation in Aurora PostgreSQL instance
Description of Vulnerability: An issue in AWS Wrappers for Amazon Aurora PostgreSQL may allow for privilege escalation to rdssuperuser role. A low privilege authenticated user can create a crafted function that could be executed with permissions of other Amazon Relational Database Service RDS...
ailite (>=6.0.2, <=6.1.10), craydel-database-wrapper (0.0.1) +13 more potentially affected by CVE-2025-12695 via dspy (2.6.27)
dspy PYPI version 2.6.27 is affected by a known vulnerability. The following packages have a transitive dependency on dspy and may be impacted: - ailite =6.0.2, =2.8.0, =0.1.6.dev8, =0.2.0, =1.0.53, =1.4.3, =0.7.0, =0.1.0, =1.9.0, =0.9.0, =0.1.0, =0.1.1, =0.1.3 Source cves: CVE-2025-12695 Source...
PYSEC-2026-1169 Apache Superset data query improperly discloses database schema information to low-privileged guest user
When a guest user accesses a chart in Apache Superset, the API response from the /chart/data endpoint includes a query field in its payload. This field contains the underlying query, which improperly discloses database schema information, such as table names, to the low-privileged guest user. Thi...
Apache Superset data query improperly discloses database schema information to low-privileged guest user
When a guest user accesses a chart in Apache Superset, the API response from the /chart/data endpoint includes a query field in its payload. This field contains the underlying query, which improperly discloses database schema information, such as table names, to the low-privileged guest user.This...
PyLoad vulnerable to SQL Injection via API /json/add_package in add_links parameter
SummaryThe parameter addlinks in the API /json/addpackage is vulnerable to SQL Injection. SQL injection vulnerabilities can lead to sensitive data leakage. Details- Affected file:https://github.com/pyload/pyload/blob/develop/src/pyload/core/database/filedatabase.pyL271- Affected...
CVE-2026-14969
A flaw was found in 389-ds-base where the LDBM backend attribute encryption uses a hardcoded static initialization vector for AES-CBC and 3DES-CBC operations, allowing an attacker with privileged filesystem access to detect plaintext equality across encrypted entries by comparing ciphertext block...
django-database-conn-pool (>=1.1.0, <=1.1.1), django-learngual (>=0.39.0, <=0.895.0) +2 more potentially affected by CVE-2026-53877 via django (4.0.8)
django PYPI version 4.0.8 is affected by a known vulnerability. The following packages have a transitive dependency on django and may be impacted: - django-database-conn-pool =1.1.0, =0.39.0, =0.11.21, =0.50.3 Source cves: CVE-2026-53877 Source advisory: OSV:GHSA-CRHF-3PFG-W68W...
django-database-conn-pool (>=1.1.0, <=1.1.1), django-learngual (>=0.39.0, <=0.895.0) +2 more potentially affected by CVE-2026-48588 via django (4.0.8)
django PYPI version 4.0.8 is affected by a known vulnerability. The following packages have a transitive dependency on django and may be impacted: - django-database-conn-pool =1.1.0, =0.39.0, =0.11.21, =0.50.3 Source cves: CVE-2026-48588 Source advisory: OSV:GHSA-3H9F-R86X-QVJX...
PYSEC-2026-1390 Frappe has possibility of SQL injection due to improper validations
Impact An SQL Injection vulnerability has been identified in Frappe Framework which could allow a malicious actor to access sensitive information. Workarounds Upgrading is required, no other workaround is present. Credits Thanks to Thanh of Calif.io for reporting the issue...
Frappe has possibility of SQL injection due to improper validations
ImpactSQL injection could be achieved via a specially crafted request, which could allow malicious person to gain access to sensitive information. WorkaroundsUpgrading is required, no other workaround is present...