276484 matches found
CVE-2026-51914
TransformerOptimus SuperAGI v0.0.14 is vulnerable to Incorrect Access Control in the agent template controller. In affected source snapshots, saveagentastemplate and publishtemplate in superagi/controllers/agenttemplate.py accept caller-supplied agentid or agentexecutionid values and do not verif...
EUVD-2026-91757
TransformerOptimus SuperAGI v0.0.14 contains an incorrect access control vulnerability in deleteuserknowledge in superagi/controllers/knowledges.py. In affected source snapshots, POST /knowledges/delete/knowledgeid deletes the selected knowledge object without requiring authentication in the rout...
EUVD-2026-91758
TransformerOptimus SuperAGI v0.0.14 is vulnerable to Incorrect Access Control in the tool controller. In affected source snapshots, gettool and updatetool in superagi/controllers/tool.py accept a caller-supplied toolid and fail to verify organization ownership through the associated toolkit. A...
EUVD-2026-91759
TransformerOptimus SuperAGI v0.0.14 is vulnerable to Incorrect Access Control in the agent template controller. In affected source snapshots, saveagentastemplate and publishtemplate in superagi/controllers/agenttemplate.py accept caller-supplied agentid or agentexecutionid values and do not verif...
PT-2026-104365
SuperAGI up to v0.0.14 contains an improper access control vulnerability in the agent execution controller. In affected source snapshots, create agent execution and create agent run in superagi/controllers/agent execution.py accept a caller-supplied agent id and fail to verify that the referenced...
PT-2026-104371
TransformerOptimus SuperAGI v0.0.14 contains an incorrect access control vulnerability in delete user knowledge in superagi/controllers/knowledges.py. In affected source snapshots, POST /knowledges/delete/knowledge id deletes the selected knowledge object without requiring authentication in the...
PT-2026-104400
MISP contains an improper access control vulnerability in its attribute search and paginated attribute view endpoints. When a user queries for soft-deleted attributes e.g., via the deleted-attributes search or the paginated attribute listing, the application returned soft-deleted attributes...
PT-2026-104354
Name of the Vulnerable Software and Affected Versions LearnPress versions prior to 4.4.9.1 Description An issue exists where missing authorization allows for the exploitation of incorrectly configured access control security levels. Recommendations Update to version 4.4.9.1 or later...
CVE-2026-51916
TransformerOptimus SuperAGI v0.0.14 contains an incorrect access control vulnerability in deleteuserknowledge in superagi/controllers/knowledges.py. In affected source snapshots, POST /knowledges/delete/knowledgeid deletes the selected knowledge object without requiring authentication in the rout...
CVE-2026-51899
In SuperAGI v0.0.14 and prior, controller endpoints /api/agents/create, /api/agents/schedule, /api/agents/delete, /api/agents/editschedule, /api/agents/stopschedule allow authenticated users from one organization to create, schedule, edit, stop, and delete agents belonging to a different...
PT-2026-104425
Name of the Vulnerable Software and Affected Versions Phproject versions prior to 1.8.7 Description An issue exists in the REST API where object-level authorization is missing. Authenticated users with a valid API key can bypass the security.restrict access confidentiality control because the...
CVE-2026-51904
SuperAGI versions up to v0.0.14 are vulnerable to an improper access control vulnerability within the agent execution controller. Specifically, the functions create_agent_execution and create_agent_run in superagi/controllers/agent_execution.py accept a caller-supplied agent_id but fail to verify...
CVE-2026-51915
TransformerOptimus SuperAGI v0.0.14 is vulnerable to Incorrect Access Control within the tool controller. Specifically, the get_tool and update_tool functions in superagi/controllers/tool.py accept a caller-supplied tool_id but fail to verify if the organization owns the associated toolkit. This ...
CVE-2026-51916
TransformerOptimus SuperAGI v0.0.14 contains an incorrect access control vulnerability in the delete_user_knowledge function located at superagi/controllers/knowledges.py. The POST /knowledges/delete/{knowledge_id} route allows for the deletion of knowledge objects without requiring authenticatio...
CVE-2026-51901
SuperAGI up to 0.0.14 is vulnerable to Incorrect Access Control. The agent execution controller endpoint /api/agentexecutions/schedule allows authenticated users from one organization to schedule existing agents belonging to a different organization without proper authorization checks. The endpoi...
CVE-2026-51904
SuperAGI up to v0.0.14 contains an improper access control vulnerability in the agent execution controller. In affected source snapshots, createagentexecution and createagentrun in superagi/controllers/agentexecution.py accept a caller-supplied agentid and fail to verify that the referenced agent...
CVE-2026-51914
TransformerOptimus SuperAGI v0.0.14 is vulnerable to Incorrect Access Control in the agent template controller. In affected source snapshots, saveagentastemplate and publishtemplate in superagi/controllers/agenttemplate.py accept caller-supplied agentid or agentexecutionid values and do not verif...
CVE-2026-103956: Missing Authentication for Critical Function
Missing authentication for critical function in the authentication dependency in Loom for AWS before 1.6.1 allowed remote actors to obtain super-admin authority over the agent control plane, including registering tool servers, reading stored integration credentials, and rewriting the IAM role...
CVE-2026-39717: Missing Authorization
Missing Authorization vulnerability in ThimPress LearnPress learnpress allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects LearnPress: from n/a through 4.4.10...
CVE-2026-39444: Authorization Bypass Through User-Controlled Key
Authorization Bypass Through User-Controlled Key vulnerability in PublishPress PublishPress Series organize-series allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects PublishPress Series: from n/a through 3.1.3...