3337 matches found
CVE-2026-50564
Fission is an open-source, Kubernetes-native serverless framework that simplifies the deployment of functions and applications on Kubernetes. Prior to version 1.24.0, Fission's Environment CRD exposes spec.runtime.podSpec and spec.builder.podSpec, which are merged into the Kubernetes pod specs fo...
CVE-2026-50566 Fission: Environment Runtime.Container and Builder.Container SecurityContext bypass allows privileged pod creation
Fission is an open-source, Kubernetes-native serverless framework that simplifies the deployment of functions and applications on Kubernetes. Prior to version 1.24.0, a tenant with environments.fission.io create/update RBAC can run privileged / allowPrivilegeEscalation / dangerous-capability...
CVE-2026-50566
Fission prior to v1.24.0 is affected: a tenant with environments.fission.io create/update RBAC could run privileged / allowPrivilegeEscalation / dangerous-capability containers in the Fission function or builder namespace, scheduled under the executor’s high-privilege service account. This enable...
CVE-2026-50565 Fission builder pods auto-mount the fission-builder ServiceAccount token in the user-supplied builder container
Fission is an open-source, Kubernetes-native serverless framework that simplifies the deployment of functions and applications on Kubernetes. Prior to version 1.24.0, Fission builder pods were created with ServiceAccountName: fission-builder and no AutomountServiceAccountToken: false, so the...
Fission security vulnerabilities
Fission is an open-source function deployment framework based on Kubernetes. Versions of Fission prior to 1.24.0 contained security vulnerabilities. These vulnerabilities stemmed from tenants with permissions to execute privileged/allowed-privileged/hazardous containers, under the account with hi...
EulerOS 2.0 SP13 : kata-containers (EulerOS-SA-2026-2335)
"According to the versions of the kata-containers package installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : gRPC-Go is the Go language implementation of gRPC. Versions prior to 1.79.3 have an authorization bypass resulting from improper input...
EulerOS 2.0 SP13 : kata-containers (EulerOS-SA-2026-2292)
"According to the versions of the kata-containers package installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : gRPC-Go is the Go language implementation of gRPC. Versions prior to 1.79.3 have an authorization bypass resulting from improper input...
openshell-sandbox-poc
OpenShell + Kata Containers: Dual-Protection PoC A proof-of-c...
EulerOS 2.0 SP11 : kata-containers (EulerOS-SA-2026-2246)
"According to the versions of the kata-containers package installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : gRPC-Go is the Go language implementation of gRPC. Versions prior to 1.79.3 have an authorization bypass resulting from improper input...
EulerOS 2.0 SP11 : kata-containers (EulerOS-SA-2026-2208)
"According to the versions of the kata-containers package installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : gRPC-Go is the Go language implementation of gRPC. Versions prior to 1.79.3 have an authorization bypass resulting from improper input...
CVE-2026-1248
IBM Business Automation Workflow containers and traditional may leak information about its database structure in error messages...
CVE-2026-5926
IBM Verify Identity Access Container 11.0 through 11.0.2 and IBM Security Verify Access Container 10.0 through 10.0.9.1 and IBM Verify Identity Access 11.0 through 11.0.2 and IBM Security Verify Access 10.0 through 10.0.9.1 uses weaker than expected cryptographic algorithms that could allow an...
Access Control Bypass
Overview vantage6 is a vantage6 command line interface Affected versions of this package are vulnerable to Access Control Bypass due to improper restrictions in the node process. An attacker can access input and output files belonging to other algorithms by executing malicious code within algorit...
CVE-2026-33814 affecting package kata-containers for versions less than 3.19.1.kata3-4
CVE-2026-33814 affecting package kata-containers for versions less than 3.19.1.kata3-4. A patched version of the package is available...
CVE-2026-33814 affecting package kata-containers-cc for versions less than 3.15.0.aks0-12
CVE-2026-33814 affecting package kata-containers-cc for versions less than 3.15.0.aks0-12. A patched version of the package is available...
OESA-2026-2557 kata-containers security update
This is core component of Kata Container, to make it work, you need a isulad/docker engine. Security Fixes: 'This vulnerability was fixed in Kata Containers 3.31.0:', 'Description:\n\nIn the runtime-rs standalone virtio-fs path, Kata Containers runs virtiofsd\nas root with --sandbox none --seccom...
CVE-2026-41567
Moby is an open source container framework. In versions prior to 29.5.1 and in moby/moby v2 prior to v2.0.0-beta.14, when a compressed archive is uploaded to a container via "PUT /containers/id/archive" or piped through "docker cp -", the daemon resolves decompression binaries such as "xz" or...
PT-2026-50570
Name of the Vulnerable Software and Affected Versions vantage6 versions prior to 5.0.0 Description Malicious algorithms can potentially access input and output files belonging to other algorithms. Recommendations Update to version 5.0.0. As a temporary workaround, verify and restrict the algorith...
PT-2026-49249
Impact Malicious algorithms can potentially access other algorithms input and output files. Patches Todo Workarounds Verify and restrict the algorithm containers that are allowed to run on your node. See here on how to do this. References https://docs.vantage6.ai/usage/running-the-node/security F...