6741 matches found
MitM on Jenkins Maven Plugin
Jenkins Maven Plugin 2.17 and earlier bundled a version of the commons-httpclient library with the vulnerability CVE-2012-6153 that incorrectly verified SSL certificates, making it susceptible to man-in-the-middle attacks. Maven Plugin 3.0 no longer has a dependency on commons-httpclient...
Creation of Temporary File With Insecure Permissions in logilab-commons
The Execute class in shellutils in logilab-common before 0.61.0 uses tempfile.mktemp, which allows local users to have an unspecified impact by pre-creating the temporary file...
GHSA-G5M2-22H2-RR3J Creation of Temporary File With Insecure Permissions in logilab-commons
The Execute class in shellutils in logilab-common before 0.61.0 uses tempfile.mktemp, which allows local users to have an unspecified impact by pre-creating the temporary file...
Improper Link Resolution Before File Access in logilab-commons
The 1 extractkeysfrompdf and 2 fillpdf functions in pdfext.py in logilab-common before 0.61.0 allows local users to overwrite arbitrary files and possibly have other unspecified impact via a symlink attack on /tmp/toto.fdf...
GHSA-RR52-WG7F-8875 Improper Link Resolution Before File Access in logilab-commons
The 1 extractkeysfrompdf and 2 fillpdf functions in pdfext.py in logilab-common before 0.61.0 allows local users to overwrite arbitrary files and possibly have other unspecified impact via a symlink attack on /tmp/toto.fdf...
GHSA-V7CM-W955-PJ6G Improper Input Validation Apache Commons Email
If a user of Apache Commons Email typically an application programmer passes unvalidated input as the so-called "Bounce Address", and that input contains line-breaks, then the email details recipients, contents, etc. might be manipulated. Mitigation: Users should upgrade to Commons-Email 1.5. You...
Improper Input Validation Apache Commons Email
If a user of Apache Commons Email typically an application programmer passes unvalidated input as the so-called "Bounce Address", and that input contains line-breaks, then the email details recipients, contents, etc. might be manipulated. Mitigation: Users should upgrade to Commons-Email 1.5. You...
com.datastax.spark:spark-cassandra-connector-demos_2.10 (>=1.0.0-rc3, <=1.0.6), com.datastax.spark:spark-cassandra-connector-java_2.10 (>=1.0.0-rc3, <=1.0.6) +111 more potentially affected by CVE-2011-4461 via org.eclipse.jetty:jetty-server (7.6.8.v20121106)
org.eclipse.jetty:jetty-server MAVEN version 7.6.8.v20121106 is affected by a known vulnerability. The following packages have a transitive dependency on org.eclipse.jetty:jetty-server and may be impacted: - com.datastax.spark:spark-cassandra-connector-demos2.10 =1.0.0-rc3, =1.0.0-rc3,...
GHSA-R2XF-W5PJ-9PW8 Apache Syncope JEXL Code Injection
Apache Syncope 1.0.0 before 1.0.9 and 1.1.0 before 1.1.7 allows remote administrators to execute arbitrary Java code via vectors related to Apache Commons JEXL expressions, "derived schema definition," "user / role templates," and "account links of resource mappings."...
Apache Syncope JEXL Code Injection
Apache Syncope 1.0.0 before 1.0.9 and 1.1.0 before 1.1.7 allows remote administrators to execute arbitrary Java code via vectors related to Apache Commons JEXL expressions, "derived schema definition," "user / role templates," and "account links of resource mappings."...
GHSA-FQ9F-9WV9-RFMG Improper Certificate Validation in Jenkins
Jenkins 2.73.1 and earlier, 2.83 and earlier bundled a version of the commons-httpclient library with the vulnerability CVE-2012-6153 that incorrectly verified SSL certificates, making it susceptible to man-in-the-middle attacks. This library is widely used as a transitive dependency in Jenkins...
Improper Certificate Validation in Jenkins
Jenkins 2.73.1 and earlier, 2.83 and earlier bundled a version of the commons-httpclient library with the vulnerability CVE-2012-6153 that incorrectly verified SSL certificates, making it susceptible to man-in-the-middle attacks. This library is widely used as a transitive dependency in Jenkins...
GHSA-F7F6-XRWC-9C57 Improper Input Validation in Jenkins
Jenkins 2.73.1 and earlier, 2.83 and earlier bundled a version of the commons-fileupload library with the denial-of-service vulnerability known as CVE-2016-3092. The fix for that vulnerability has been backported to the version of the library bundled with Jenkins...
Security Bulletin: Multiple Vulnerabilities have been identified in IBM Cloud Pak System
Summary Multiple Vulnerabilities have been identified in IBM Cloud Pak System. Cloud Pak System has addressed these vulnerabilities. Vulnerability Details CVEID: CVE-2021-36090 DESCRIPTION: Apache Commons Compress is vulnerable to a denial of service, caused by an out-of-memory error when large...
ch.hortis.sonar:sonar-commons (0.2), ch.hortis.sonar:sonar-maven-plugin (0.2) potentially affected by CVE-2018-3258 via mysql:mysql-connector-java (5.0.2)
mysql:mysql-connector-java MAVEN version 5.0.2 is affected by a known vulnerability. The following packages have a transitive dependency on mysql:mysql-connector-java and may be impacted: - ch.hortis.sonar:sonar-commons 0.2 - ch.hortis.sonar:sonar-maven-plugin 0.2 Source cves: CVE-2018-3258 Sourc...
Jenkins CLI Deserialization of Untrusted Data vulnerability
The Jenkins CLI subsystem in Jenkins before 1.638 and LTS before 1.625.2 allows remote attackers to execute arbitrary code via a crafted serialized Java object, related to a problematic webapps/ROOT/WEB-INF/lib/commons-collections-.jar file and the "Groovy variant in ysoserial"...
net.osgiliath.framework:net.osgiliath.features.karaf-features-full (>=0.0.1, <=0.0.3), net.osgiliath.framework:net.osgiliath.features.karaf-features-jpa (>=0.0.1, <=0.0.3) +48 more potentially affected by CVE-2015-7501 via org.apache.servicemix.bundles:org.apache.servicemix.bundles.commons-collections (>=3.2.1_1, <=3.2.1_3)
org.apache.servicemix.bundles:org.apache.servicemix.bundles.commons-collections MAVEN version =3.2.11, =0.0.1, =0.0.1, =0.0.1, =0.0.1, =0.0.1, =0.0.1, =0.0.1, =0.0.1, =0.0.1, =0.0.1, =0.0.1, =0.0.1, =2.2.0, =1.0.2, =1.0.8 - org.frie...
GHSA-FJQ5-5J5F-MVXH Deserialization of Untrusted Data in Apache commons collections
It was found that the Apache commons-collections library permitted code execution when deserializing objects involving a specially constructed chain of classes. A remote attacker could use this flaw to execute arbitrary code with the permissions of the application using the commons-collections...
Deserialization of Untrusted Data in Apache commons collections
It was found that the Apache commons-collections library permitted code execution when deserializing objects involving a specially constructed chain of classes. A remote attacker could use this flaw to execute arbitrary code with the permissions of the application using the commons-collections...
ch.marcus-schulte.maven:hivedoc-plugin (>=1.0.0, <=1.0.2), checkstyle:checkstyle (>=5.0-beta01, <=5.0) +170 more potentially affected by CVE-2015-7501 via commons-collections:commons-collections (2.0)
commons-collections:commons-collections MAVEN version 2.0 is affected by a known vulnerability. The following packages have a transitive dependency on commons-collections:commons-collections and may be impacted: - ch.marcus-schulte.maven:hivedoc-plugin =1.0.0, =5.0-beta01, =1.0.0, =1.10.3, =2.8.0...