Lucene search
+L

18 matches found

EUVD
EUVD
•added 2026/10/23 7:04 p.m.•8 views

EUVD-2026-109127

An incomplete list of disallowed inputs in the Python code validator of the runscript tool in AWS MCP Server might allow an authenticated remote user to execute arbitrary code within their own isolated session environment via a crafted script. AWS fixed this issue service-side. No customer action...

6.4CVSS6.8AI score0.00306EPSS
SaveExploits0References1
Positive Technologies
Positive Technologies
•added 2026/10/23 12:00 a.m.•7 views

PT-2026-122202

Name of the Vulnerable Software and Affected Versions AWS MCP Server affected versions not specified Description An incomplete list of disallowed inputs in the Python code validator of the 'run script' tool allows an authenticated remote user to execute arbitrary code within their own isolated...

6.4CVSS6.7AI score0.00306EPSS
SaveExploits0References4
IBM Security Bulletins
IBM Security Bulletins
•added 2026/08/17 8:50 p.m.•33 views

Security Bulletin: Unauthenticated Remote Code Execution via Auto-Login Bypass and Code Validation

Summary A vulnerability allowed unauthenticated attackers to achieve remote code execution on default-configured instances. The vulnerability combined two distinct issues: an unauthenticated endpoint that issued superuser bearer tokens to any network caller, and a code validation endpoint that...

9.8CVSS8.8AI score0.28658EPSS
SaveExploits10Affected Software1
Packet Storm News
Packet Storm News
•added 2026/08/17 12:00 a.m.•18 views

Securing AI-Generated Code: A Just-In-Time Vulnerability Detection and Remediation Pipeline

AI-assisted development tools generate vulnerable code at significant rates, yet few automated mechanisms exist to detect, enrich, fix, and verify security issues at development velocity, particularly ones that ground remediation in real-world threat context. This paper presents an automated...

5.6AI score
SaveExploits0
vulnersOsv
vulnersOsv
•added 2026/08/04 11:34 a.m.•4 views

dike (>=0.1.0, <=0.4.0), liara (>=2.1.0, <=2.3.2) +9 more potentially affected by CVE-2026-61632 via pymdown-extensions (8.2.0)

pymdown-extensions PYPI version 8.2.0 is affected by a known vulnerability. The following packages have a transitive dependency on pymdown-extensions and may be impacted: - dike =0.1.0, =2.1.0, =0.1.0, =0.19.1, =0.13.0, =0.3.0, =2.2.0, =0.1.0, =0.1.6 Source cves: CVE-2026-61632 Source advisory:...

5.3CVSS5.8AI score0.00403EPSS
SaveExploits0
NVD
NVD
•added 2026/06/30 11:17 p.m.•29 views

CVE-2026-56777

n8n before 2.25.7 and 2.26.x before 2.26.2 contains an abstract syntax tree AST security validator bypass in the Python Code node. An authenticated user with permission to create or modify workflows containing a Python Code node can bypass the validator and access the task executor module...

5.3CVSS0.00326EPSS
SaveExploits0References2
EUVD
EUVD
•added 2025/10/03 8:07 p.m.•21 views

EUVD-2021-34131

Malicious code in bioql PyPI...

9.8CVSS6.3AI score0.00749EPSS
SaveExploits0References5
OSSF Malicious Packages
OSSF Malicious Packages
•added 2024/06/25 1:48 p.m.•11 views

Malicious code in area-code_validator (RubyGems)

--- -= Per source details. Do not edit below this line.=-...

5.3AI score
SaveExploits0References1
CNNVD
CNNVD
•added 2023/09/19 12:00 a.m.•19 views

WordPress plugin Serial Codes Generator and Validator with WooCommerce Support Cross-Site Scripting Vulnerability

WordPress and WordPress plugin are both products of the WordPress Foundation.WordPress is a blogging platform developed using the PHP language. The platform supports personal blog sites on PHP and MySQL servers.WordPress plugin is an application plugin. A cross-site scripting vulnerability exists...

4.8CVSS6.1AI score0.00475EPSS
SaveExploits2References2
NVD
NVD
•added 2022/12/29 9:15 a.m.•40 views

CVE-2021-4295

A vulnerability classified as problematic was found in ONC code-validator-api up to 1.0.30. This vulnerability affects the function vocabularyValidationConfigurations of the file src/main/java/org/sitenv/vocabularies/configuration/CodeValidatorApiConfiguration.java of the component XML Handler. T...

9.8CVSS0.00749EPSS
SaveExploits0References5
osv_cve
osv_cve
•added 2022/12/29 9:15 a.m.•32 views

CVE-2021-4295

A vulnerability classified as problematic was found in ONC code-validator-api up to 1.0.30. This vulnerability affects the function vocabularyValidationConfigurations of the file src/main/java/org/sitenv/vocabularies/configuration/CodeValidatorApiConfiguration.java of the component XML Handler. T...

9.8CVSS6.9AI score
SaveExploits0References5
Prion
Prion
•added 2022/12/29 9:15 a.m.•25 views

Xxe

A vulnerability classified as problematic was found in ONC code-validator-api up to 1.0.30. This vulnerability affects the function vocabularyValidationConfigurations of the file src/main/java/org/sitenv/vocabularies/configuration/CodeValidatorApiConfiguration.java of the component XML Handler. T...

7.5CVSS9.4AI score0.00749EPSS
SaveExploits0References5Affected Software1
Mend
Mend
•added 2022/12/29 8:08 a.m.•8 views

CVE-2021-4295

A vulnerability classified as problematic was found in ONC code-validator-api up to 1.0.30. This vulnerability affects the function vocabularyValidationConfigurations of the file src/main/java/org/sitenv/vocabularies/configuration/CodeValidatorApiConfiguration.java of the component XML Handler. T...

9.8CVSS0.00749EPSS
SaveExploits0References5
Cvelist
Cvelist
•added 2022/12/29 8:08 a.m.•44 views

CVE-2021-4295 ONC code-validator-api XML CodeValidatorApiConfiguration.java vocabularyValidationConfigurations xml external entity reference

A vulnerability classified as problematic was found in ONC code-validator-api up to 1.0.30. This vulnerability affects the function vocabularyValidationConfigurations of the file src/main/java/org/sitenv/vocabularies/configuration/CodeValidatorApiConfiguration.java of the component XML Handler. T...

5.5CVSS9.8AI score0.00749EPSS
SaveExploits0References5
CVE
CVE
•added 2022/12/29 8:08 a.m.•83 views

CVE-2021-4295

ONC code-validator-api (versions up to 1.0.30) contains an XML External Entity (XXE) issue in vocabularyValidationConfigurations of CodeValidatorApiConfiguration.java. The vulnerability allows external entity reference manipulation and is addressed by upgrading to version 1.0.31. The linked patch...

9.8CVSS7.5AI score0.00749EPSS
SaveExploits0References5Affected Software1
Positive Technologies
Positive Technologies
•added 2022/12/29 12:00 a.m.•19 views

PT-2022-11751 · Unknown · Onc Code-Validator-Api

Name of the Vulnerable Software and Affected Versions: ONC code-validator-api versions up to 1.0.30 Description: A vulnerability was found in the ONC code-validator-api, affecting the vocabularyValidationConfigurations function of the XML Handler component. The issue leads to an xml external enti...

9.8CVSS5.8AI score0.00749EPSS
SaveExploits0References10
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2022/12/29 12:00 a.m.•8 views

CVE-2021-4295: Improper Restriction of XML External Entity Reference

A vulnerability classified as problematic was found in ONC code-validator-api up to 1.0.30. This vulnerability affects the function vocabularyValidationConfigurations of the file src/main/java/org/sitenv/vocabularies/configuration/CodeValidatorApiConfiguration.java of the component XML Handler. T...

9.8CVSS5.1AI score0.00749EPSS
SaveExploits0References3
CNNVD
CNNVD
•added 2022/12/29 12:00 a.m.•25 views

code-validator-api Code-related vulnerabilities

code-validator-api is an open source library of source code for vocabulary validator APIs and services from the Office of the National Coordinator for Health IT. A code-validator-api vulnerability exists in versions prior to 1.0.30. An attacker exploited this vulnerability to cause xml external...

9.8CVSS6.7AI score0.00749EPSS
SaveExploits0References6
Rows per page
Query Builder