42587 matches found
CVE-2026-51872
Devika v1.0 is vulnerable to a Code Injection vulnerability (CWE-94) located in the Runner.run_code function within src/agents/runner/runner.py. This flaw allows for the execution of arbitrary code. While the documents confirm the vulnerability exists and provide a CVSS 3.1 base score of 9.8 (CRI...
CVE-2026-51861
bisheng 2.3.0, 2.4.0, and 2.4.0-beta1 is vulnerable to Code Injection in src/backend/bisheng/api/v1/validate.py...
CVE-2026-51871
Devika v1.0 is vulnerable to Code Injection in the Runner.execute function in src/agents/runner/runner.py which allows an attacker to achieve arbitrary code execution by exploiting the direct execution of LLM-generated content...
CVE-2026-51872
Devika v1.0 is vulnerable to Code Injection via the Runner.runcode function in src/agents/runner/runner.py...
EUVD-2026-90412
Devika v1.0 is vulnerable to Code Injection in the Runner.execute function in src/agents/runner/runner.py which allows an attacker to achieve arbitrary code execution by exploiting the direct execution of LLM-generated content...
EUVD-2026-90411
Devika v1.0 is vulnerable to Code Injection via the Runner.runcode function in src/agents/runner/runner.py...
EUVD-2026-90419
bisheng 2.3.0, 2.4.0, and 2.4.0-beta1 is vulnerable to Code Injection in src/backend/bisheng/api/v1/validate.py...
PT-2026-103350
External control of system or configuration setting vulnerability in The Wikimedia Foundation MediaWiki CentralAuth extension allows Code Injection. This issue affects MediaWiki CentralAuth extension: 1.46, 1.45, and 1.43...
PT-2026-103612
bisheng 2.3.0, 2.4.0, and 2.4.0-beta1 is vulnerable to Code Injection in src/backend/bisheng/api/v1/validate.py...
PT-2026-103620
Name of the Vulnerable Software and Affected Versions Devika version 1.0 Description Code Injection is possible through the run code function within the Runner class located in src/agents/runner/runner.py. Recommendations As a temporary workaround, consider disabling the run code function until a...
PT-2026-103619
Name of the Vulnerable Software and Affected Versions Devika version 1.0 Description Code Injection is possible in the execute function within src/agents/runner/runner.py. This issue occurs due to the direct execution of content generated by a Large Language Model LLM, which allows an attacker to...
AlmaLinux 9.2 [TuxCare] Security Update: python3.11-setuptools / python3.11-setuptools-wheel Multiple Vulnerabilities (ALMALINUX9.2:CLSA-2025:1764615456)
The AlmaLinux 9.2 host has packages installed that are affected by multiple vulnerabilities as referenced in the TuxCare ALMALINUX9.2:CLSA-2025:1764615456 advisory. - A vulnerability in the packageindex module of pypa/setuptools versions up to 69.1.1 allows for remote code execution via its...
AlmaLinux 9.6 [TuxCare] Security Update: gpsd-minimal / gpsd-minimal-clients (ALMALINUX9.6:CLSA-2026:1789034846)
The AlmaLinux 9.6 host has packages installed that are affected by a vulnerability as referenced in the TuxCare ALMALINUX9.6:CLSA-2026:1789034846 advisory. - gpsd through release-3.27.5, fixed at commit 4c06658, contains a code injection vulnerability in the gpsprof utility that allows an attacke...
CentOS Linux 6 [TuxCare] Security Update: vim-X11 / vim-common / vim-enhanced / vim-filesystem / vim-minimal Multiple Vulnerabilities (CENTOS6:CLSA-2026:1782153265)
The CentOS Linux 6 host has packages installed that are affected by multiple vulnerabilities as referenced in the TuxCare CENTOS6:CLSA-2026:1782153265 advisory. - Vim is an open source, command line text editor. Prior to version 9.2.0495, a Vimscript code injection vulnerability exists in...
Unity Linux 20.1050e / 20.1060e / 20.1070e Security Update: perl-DBI (UTSA-2026-126158)
The Unity Linux 20 host has a package installed that is affected by a vulnerability as referenced in the UTSA-2026-126158 advisory. DBI versions before 1.650 for Perl are vulnerable to code injection via caller-influenced Profile. When a string is assigned to a DBI handle's Profile attribute, DBI...
CentOS Linux 7 [TuxCare] Security Update: ImageMagick / ImageMagick-c++ / ImageMagick-c++-devel / etc Multiple Vulnerabilities (CENTOS7:CLSA-2026:1773924173)
The CentOS Linux 7 host has packages installed that are affected by multiple vulnerabilities as referenced in the TuxCare CENTOS7:CLSA-2026:1773924173 advisory. - ImageMagick is free and open-source software used for editing and manipulating digital images. Versions 14.10.1 and below have a NULL...
Rocky Linux 9.6 [TuxCare] Security Update: gpsd-minimal / gpsd-minimal-clients (ALMALINUX9.6:CLSA-2026:1789034846)
The Rocky Linux 9.6 host has packages installed that are affected by a vulnerability as referenced in the TuxCare ALMALINUX9.6:CLSA-2026:1789034846 advisory. - gpsd through release-3.27.5, fixed at commit 4c06658, contains a code injection vulnerability in the gpsprof utility that allows an...
AlmaLinux 9.2 [TuxCare] Security Update: gpsd-minimal / gpsd-minimal-clients (ALMALINUX9.2:CLSA-2026:1789389842)
The AlmaLinux 9.2 host has packages installed that are affected by a vulnerability as referenced in the TuxCare ALMALINUX9.2:CLSA-2026:1789389842 advisory. - gpsd through release-3.27.5, fixed at commit 4c06658, contains a code injection vulnerability in the gpsprof utility that allows an attacke...
CVE-2026-86131 Fireware OS Code Injection in BOVPN Over TLS Client Allows Remote Code Execution
A code injection vulnerability in WatchGuard Fireware OS's BOVPN Over TLS client configuration handling allows an attacker who controls the remote VPN server to execute arbitrary commands as root on the connecting Firebox...
CVE-2026-86131
A code injection vulnerability exists in the WatchGuard Fireware OS during the handling of BOVPN Over TLS client configurations. This flaw allows an attacker who controls a remote VPN server to execute arbitrary commands with root privileges on the connecting Firebox . No specific patch versions ...