4 matches found
apish (1.2.11), apish-fork (1.2.12) +6 more potentially affected by CVE-2016-1000249 via fury-adapter-swagger (>=0.6.2, <=0.9.1)
fury-adapter-swagger NPM version =0.6.2, =1.1.0, =1.0.0, =1.2.8, =0.1.1, =0.3.35 Source cves: CVE-2016-1000249 Source advisory: MEND:CVE-2016-1000249...
CVE-2016-1000249
The CVE entry relates to fury-adapter-swagger. Versions 0.2.0 through 0.9.7 contain a weakness that allows an attacker to read arbitrary files from the system (e.g., /etc/passwd) and can cause a DoS by reading sensitive data or exhausting memory. Remediation: upgrade to version 0.9.7 or later. Th...
CVE-2016-1000249
creationtimestamp| type| source ---|---|--- 2020-09-01 16:38:33+00:00| published-proof-of-concept| https://github.com/advisories/GHSA-2r7f-4h2c-5x73...
apish (1.2.11), apish-fork (1.2.12) +6 more potentially affected by CVE-2016-1000249 via fury-adapter-swagger (>=0.6.2, <=0.9.1)
fury-adapter-swagger NPM version =0.6.2, =1.1.0, =1.0.0, =1.2.8, =0.1.1, =0.3.35 Source cves: CVE-2016-1000249 Source advisory: OSV:GHSA-2R7F-4H2C-5X73...