101 matches found
CVE-2026-32588
Authenticated DoS over CQL in Apache Cassandra 4.0, 4.1, 5.0 allows authenticated user to raise query latencies via repeated password changes. Users are recommended to upgrade to version 4.0.20, 4.1.11, 5.0.7, which fixes this issue...
CVE-2026-32588: Uncontrolled Resource Consumption
Authenticated DoS over CQL in Apache Cassandra 4.0, 4.1, 5.0 allows authenticated user to raise query latencies via repeated password changes. Users are recommended to upgrade to version 4.0.20, 4.1.11, 5.0.7, which fixes this issue...
Authorizer: CQL/N1QL Injection in Cassandra and Couchbase Backends via fmt.Sprintf String Interpolation
Vulnerability Details CWE: CWE-943 - Improper Neutralization of Special Elements in Data Query Logic All 66+ CQL queries in internal/storage/db/cassandradb/ use fmt.Sprintf to interpolate user-controlled values directly into CQL query strings without parameterization. Unauthenticated endpoints...
PT-2026-33390
Vulnerability Details CWE: CWE-943 - Improper Neutralization of Special Elements in Data Query Logic All 66+ CQL queries in internal/storage/db/cassandradb/ use fmt.Sprintf to interpolate user-controlled values directly into CQL query strings without parameterization. Unauthenticated endpoints...
@ainsleydev/payload-helper (0.0.16), @contentql/core (>=0.1.2, <=0.3.5) +2 more potentially affected by CVE-2026-34750 via @payloadcms/storage-s3 (>=3.0.0-beta.29, <=3.0.0-beta.111)
@payloadcms/storage-s3 NPM version =3.0.0-beta.29, =0.1.2, =0.1.0, =0.1.4, =0.1.5 Source cves: CVE-2026-34750 Source advisory: SNYK:JS-PAYLOADCMSSTORAGES3-15873860...
@ainsleydev/payload-helper (0.0.16), @contentql/core (>=0.1.2, <=0.3.5) +2 more potentially affected by CVE-2026-34750 via @payloadcms/storage-s3 (>=3.0.0-beta.29, <=3.0.0-beta.111)
@payloadcms/storage-s3 NPM version =3.0.0-beta.29, =0.1.2, =0.1.0, =0.1.4, =0.1.5 Source cves: CVE-2026-34750 Source advisory: GHSA-FRQ9-7J6G-V74X...
ca.uhn.hapi.fhir:hapi-fhir-cli-api (>=4.0.0, <=8.8.2), ca.uhn.hapi.fhir:hapi-fhir-cli-app (>=5.6.5, <=7.4.5) +223 more potentially affected by CVE-2026-34361 via ca.uhn.hapi.fhir:org.hl7.fhir.validation (>=1.0.0, <=6.9.3)
ca.uhn.hapi.fhir:org.hl7.fhir.validation MAVEN version =1.0.0, =4.0.0, =5.6.5, =4.1.0, =4.1.0, =4.0.0, =5.0.0, =4.0.0, =5.3.0, =6.2.0, =5.1.0, =6.8.0, =6.4.0, =5.3.0, =4.0.0, =4.0.0, =8.8.2 and more Source cves: CVE-2026-34361 Source advisory: MEND:CVE-2026-34361...
info.cqframework:elm-fhir (>=1.5.5, <=1.5.7), org.opencds.cqf.cql.ls:cql-ls (>=1.5.3, <=1.5.4) +1 more potentially affected by CVE-2026-34361 via ca.uhn.hapi.fhir:org.hl7.fhir.validation (5.5.16)
ca.uhn.hapi.fhir:org.hl7.fhir.validation MAVEN version 5.5.16 is affected by a known vulnerability. The following packages have a transitive dependency on ca.uhn.hapi.fhir:org.hl7.fhir.validation and may be impacted: - info.cqframework:elm-fhir =1.5.5, =1.5.3, =1.5.3, =1.5.4 Source cves:...
info.cqframework:cqf-fhir (>=1.5.10, <=1.5.12), info.cqframework:elm-fhir (>=1.5.8, <=1.5.12) +4 more potentially affected by CVE-2026-34361 via ca.uhn.hapi.fhir:org.hl7.fhir.validation (5.6.15)
ca.uhn.hapi.fhir:org.hl7.fhir.validation MAVEN version 5.6.15 is affected by a known vulnerability. The following packages have a transitive dependency on ca.uhn.hapi.fhir:org.hl7.fhir.validation and may be impacted: - info.cqframework:cqf-fhir =1.5.10, =1.5.8, =1.5.6, =1.5.7, =1.5.7, =1.5.9 Sour...
info.cqframework:elm-fhir (1.5.4), org.opencds.cqf.cql.ls:cql-ls (1.5.2) +1 more potentially affected by CVE-2026-34361 via ca.uhn.hapi.fhir:org.hl7.fhir.validation (5.4.8)
ca.uhn.hapi.fhir:org.hl7.fhir.validation MAVEN version 5.4.8 is affected by a known vulnerability. The following packages have a transitive dependency on ca.uhn.hapi.fhir:org.hl7.fhir.validation and may be impacted: - info.cqframework:elm-fhir 1.5.4 - org.opencds.cqf.cql.ls:cql-ls 1.5.2 -...
ca.uhn.hapi.fhir:org.hl7.fhir.convertors (5.4.8), ca.uhn.hapi.fhir:org.hl7.fhir.validation (5.4.8) +3 more potentially affected by CVE-2026-33180 via ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may (5.4.8)
ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may MAVEN version 5.4.8 is affected by a known vulnerability. The following packages have a transitive dependency on ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may and may be impacted: - ca.uhn.hapi.fhir:org.hl7.fhir.convertors 5.4.8 -...
info.cqframework:elm-fhir (1.5.4), org.opencds.cqf.cql.ls:cql-ls (1.5.2) +1 more potentially affected by CVE-2026-33180 via ca.uhn.hapi.fhir:org.hl7.fhir.validation (5.4.8)
ca.uhn.hapi.fhir:org.hl7.fhir.validation MAVEN version 5.4.8 is affected by a known vulnerability. The following packages have a transitive dependency on ca.uhn.hapi.fhir:org.hl7.fhir.validation and may be impacted: - info.cqframework:elm-fhir 1.5.4 - org.opencds.cqf.cql.ls:cql-ls 1.5.2 -...
info.cqframework:cqf-fhir (>=1.5.10, <=1.5.12), info.cqframework:elm-fhir (>=1.5.8, <=1.5.12) +4 more potentially affected by CVE-2026-33180 via ca.uhn.hapi.fhir:org.hl7.fhir.validation (5.6.15)
ca.uhn.hapi.fhir:org.hl7.fhir.validation MAVEN version 5.6.15 is affected by a known vulnerability. The following packages have a transitive dependency on ca.uhn.hapi.fhir:org.hl7.fhir.validation and may be impacted: - info.cqframework:cqf-fhir =1.5.10, =1.5.8, =1.5.6, =1.5.7, =1.5.7, =1.5.9 Sour...
ca.uhn.hapi.fhir:hapi-fhir-base-test-jaxrsserver-kotlin (>=5.7.7, <=5.7.9), ca.uhn.hapi.fhir:hapi-fhir-base-test-mindeps-client (>=5.7.7, <=5.7.9) +79 more potentially affected by CVE-2026-33180 via ca.uhn.hapi.fhir:org.hl7.fhir.utilities (5.6.27)
ca.uhn.hapi.fhir:org.hl7.fhir.utilities MAVEN version 5.6.27 is affected by a known vulnerability. The following packages have a transitive dependency on ca.uhn.hapi.fhir:org.hl7.fhir.utilities and may be impacted: - ca.uhn.hapi.fhir:hapi-fhir-base-test-jaxrsserver-kotlin =5.7.7, =5.7.7, =5.7.7,...
EUVD-2018-20851
Malware in sbrugna...
EUVD-2022-33598
Malicious code in bioql PyPI...
info.archinnov:achilles-core (>=2.0.9-dse, <=2.0.13-dse), info.archinnov:achilles-cql (>=2.0.9-dse, <=2.0.13-dse) potentially affected by CVE-2025-23015 via org.apache.cassandra:cassandra-all (1.2.13)
org.apache.cassandra:cassandra-all MAVEN version 1.2.13 is affected by a known vulnerability. The following packages have a transitive dependency on org.apache.cassandra:cassandra-all and may be impacted: - info.archinnov:achilles-core =2.0.9-dse, =2.0.9-dse, =2.0.13-dse Source cves: CVE-2025-230...
info.archinnov:achilles-embedded (3.0.2), info.archinnov:achilles-junit (3.0.2) +2 more potentially affected by CVE-2025-23015 via org.apache.cassandra:cassandra-all (2.0.6)
org.apache.cassandra:cassandra-all MAVEN version 2.0.6 is affected by a known vulnerability. The following packages have a transitive dependency on org.apache.cassandra:cassandra-all and may be impacted: - info.archinnov:achilles-embedded 3.0.2 - info.archinnov:achilles-junit 3.0.2 -...
info.archinnov:achilles (>=1.8.1, <=2.0.3), info.archinnov:achilles-core (>=1.8.1, <=2.0.3) +2 more potentially affected by CVE-2025-23015 via org.apache.cassandra:cassandra-all (1.2.4)
org.apache.cassandra:cassandra-all MAVEN version 1.2.4 is affected by a known vulnerability. The following packages have a transitive dependency on org.apache.cassandra:cassandra-all and may be impacted: - info.archinnov:achilles =1.8.1, =1.8.1, =1.8.1, =1.8.1, =2.0.3 Source cves: CVE-2025-23015...
ca.uhn.hapi.fhir:org.hl7.fhir.convertors (5.5.16), ca.uhn.hapi.fhir:org.hl7.fhir.validation (5.5.16) +3 more potentially affected by CVE-2024-52007 via ca.uhn.hapi.fhir:org.hl7.fhir.r4 (5.5.16)
ca.uhn.hapi.fhir:org.hl7.fhir.r4 MAVEN version 5.5.16 is affected by a known vulnerability. The following packages have a transitive dependency on ca.uhn.hapi.fhir:org.hl7.fhir.r4 and may be impacted: - ca.uhn.hapi.fhir:org.hl7.fhir.convertors 5.5.16 - ca.uhn.hapi.fhir:org.hl7.fhir.validation...