3101 matches found
libsigrok
README El proyecto sigrok tiene como objetivo crear una suite de software de análisis de señales portátil, multiplataforma, libre/abierta y de código abierto que admita varios tipos de dispositivos como analizadores lógicos, osciloscopios, multímetros y más. libsigrok es una biblioteca compartida...
longfellow-zk
Longfellow ZK 概述 Longfellow 库支持构建与遗留身份验证标准相关的零知识协议,例如 ISO MDOC 标准、JWT 标准以及 W3 可验证凭证。该实现描述于: Anonymous credentials from ECDSA libzk: A C++ Library for Zero-Knowledge Proofs 项目文档 它以 Google 剑桥办公室外的那座桥命名。 安全性 本项目已完成由该领域学术与行业专家小组进行的多次独立安全审查。其报告可在项目文档/审查页面获取。 规范 本仓库包含 Longfellow 及其组件规范的工作文件。 如果您有兴趣贡献,请...
resiprocate
概述 reSIProcate 仓库包含以下 C++ 库和应用程序: resip 库:全面的 RFC3261 SIP 协议栈 dum(对话使用管理器)库:用于创建 SIP 用户代理的高级 SIP 库(无媒体栈) recon 库:集成了媒体栈的高级 SIP UA 库 rePro 应用程序:SIP 代理服务器 reTurn 应用程序:STUN/TURN 服务器 MOHParkServer 应用程序:使用 recon 的基于 SIP 的保持音乐服务器 reConServer 应用程序:使用 recon 的基于 SIP 的 B2BUA 服务器(含媒体) reTurn 库:STUN/TURN 客户端...
wolfCOSE
wolfCOSE wolfCOSE es una biblioteca ligera en C que implementa CBOR RFC 8949, COSE RFC 9052/9053 y ML-DSA para COSE RFC 9964 poscuántico, utilizando wolfSSL como backend criptográfico. Características Principales Conjunto completo de mensajes RFC 9052 : los seis tipos de mensaje COSE, incluidos...
SindriKit
SindriKit Offensive Development Deserves Better Architecture. A C library for building offensive capabilities. Core Concept Most offensive utilities hardcode their execution mechanics inside the technique's logic. A reflective loader doesn't just map an image; it maps it using a specific, hardcod...
kdmp-parser
kdmp-parser Esta biblioteca de C++ analiza volcados de memoria del kernel de Windows completos .dump /f en WinDbg, volcados BMP .dump /ka en WinDbg, así como tipos de volcado más recientes introducidos en 2022. La biblioteca admite la carga de volcados de 64 bits y proporciona acceso de lectura a...
expat_2_1_0_CVE-2024-28757
Expat, versión 2.1.0 Esto es Expat, una biblioteca de C para analizar XML, escrita por James Clark. Expat es un analizador de XML orientado a flujo. Esto significa que registra manejadores con el analizador antes de comenzar el análisis. Estos manejadores se invocan cuando el analizador descubre...
MeshCore
关于 MeshCore MeshCore 是一个轻量级、可移植的 C++ 库,支持使用 LoRa 和其他数据包无线电的嵌入式项目实现多跳数据包路由。专为希望创建无需互联网即可运行、具有弹性的去中心化通信网络的开发者而设计。 🔍 什么是 MeshCore? MeshCore 现在支持多种 LoRa 设备,无需手动编译固件即可轻松刷写。用户可以使用 Adafruit ESPTool 等工具刷写预构建的二进制文件,并通过串口控制台与网络进行交互。 MeshCore 能够创建无线 Mesh 网络,与 Meshtastic 和 Reticulum...
libptrace
libptrace libptrace是一个事件驱动的进程/线程调试、追踪和操作框架。它使用C语言编写,并具有Python 2.7和3.7的绑定。 它的设计初衷是作为库使用。API在设计时考虑了跨平台支持。虽然当前版本仅运行在32位和64位(支持wow64)的Windows上,但其设计和抽象使得其他平台甚至远程调试支持可以在同一API下添加。 它是多核/多线程感知的,可以轻松地同时运行多个事件循环。通过增加执行核心数量,可以扩展调试进程组或管道,或追踪大量进程的能力。 前言 我在2006年还在大学时编写了libptrace的初始版本,并于2011年将其重新授权给当时的雇主Immunity...
wsb-detect
⏳ wsb-detect wsb-detect 使您能够检测自己是否运行在 Windows 沙盒("WSB")中。该沙盒被 Windows Defender 用于动态分析,也常被安全分析人员等手动使用。在 2019 年末,微软引入了一项名为 Windows 沙盒(简称 WSB)的新功能。用于识别 WSB 的技术概述如下,请参阅技术部分。如果您有任何指纹识别方面的想法,欢迎提交拉取请求 🎉。我断断续续地摆弄过它,后续还会发布更多关于 Windows 沙盒的内容。 Windows 沙盒允许您在 15 秒内快速创建一个基于 Hyper-V 的一次性虚拟机,该虚拟机具有常见 VM...
xmlsec
XMLSec Library XMLSec library provides C based implementation for major XML Security standards: XML Signature Syntax and Processing XML Encryption Syntax and Processing Detailed information about supported features and algorithms can be found in the XMLDsig and the XMLEnc interoperability reports...
libpeconv
libPeConv Una biblioteca para cargar y manipular archivos PE. Objetivos El objetivo de libPEConv era crear una "navaja suiza" para la carga personalizada de archivos PE. Reúne varias funciones auxiliares que puedes integrar rápidamente en tu propio loader. Por ejemplo: reasignar secciones, aplica...
memoro
Memoro Memoro is a highly detailed heap profiler. Memoro not only shows you where and when your program makes heap allocations, but will show you how your program actually used that memory. Memoro collects detailed information on accesses to the heap, including reads and writes to memory and when...
wnfexec
Resumen WnfExec es una librería de prueba de concepto en C que inyecta shellcode en un proceso mediante el secuestro de un callback de suscripción WNF y luego desencadenando un cambio de estado. No hay nada novedoso aquí y fue construida basándose en la investigación de otros. Mi intención fue...
UnhookMe
UnhookMe - 动态解除挂钩的导入解析器 在侵入性防病毒软件和EDR引入热补丁以增强其监控能力的时代,现代对手必须拥有强大的工具来绕过这些看守。这里提出的动态导入解析器实现,能够即时解除所用函数的挂钩,是加强对手韧性努力的又一步。 我在这里提出的解决方案是,从使用链接器解析的WinAPI导入(在编译后可执行文件的PE头中可见,特别是导入地址表)转向完全动态的方法,仅以动态方式解析导入。这种动态解析器可以配备在后台运行的解除挂钩逻辑,无需操作员任何指导。 最简单的使用示例 以下是如何确保以解除挂钩、不受监控的方式调用MessageBoxW: RESOLVEuser32,...
VX-API
由 vx-underground 管理 | 在 Twitter 上关注我们 | 在 VXUG/samples 页面下载恶意软件样本 VX-API 版本:2.01.015 开发者:smellyvx VX-API 是一个恶意功能集合,旨在辅助恶意软件开发。建议您克隆和/或下载整个仓库,然后打开 Visual Studio 解决方案文件,以便轻松浏览功能和概念。 某些函数可能依赖于解决方案文件中的其他函数。使用此处提供的解决方案文件将更容易识别需要哪些其他功能和/或头文件数据。...
pinjectra
Pinjectra Pinjectra 是一个 C/C++ 库,以“混搭”风格实现了进程注入技术(重点针对 Windows 10 64 位)。示例如下: // CreateRemoteThread Demo + DLL Load i.e., LoadLibraryA as Entry Point executor = new CodeViaCreateRemoteThread new OpenProcessVirtualAllocExWriteProcessMemory void "MsgBoxOnProcessAttach.dll", 25, PROCESSVMWRITE |...
tiny-AES-c
Tiny AES en C Esta es una implementación pequeña y portátil de los algoritmos de cifrado AES ECB, CTR y CBC escritos en C. Puedes sobrescribir el tamaño de clave predeterminado de 128 bits con 192 o 256 bits definiendo los símbolos AES192 o AES256 en aes.h. La API es muy sencilla y tiene este...
external_expat_2.1.0_CVE-2022-43680
Expat, versión 2.1.0 Este es Expat, una biblioteca de C para analizar XML, escrita por James Clark. Expat es un analizador XML orientado a flujos. Esto significa que registras manejadores con el analizador antes de comenzar el análisis. Estos manejadores se invocan cuando el analizador descubre l...
external_expat-2.1.0_CVE-2022-43680
Expat, Versión 2.1.0 Esto es Expat, una biblioteca C para analizar XML, escrita por James Clark. Expat es un analizador XML orientado a flujos. Esto significa que registras manejadores con el analizador antes de iniciar el análisis. Estos manejadores son llamados cuando el analizador descubre las...