16523 matches found
FreeRDP: FreeRDP: Denial of Service due to buffer over-read in RPC gateway
A flaw was found in FreeRDP. A remote attacker can exploit a buffer over-read vulnerability within the RPC Remote Procedure Call gateway transport parser by sending a malicious BINDACK Protocol Data Unit PDU with a truncated result entry. This can lead to a process abort, resulting in a Denial of...
CVE-2026-47729
🦑 CVE-2026-47729 - Squidbleed ⚠️ Heartbleed's ancient cousin, hiding in Squid since 1997. ✨ Features Single-file PoC — Zero dependencies Malicious FTP server mimicking NetWare banner + truncated LIST response Real-time detection and decoding of Basic Auth + Bearer tokens Multi-threaded heap...
CVE-2026-57185
A flaw was found in Asterisk. An authenticated remote attacker can trigger a buffer over-read in the PJSIP Message Waiting Indication MWI body parser by sending a specially crafted Session Initiation Protocol SIP NOTIFY request. Successful exploitation causes Asterisk to crash, resulting in a...
Important: Red Hat Security Advisory: freerdp security update
An update for freerdp is now available for Red Hat Enterprise Linux 8.6 Advanced Mission Critical Update Support and Red Hat Enterprise Linux 8.6 Extended Update Support Long-Life Add-On. Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerabili...
FreeRDP: FreeRDP: Denial of Service due to buffer over-read in RPC gateway
A flaw was found in FreeRDP. A remote attacker can exploit a buffer over-read vulnerability within the RPC Remote Procedure Call gateway transport parser by sending a malicious BINDACK Protocol Data Unit PDU with a truncated result entry. This can lead to a process abort, resulting in a Denial of...
nginx: NGINX: Heap buffer over-read allows memory modification or denial of service
A vulnerability in NGINX's ngxhttpssimodule allows an unauthenticated MITM attacker to trigger a heap buffer over-read by manipulating upstream server responses. This requires SSI, proxypass, and proxybuffering off to be configured, and can result in memory modification or a Denial of Service DoS...
Important: Red Hat Security Advisory: freerdp security update
An update for freerdp is now available for Red Hat Enterprise Linux 8.8 Update Services for SAP Solutions and Red Hat Enterprise Linux 8.8 Telecommunications Update Service. Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring...
FreeRDP: FreeRDP: Denial of Service due to buffer over-read in RPC gateway
A flaw was found in FreeRDP. A remote attacker can exploit a buffer over-read vulnerability within the RPC Remote Procedure Call gateway transport parser by sending a malicious BINDACK Protocol Data Unit PDU with a truncated result entry. This can lead to a process abort, resulting in a Denial of...
FreeRDP: FreeRDP: Denial of Service due to buffer over-read in RPC gateway
A flaw was found in FreeRDP. A remote attacker can exploit a buffer over-read vulnerability within the RPC Remote Procedure Call gateway transport parser by sending a malicious BINDACK Protocol Data Unit PDU with a truncated result entry. This can lead to a process abort, resulting in a Denial of...
nginx: NGINX: Heap buffer over-read allows memory modification or denial of service
A vulnerability in NGINX's ngxhttpssimodule allows an unauthenticated MITM attacker to trigger a heap buffer over-read by manipulating upstream server responses. This requires SSI, proxypass, and proxybuffering off to be configured, and can result in memory modification or a Denial of Service DoS...
nginx: NGINX: Heap buffer over-read allows memory modification or denial of service
A vulnerability in NGINX's ngxhttpssimodule allows an unauthenticated MITM attacker to trigger a heap buffer over-read by manipulating upstream server responses. This requires SSI, proxypass, and proxybuffering off to be configured, and can result in memory modification or a Denial of Service DoS...
vucsa
Vulnerable Client-Server Application VuCSA Vulnerable client-server application VuCSA is made for learning/presenting how to perform penetration tests of non-http client-server applications. It is written in Java with JavaFX graphical user interface. Currently, the vulnerable application contains...
Heartbleed-PoC-Exploit-Script
Heartbleed-PoC-Exploit-Script This Python Proof-of-Concept PoC script detects the Heartbleed vulnerability CVE-2014-0160 by performing a TLS handshake with the heartbeat extension and sending a crafted heartbeat request. It parses server responses to identify leaked memory, helping assess...
cve-2022-21877
POC CVE-2022-21877 This repository contains a POC for the CVE-2022-21877, found by Quang Linh, working at STAR Labs. This is an information leak found inside the spaceport.sys driver. An accompying blogpost can be found at this address. Using it To build the POC, simply run .\build. To run it, yo...
CVE-2019-19204
CVE-2019-19204 An issue was discovered in Oniguruma 6.x before 6.9.4rc2. In the function fetchintervalquantifier formerly known as fetchrangequantifier in regparse.c, PFETCH is called without checking PEND. This leads to a heap-based buffer over-read. Researcher: ManhND of The Tarantula Team,...
CVE-2025-23134_fixes_code
CVE-2026-34180 – Patch Changes The patch addresses an integer truncation issue in the OpenSSL ASN.1/DER decoding code. The following changes were made: 1. Updated the ASN.1 content length type Changed the len parameter of asn1exc2i from int to long. This allows the function to receive and handle...
mongobleed
mongobleed CVE-2025-14847 exploit for MongoDB heap memory disclosure via OPCOMPRESSED buffer over-read. Usage $ bundle exec ruby mongobleed.rb --help Usage: mongobleed.rb options --host HOST Target host default: localhost --port PORT Target port default: 27017 --min-offset MIN Min doc length...
heartbleed
Heartbleed Bug Description of the scenario The Heartbleed bug is an example of a cybersecurity attack that exploits a vulnerability in the OpenSSL library. Briefly, a missing validation step in the OpenSSL library could allow a hacker to access sensitive information on a server that is using the...
heartbleed-proof-of-concept
Heartbleed CVE-2014-0160 Setup You will require docker in order to perform the setup. The exploit, dynamically generates the random bytes from the Client Hello message, therefore you will need to link the library when building the executable. The required package to be installed, in order to link...
CVE-2019-19203
CVE-2019-19203 An issue was discovered in Oniguruma 6.x before 6.9.4rc2. In the function gb18030mbcenclen in file gb18030.c, a UChar pointer is dereferenced without checking if it passed the end of the matched string. This leads to a heap-based buffer over-read. Researcher: ManhND of The Tarantul...