Lucene search
+L

917 matches found

osv_ghsa
osv_ghsa
•added 2026/10/27 4:09 p.m.•7 views

GHSA-8M4G-J4WP-WGCG Authlib accepts an empty HMAC key, allowing JWS/JWT signature forgery (HS256/HS384/HS512)

Reporter: Cavan Loughran, Celvex Group Inc. Summary Authlib's symmetric oct key handling accepts an empty key empty bytes b'' / empty string '' as a valid HMAC signing and verification key. An empty HMAC key produces a deterministic digest that any party can reproduce, so an attacker who knows or...

7.4CVSS6AI score0.00299EPSS
SaveExploits1References5
EUVD
EUVD
•added 2026/10/27 4:09 p.m.•16 views

EUVD-2026-108517

Authlib accepts an empty HMAC key, allowing JWS/JWT signature forgery HS256/HS384/HS512...

7.4CVSS5.9AI score0.00299EPSS
SaveExploits1References4
osv_ghsa
osv_ghsa
•added 2026/10/27 3:39 p.m.•7 views

GHSA-X4RV-C3WX-4CR8 Authlib: Unvalidated request_uri fetch in JWT-secured authorization request (JAR) leading to SSRF

Summary Authlib's RFC 9101 JAR extension passes the attacker-controlled requesturi authorization parameter straight to the getrequestobject fetch hook with no validation, at a pre-authentication endpoint. Authlib already defines the pre-registration allowlist for this requesturis client metadata...

5.4CVSS6.2AI score0.00385EPSS
SaveExploits1References7
EUVD
EUVD
•added 2026/10/27 3:39 p.m.•12 views

EUVD-2026-108522

Authlib: Unvalidated requesturi fetch in JWT-secured authorization request JAR leading to SSRF...

5.4CVSS5.9AI score0.00385EPSS
SaveExploits1References6
Github Security Blog
Github Security Blog
•added 2026/10/27 3:39 p.m.•8 views

Authlib: Unvalidated request_uri fetch in JWT-secured authorization request (JAR) leading to SSRF

Summary Authlib's RFC 9101 JAR extension passes the attacker-controlled requesturi authorization parameter straight to the getrequestobject fetch hook with no validation, at a pre-authentication endpoint. Authlib already defines the pre-registration allowlist for this requesturis client metadata...

5.4CVSS6.2AI score0.00385EPSS
SaveExploits1References7Affected Software1
Github Security Blog
Github Security Blog
•added 2026/10/27 3:39 p.m.•8 views

Authlib: ID token can disable its own nonce validation via the nonce_supported claim

Summary OpenIDMixin.parseidtoken reads the noncesupported claim from the ID token it is validating. When that claim is boolean false, the expected nonce is set to None and nonce validation is skipped for that token. An ID token that carries this claim is therefore accepted in a session whose nonc...

4.2CVSS5.9AI score0.00265EPSS
SaveExploits1References6Affected Software1
osv_ghsa
osv_ghsa
•added 2026/10/27 3:39 p.m.•10 views

GHSA-C5MF-XMP2-59RC Authlib: ID token can disable its own nonce validation via the nonce_supported claim

Summary OpenIDMixin.parseidtoken reads the noncesupported claim from the ID token it is validating. When that claim is boolean false, the expected nonce is set to None and nonce validation is skipped for that token. An ID token that carries this claim is therefore accepted in a session whose nonc...

4.2CVSS5.9AI score0.00265EPSS
SaveExploits1References6
EUVD
EUVD
•added 2026/10/27 3:39 p.m.•11 views

EUVD-2026-108519

Authlib: ID token can disable its own nonce validation via the noncesupported claim...

4.2CVSS5.8AI score0.00265EPSS
SaveExploits1References5
osv_ghsa
osv_ghsa
•added 2026/10/27 3:39 p.m.•10 views

GHSA-FCH4-3C6X-J4GC Authlib: Default JWT bearer grant accepts assertions for the wrong audience

Description Summary Authlib's default RFC 7523 JWT bearer grant leaves getaudiences empty, so verifyclaims only checks that an aud claim exists instead of requiring it to match the current authorization server's token endpoint. An attacker holding a legitimately issued JWT assertion for any...

6.8CVSS5.9AI score0.00351EPSS
SaveExploits1References6
EUVD
EUVD
•added 2026/10/27 3:39 p.m.•10 views

EUVD-2026-108520

Authlib: Default JWT bearer grant accepts assertions for the wrong audience...

6.8CVSS5.8AI score0.00351EPSS
SaveExploits1References5
Github Security Blog
Github Security Blog
•added 2026/10/27 3:39 p.m.•8 views

Authlib: Default JWT bearer grant accepts assertions for the wrong audience

Description Summary Authlib's default RFC 7523 JWT bearer grant leaves getaudiences empty, so verifyclaims only checks that an aud claim exists instead of requiring it to match the current authorization server's token endpoint. An attacker holding a legitimately issued JWT assertion for any...

6.8CVSS5.9AI score0.00351EPSS
SaveExploits1References6Affected Software1
osv_ghsa
osv_ghsa
•added 2026/10/27 3:38 p.m.•8 views

GHSA-Q686-2QMG-HQC7 Authlib: OpenID implicit grant checks raw scope instead of allowed scope before issuing ID tokens

Report metadata | Field | Value | | --- | --- | | Package | authlib PyPI, pkg:pypi/authlib | | Repository | https://github.com/authlib/authlib | | Component | authlib.oidc.core.grants.implicit.OpenIDImplicitGrant.validateauthorizationrequest | | Vulnerability class | Authorization bypass: a...

4.6CVSS5.8AI score0.00162EPSS
SaveExploits1References6
EUVD
EUVD
•added 2026/10/27 3:38 p.m.•12 views

EUVD-2026-108521

Authlib: OpenID implicit grant checks raw scope instead of allowed scope before issuing ID tokens...

4.6CVSS5.9AI score0.00162EPSS
SaveExploits1References5
Github Security Blog
Github Security Blog
•added 2026/10/27 3:38 p.m.•7 views

Authlib: OpenID implicit grant checks raw scope instead of allowed scope before issuing ID tokens

Report metadata | Field | Value | | --- | --- | | Package | authlib PyPI, pkg:pypi/authlib | | Repository | https://github.com/authlib/authlib | | Component | authlib.oidc.core.grants.implicit.OpenIDImplicitGrant.validateauthorizationrequest | | Vulnerability class | Authorization bypass: a...

4.6CVSS5.8AI score0.00162EPSS
SaveExploits1References6Affected Software1
Github Security Blog
Github Security Blog
•added 2026/10/27 3:38 p.m.•9 views

Authlib incomplete algorithm-confusion fix permits HMAC forgery with prefixed public keys

Summary OctKey.importkey carries the only guard that stops an asymmetric public key from being used as an HMAC secret in authlib.jose. That guard is rawkey.startswithPOSSIBLEUNSAFEKEYS — anchored at byte 0 — while the loader that consumes the identical bytes on the asymmetric path...

7.4CVSS5.9AI score0.00213EPSS
SaveExploits1References6Affected Software1
osv_ghsa
osv_ghsa
•added 2026/10/27 3:38 p.m.•13 views

GHSA-7VR2-2FGP-9W7P Authlib incomplete algorithm-confusion fix permits HMAC forgery with prefixed public keys

Summary OctKey.importkey carries the only guard that stops an asymmetric public key from being used as an HMAC secret in authlib.jose. That guard is rawkey.startswithPOSSIBLEUNSAFEKEYS — anchored at byte 0 — while the loader that consumes the identical bytes on the asymmetric path...

7.4CVSS5.9AI score0.00213EPSS
SaveExploits1References6
EUVD
EUVD
•added 2026/10/27 3:38 p.m.•13 views

EUVD-2026-108514

Authlib incomplete algorithm-confusion fix permits HMAC forgery with prefixed public keys...

7.4CVSS5.8AI score0.00213EPSS
SaveExploits1References5
osv_ghsa
osv_ghsa
•added 2026/10/27 3:37 p.m.•5 views

GHSA-JJ7H-C3HG-M23X Authlib: is_secure_transport() loopback exemption can be bypassed with a userinfo component, allowing cleartext-HTTP URLs to non-loopback hosts

Summary authlib.common.security.issecuretransport is used throughout Authlib to enforce the OAuth 2.0 / OIDC requirement that endpoint and redirect URIs use TLS, with an RFC 8252 §7.3 exemption for loopback http:// URIs. The check is implemented as a textual str.startswith prefix match, so a URL...

2.6CVSS6AI score0.00273EPSS
SaveExploits1References5
EUVD
EUVD
•added 2026/10/27 3:37 p.m.•16 views

EUVD-2026-108513

Authlib: issecuretransport loopback exemption can be bypassed with a userinfo component, allowing cleartext-HTTP URLs to non-loopback hosts...

2.6CVSS5.9AI score0.00273EPSS
SaveExploits1References4
Github Security Blog
Github Security Blog
•added 2026/10/27 3:37 p.m.•9 views

Authlib: is_secure_transport() loopback exemption can be bypassed with a userinfo component, allowing cleartext-HTTP URLs to non-loopback hosts

Summary authlib.common.security.issecuretransport is used throughout Authlib to enforce the OAuth 2.0 / OIDC requirement that endpoint and redirect URIs use TLS, with an RFC 8252 §7.3 exemption for loopback http:// URIs. The check is implemented as a textual str.startswith prefix match, so a URL...

2.6CVSS6AI score0.00273EPSS
SaveExploits1References5Affected Software1
Rows per page
Query Builder