15002 matches found
CVE-2025-68783
CVE-2025-68783 affects the Linux kernel ALSA usb-mixer for the us16x08, where get_meter_levels_from_urb() previously derived a channel index from a meter packet without validating range, risking writes past the end of per-channel arrays when the packet contained a negative or out-of-range channel...
CVE-2025-68777 Input: ti_am335x_tsc - fix off-by-one error in wire_order validation
In the Linux kernel, the following vulnerability has been resolved: Input: tiam335xtsc - fix off-by-one error in wireorder validation The current validation 'wireorderi ARRAYSIZEconfigpins' allows wireorderi to equal ARRAYSIZEconfigpins, which causes out-of-bounds access when used as index in...
Astra Linux – vulnerability in linux-6.1, linux-6.12
In the Linux kernel, the following vulnerability has been resolved: scsi: pm80xx: Fix array-index-out-of-of-bounds on rmmod Since commit f7b705c238d1 “scsi: pm80xx: Set phyattached to zero when device is gone”, UBSAN reports: UBSAN: array-index-out-of-bounds in...
Astra Linux – vulnerability in cjson
cJSON versions 1.5.0 through 1.7.18 allow out-of-bounds access via the decodearrayindexfrompointer function in cJSONUtils.c. This enables remote attackers to bypass array bounds checks and access restricted data by using malformed JSON pointer strings containing alphanumeric characters...
Astra Linux – vulnerability in webkit2gtk
Multiple issues were addressed by disabling array allocation sinking. This issue is fixed in Safari 26.1, iOS 26.1 and iPadOS 26.1, macOS Tahoe 26.1, and visionOS 26.1. Processing maliciously crafted web content may lead to an unexpected process crash...
Astra Linux – vulnerability in php8.2
In PHP versions: 8.1. prior to 8.1.34, 8.2. prior to 8.2.30, 8.3. prior to 8.3.29, 8.4. prior to 8.4.16, and 8.5. prior to 8.5.1, a heap buffer overflow occurs in arraymerge when the total number of elements in packed arrays exceeds 32-bit limits or HTMAXSIZE. This is caused by an integer overflo...
Astra Linux – vulnerability in ffmpeg
A NULL pointer dereference vulnerability exists in FFmpeg’s Firequalizer filter libavfilter/affirequalizer.c due to a missing check on the return value of avmallocarray in the configinput function. An attacker could exploit this by tricking a victim into processing a crafted media file with the...
CVE-2025-59022 TYPO3 CMS Allows Broken Access Control in Recycler Module
Backend users who had access to the recycler module could delete arbitrary data from any database table defined in the TCA - regardless of whether they had permission to that particular table. This allowed attackers to purge and destroy critical site data, effectively rendering the website...
CVE-2025-59022 TYPO3 CMS Allows Broken Access Control in Recycler Module
Backend users who had access to the recycler module could delete arbitrary data from any database table defined in the TCA - regardless of whether they had permission to that particular table. This allowed attackers to purge and destroy critical site data, effectively rendering the website...
CVE-2025-59022
CVE-2025-59022 affects TYPO3 CMS: back-end users with Recycler Module access can delete arbitrary data from any TCA-defined table, bypassing permissions and potentially rendering sites unavailable. Affected versions include 10.0.0–10.4.54, 11.0.0–11.5.48, 12.0.0–12.4.40, 13.0.0–13.4.22, and 14.0....
CLSA-2026-1768299147 Fix CVE(s): CVE-2025-14178
SECURITY UPDATE: heap buffer overflow in arraymerge - debian/patches/CVE-2025-14178.patch: fix integer overflow in the precomputation of element counts using zendhashnumelements - CVE-2025-14178...
Linux Kernel Security Vulnerabilities
Linux kernel is the kernel used by Linux, the open source operating system of the Linux Foundation in the United States. A security vulnerability exists in the Linux kernel that stems from the use of the wrong array index in rosekillbydevice, which could lead to an out-of-bounds read...
Linux Distros Unpatched Vulnerability : CVE-2025-71100
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - In the Linux kernel, the following vulnerability has been resolved: wifi: rtlwifi: 8192cu: fix tid out of range in rtl92cutxfilldesc TID getting from...
Linux Kernel Security Vulnerabilities
Linux kernel is the kernel used by Linux, the open source operating system of the Linux Foundation in the United States. A security vulnerability exists in the Linux kernel that stems from a failure to check the TID range in the rtl92cutxfilldesc function, which could lead to an array index...
CVE-2025-71100: Improper Validation of Array Index
In the Linux kernel, the following vulnerability has been resolved: wifi: rtlwifi: 8192cu: fix tid out of range in rtl92cutxfilldesc TID getting from ieee80211gettid might be out of range of array size of staentry-tids, so check TID is less than MAXTIDCOUNT. Othwerwise, UBSAN warn: UBSAN:...
ROS-20260113-7390
A vulnerability in the drivers/us module ucsiccgsynccontrol of the Linux kernel is related to unchecked array indexing. Exploitation of the vulnerability may allow an intruder to affect confidentiality, integrity and availability of protected information...
Elastic Metricbeat security vulnerabilities
Elastic Metricbeat is a metrics collector from the Dutch company Elastic. A security vulnerability exists in Elastic Metricbeat that stems from improper array index validation and insufficient input validation, which could lead to a denial of service by an attacker via specially crafted malformed...
PT-2026-2632
Name of the Vulnerable Software and Affected Versions Metricbeat affected versions not specified Description The software contains flaws related to improper validation of array indices and improper input validation. These issues can be exploited through specially crafted, malformed payloads sent ...
MiracleLinux 8 : java-17-openjdk-17.0.14.0.7-3.el8 (AXSA:2025-9605:04)
The remote MiracleLinux 8 host has packages installed that are affected by a vulnerability as referenced in the AXSA:2025-9605:04 advisory. JDK: Enhance array handling CVE-2025-21502 Bug Fixes: The Asianux OpenJDK packages rely on the copy-jdk-configs package to transfer configuration files to a...
TencentOS Server 4: grafana (TSSA-2026:0007)
"The version of Tencent Linux installed on the remote TencentOS Server 4 host is prior to tested version. It is, therefore, affected by a vulnerability as referenced in the TSSA-2026:0007 advisory. Package updates are available for TencentOS Server 4 that fix the following vulnerabilities:...