3438 matches found
CVE-2020-11019
CVE-2020-11019 In FreeRDP less than or equal to 2.0.0, when running with logger set to "WLOGTRACE", a possible crash of application could occur due to a read of an invalid array index. Data could be printed as string to local terminal. This has been fixed in 2.1.0. authentication| complexity|...
CVE-2026-1281-CVE-2026-1340-Ivanti-EPMM-RCE
Ivanti EPMM pre-auth RCE Dummy Target A simple demo application that shows how to reproduce the Ivanti EPMM pre-auth RCE vulnerability CVE-2026-1281 / CVE-2026-1340 for educational and security research purposes. Vulnerability Overview This vulnerability exploits Bash arithmetic expansion behavio...
SUSE CVE-2026-115722
RPly through 1.1.4 contains an improper array index validation vulnerability in plyreadheaderproperty that accepts list as a list property's length or value type. Attackers can supply a crafted PLY file that makes plyreadlistproperty call an out-of-bounds handler, crashing ASCII parsing or...
CVE-2021-32537
CVE-2021-32537: Out-of-bounds access in RTKVHD64 leading to pool corruption. This is a bug that I reported to Realtek beginning of April 2021. The affected driver is named RTKVHD64.sys and seems to be available on a bunch of mainstream hardware tested the below hardware configurations but probabl...
SUSE CVE-2026-98601
In the Linux kernel, the following vulnerability has been resolved: Bluetooth: btintelpcie: validate device-supplied DMA indices In btintelpciemsixrxhandle, the driver processes RX completion descriptors urbd1 written by the PCIe device into DMA-coherent memory. urbd1-frbdtag a 16-bit field fully...
CVE-2026-82945
SOEM versions 2.0.0 and earlier are vulnerable to memory corruption during device configuration. The root cause is an out-of-bounds write where the software fails to validate that the array index does not exceed the EC_MAXFMMU entries limit. A malicious device can provide more configuration block...
CVE-2026-82945 Memory Corruption via FMMU Configuration Table Overflow
SOEM version 2.0.0 and earlier contains a vulnerability during device configuration where a malicious device can cause memory corruption. The software writes configuration data to a fixed-size array without checking if the array index exceeds its maximum size of ECMAXFMMU entries. A device...
Improper Validation of Array Index
Overview vllm is an A high-throughput and memory-efficient inference and serving engine for LLMs Affected versions of this package are vulnerable to Improper Validation of Array Index via the Rust gRPC Generate and GenerateStream service handlers in rust/src/server/src/grpc/convert.rs, which map...
Improper Validation of Array Index
Overview vllm is an A high-throughput and memory-efficient inference and serving engine for LLMs Affected versions of this package are vulnerable to Improper Validation of Array Index via missing validation of multimodal data in the scale-out entrypoint's protocol.py before engine handoff. An...
Improper Validation of Array Index
Overview vllm is an A high-throughput and memory-efficient inference and serving engine for LLMs Affected versions of this package are vulnerable to Improper Validation of Array Index via the validatestoptokenids method absent before the fix in vllm/samplingparams.py, where stoptokenids supplied ...
Linux Distros Unpatched Vulnerability : CVE-2026-115722
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - RPly through 1.1.4 contains an improper array index validation vulnerability in plyreadheaderproperty that accepts list as a list property's length or value typ...
Improper Validation of Array Index
Overview rply is a Python parser generator, that also works with RPython. Affected versions of this package are vulnerable to Improper Validation of Array Index via improper array index validation in plyreadheaderproperty, which accepts list as a list property's length or value type. An attacker...
DEBIAN-CVE-2026-115722
RPly through 1.1.4 contains an improper array index validation vulnerability in plyreadheaderproperty that accepts list as a list property's length or value type. Attackers can supply a crafted PLY file that makes plyreadlistproperty call an out-of-bounds handler, crashing ASCII parsing or...
CVE-2026-115722
RPly through 1.1.4 contains an improper array index validation vulnerability in plyreadheaderproperty that accepts list as a list property's length or value type. Attackers can supply a crafted PLY file that makes plyreadlistproperty call an out-of-bounds handler, crashing ASCII parsing or...
EUVD-2026-108710
RPly through 1.1.4 contains an improper array index validation vulnerability in plyreadheaderproperty that accepts list as a list property's length or value type. Attackers can supply a crafted PLY file that makes plyreadlistproperty call an out-of-bounds handler, crashing ASCII parsing or...
CVE-2026-115722
RPly through 1.1.4 contains an improper array index validation vulnerability in plyreadheaderproperty that accepts list as a list property's length or value type. Attackers can supply a crafted PLY file that makes plyreadlistproperty call an out-of-bounds handler, crashing ASCII parsing or...
PT-2026-121834
RPly through 1.1.4 contains an improper array index validation vulnerability in ply read header property that accepts list as a list property's length or value type. Attackers can supply a crafted PLY file that makes ply read list property call an out-of-bounds handler, crashing ASCII parsing or...
Unity Linux 20.1020e / 20.1050e / 20.1060e / 20.1070e Security Update: kernel (UTSA-2026-142710)
The Unity Linux 20 host has a package installed that is affected by a vulnerability as referenced in the UTSA-2026-142710 advisory. In the Linux kernel, the following vulnerability has been resolved: ocfs2: fix UBSAN array-index-out-of-bounds in ocfs2sumrightmostrec BUG On-disk corruption setting...
CVE-2026-114405
Improper validation of array index vulnerability in Velneo vServer. This issue affects vServer: from 36.0 before 36.6 and from 37.0 before 37.2...
CVE-2026-114405 Denial of Service via Malformed VATP Packet in Velneo vServer
Improper validation of array index vulnerability in Velneo vServer. This issue affects vServer: from 36.0 before 36.6 and from 37.0 before 37.2...