7516 matches found
CVE-2026-42356 Apache HTTP Server: limited RCE for some internal redirects to non-CGI files in CGI directories
Deployment of wrong handler vulnerability in Apache HTTP Server allows the target of some internal redirects from CGI programs to also be treated as CGI and executed. The target must already be in a directory enabled for CGI and have no other extension understood by modmime. This issue affects...
EUVD-2026-90886
Deployment of wrong handler vulnerability in Apache HTTP Server allows the target of some internal redirects from CGI programs to also be treated as CGI and executed. The target must already be in a directory enabled for CGI and have no other extension understood by modmime. This issue affects...
CVE-2026-42356
Deployment of wrong handler vulnerability in Apache HTTP Server allows the target of some internal redirects from CGI programs to also be treated as CGI and executed. The target must already be in a directory enabled for CGI and have no other extension understood by modmime. This issue affects...
CVE-2026-42528 Apache HTTP Server: mod_dav shared lock overflow
A memory calculation bug in moddav in Apache httpd 2.4.67 and earlier allows an attacker with permission to create WebDAV locks to crash server child processes. Users are recommended to upgrade to version 2.4.69, which fixes this issue...
CVE-2026-42528 Apache HTTP Server: mod_dav shared lock overflow
A memory calculation bug in moddav in Apache httpd 2.4.67 and earlier allows an attacker with permission to create WebDAV locks to crash server child processes. Users are recommended to upgrade to version 2.4.69, which fixes this issue...
CVE-2026-42528
A memory calculation bug in the mod_dav module of Apache httpd version 2.4.67 and earlier allows an attacker with permission to create WebDAV locks to trigger a crash in server child processes. This vulnerability is characterized as a mod_dav shared lock overflow . To mitigate this issue, users a...
CVE-2021-42013-EXPLOIT
🚨 CVE-2021-42013 - Apache 2.4.49 & 2.4.50 Remote Code Execution 🚨 CVE-2021-42013 builds upon the previously identified vulnerability, CVE-2021-41773. Despite the Apache team's efforts to address CVE-2021-41773 in version 2.4.50, subsequent investigations revealed that the fix fell short of fully...
Security Bulletin: Multiple Vulnerabilities in IBM Cloud Pak System
Summary Multiple vulnerabilities were addressed in IBM Cloud Pak System version 2.3.6.2. Vulnerability Details CVEID:CVE-2026-24072 DESCRIPTION: An escalation of privilege bug in various modules in Apache HTTP 2.4.66 and earlier allows local .htaccess authors to read files with the privileges of...
AlmaLinux 9.2 [TuxCare] Security Update: httpd / httpd-core / httpd-devel / httpd-filesystem / httpd-manual / etc Multiple Vulnerabilities (ALMALINUX9.2:CLSA-2026:1781261042)
The AlmaLinux 9.2 host has packages installed that are affected by multiple vulnerabilities as referenced in the TuxCare ALMALINUX9.2:CLSA-2026:1781261042 advisory. - Use After Free vulnerability in Apache HTTP Server with modldap in per-directory configuration This issue affects Apache HTTP...
CentOS Linux 6 [TuxCare] Security Update: httpd / httpd-devel / httpd-manual / httpd-tools / mod_ssl (CENTOS6:CLSA-2026:1781253209)
The CentOS Linux 6 host has packages installed that are affected by a vulnerability as referenced in the TuxCare CENTOS6:CLSA-2026:1781253209 advisory. - Apache HTTP Server 2.4.65 and earlier with Server Side Includes SSI enabled and modcgid but not modcgi passes the shell-escaped query string to...
PT-2026-103924
Name of the Vulnerable Software and Affected Versions Apache HTTP Server versions 2.4.0 through 2.4.68 Description A NULL pointer dereference exists in the mod heartmonitor module when used over a unicast listener. This issue can lead to a Denial of Service DoS, which is a condition where the...
PT-2026-103925
Name of the Vulnerable Software and Affected Versions Apache HTTP Server versions 2.4.0 through 2.4.68 Description The mod session cookie module contains an issue where sensitive information may be exposed to an unauthorized actor. Specifically, when the SessionCookieRemove directive changes duri...
PT-2026-103934
Name of the Vulnerable Software and Affected Versions Apache HTTP Server versions prior to 2.4.69 Description Improper validation of the FTP PASV reply address in the mod proxy ftp module allows an untrusted FTP server to force the proxy to open a data connection to an arbitrary third-party host...
PT-2026-103937
Name of the Vulnerable Software and Affected Versions Apache HTTP Server versions 2.4.30 through 2.4.68 Description An issue exists involving the inconsistent interpretation of HTTP requests, known as HTTP Request/Response Smuggling. This occurs via the mod proxy uwsgi module when processing a...
PT-2026-103941
Name of the Vulnerable Software and Affected Versions Apache HTTP Server versions prior to 2.4.69 Description A use after free issue exists in the mod auth digest module. This occurs when an unauthenticated remote client sends concurrent Digest authentication requests while AuthDigestNcCheck is...
CVE-2026-56154: Use After Free
Use After Free vulnerability in Apache HTTP Server's modrewrite when using lookahead %LA-U:HTTP:... This issue affects Apache HTTP Server: from 2.4.0 through 2.4.68...
CVE-2026-56449: Out-of-bounds Write
Out-of-bounds Write vulnerability in Apache HTTP Server's modproxyhtml with crafted HTTP response bodies. This issue affects Apache HTTP Server version 2.4.68...
CVE-2026-56153: Out-of-bounds Write
Out-of-bounds Write vulnerability in Apache HTTP Server's modcharsetlite. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.68...
CVE-2026-58415: Files or Directories Accessible to External Parties
Internal state files accessible to external parties in moddavfs in Apache Software Foundation Apache HTTP Server before 2.4.69 on all platforms allows a remote client to read WebDAV dead properties of resources it cannot author via a GET request for the .DAV state directory This issue affects...
CVE-2026-63718: Inconsistent Interpretation of HTTP Requests
Inconsistent Interpretation of HTTP Requests 'HTTP Request/Response Smuggling' response smuggling vulnerability in Apache HTTP Server via modproxyuwsgi and a crafted uwsgi response with Transfer-Encoding. This issue affects Apache HTTP Server: from 2.4.30 through 2.4.68...