10136 matches found
Medium: perl-YAML-LibYAML
Issue Overview: YAML-LibYAML prior to 0.903.0 for Perl uses 2-args open, allowing existing files to be modified CVE-2025-40908 Affected Packages: perl-YAML-LibYAML Issue Correction: Run dnf update perl-YAML-LibYAML --releasever 2023.7.20250623 or dnf update --advisory ALAS2023-2025-1036...
Important: perl-File-Find-Rule-Perl
Issue Overview: File::Find::Rule through 0.34 for Perl is vulnerable to Arbitrary Code Execution when grep encounters a crafted filename. A file handle is opened with the 2 argument form of open allowing an attacker controlled filename to provide the MODE parameter to open, turning the filename...
Amazon Linux 2023 : curl, curl-minimal, libcurl (ALAS2023-2025-1043)
It is, therefore, affected by a vulnerability as referenced in the ALAS2023-2025-1043 advisory. When curl is asked to use HSTS, the expiry time for a subdomain mightoverwrite a parent domain's cache entry, making it end sooner or later thanotherwise intended. This affects curl using applications...
Amazon Linux 2023 : bsdcat, bsdcpio, bsdtar (ALAS2023-2025-1022)
It is, therefore, affected by a vulnerability as referenced in the ALAS2023-2025-1022 advisory. A vulnerability has been identified in the libarchive library, specifically within the archivereadformatrarseekdata function. This flaw involves an integer overflow that can ultimately lead to a...
Amazon Linux 2023 : libxml2, libxml2-devel, libxml2-static (ALAS2023-2025-1019)
It is, therefore, affected by a vulnerability as referenced in the ALAS2023-2025-1019 advisory. A flaw was found in libxml2's xmlBuildQName function, where integer overflows in buffer size calculations can lead to a stack-based buffer overflow. This issue can result in memory corruption or a deni...
Amazon Linux 2023 : amazon-cloudwatch-agent (ALAS2023-2025-1029)
It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2023-2025-1029 advisory. The tokenizer incorrectly interprets tags with unquoted attribute values that end with a solidus character / as self-closing. When directly using Tokenizer, this can result in such tags...
Amazon Linux 2 : runc (ALASDOCKER-2025-068)
The version of runc installed on the remote host is prior to 1.2.4-3. It is, therefore, affected by a vulnerability as referenced in the ALAS2DOCKER-2025-068 advisory. The net/http package accepted data in the chunked transfer encoding containing an invalid chunk-size line terminated by a bare LF...
Amazon Linux 2023 : bpftool, kernel, kernel-devel (ALAS2023-2025-1037)
It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2023-2025-1037 advisory. In the Linux kernel, the following vulnerability has been resolved: btrfs: check folio mapping after unlock in relocateonefolio CVE-2024-56758 In the Linux kernel, the following vulnerability...
Amazon Linux 2023 : java-1.8.0-amazon-corretto, java-1.8.0-amazon-corretto-devel (ALAS2023-2025-1017)
It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2023-2025-1017 advisory. Vulnerability in the Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition product of Oracle Java SE component: JSSE. Supported versions that are affected are Oracle Java...
Amazon Linux 2023 : amazon-ecr-credential-helper (ALAS2023-2025-1039)
It is, therefore, affected by a vulnerability as referenced in the ALAS2023-2025-1039 advisory. The net/http package accepted data in the chunked transfer encoding containing an invalid chunk-size line terminated by a bare LF. When used in conjunction with a server or proxy which incorrectly...
Amazon Linux 2 : runc (ALASECS-2025-068)
The version of runc installed on the remote host is prior to 1.2.4-3. It is, therefore, affected by a vulnerability as referenced in the ALAS2ECS-2025-068 advisory. The net/http package accepted data in the chunked transfer encoding containing an invalid chunk-size line terminated by a bare LF...
Amazon Linux 2023 : golang, golang-bin, golang-misc (ALAS2023-2025-1028)
It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2023-2025-1028 advisory. Calling Verify with a VerifyOptions.KeyUsages that contains ExtKeyUsageAny unintentionally disabledpolicy validation. This only affected certificate chains which contain policy graphs, which a...
Amazon Linux 2023 : abseil-cpp, abseil-cpp-devel (ALAS2023-2025-1042)
It is, therefore, affected by a vulnerability as referenced in the ALAS2023-2025-1042 advisory. There exists a heap buffer overflow vulnerable in Abseil-cpp. The sized constructors, reserve, and rehash methods of absl::flat,nodehashset,map did not impose an upper bound on their size argument. As ...
Amazon Linux 2023 : containerd, containerd-stress (ALAS2023-2025-1040)
It is, therefore, affected by a vulnerability as referenced in the ALAS2023-2025-1040 advisory. The net/http package accepted data in the chunked transfer encoding containing an invalid chunk-size line terminated by a bare LF. When used in conjunction with a server or proxy which incorrectly...
Amazon Linux 2023 : libvpx, libvpx-devel, libvpx-utils (ALAS2023-2025-1023)
It is, therefore, affected by a vulnerability as referenced in the ALAS2023-2025-1023 advisory. Use after free in libvpx in Google Chrome prior to 137.0.7151.55 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. Chromium security severity: Medium Duplicate:...
Amazon Linux 2 : runc (ALASNITRO-ENCLAVES-2025-064)
The version of runc installed on the remote host is prior to 1.2.4-3. It is, therefore, affected by a vulnerability as referenced in the ALAS2NITRO-ENCLAVES-2025-064 advisory. The net/http package accepted data in the chunked transfer encoding containing an invalid chunk-size line terminated by a...
Amazon Linux 2 : amazon-ecr-credential-helper (ALASDOCKER-2025-069)
The version of amazon-ecr-credential-helper installed on the remote host is prior to 0.10.0-1. It is, therefore, affected by a vulnerability as referenced in the ALAS2DOCKER-2025-069 advisory. The net/http package accepted data in the chunked transfer encoding containing an invalid chunk-size lin...
Amazon Linux 2 : kernel (ALASKERNEL-5.15-2025-075)
The version of kernel installed on the remote host is prior to 5.15.185-126.190. It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2KERNEL-5.15-2025-075 advisory. In the Linux kernel, the following vulnerability has been resolved: schhfsc: Fix qlen accounting bug whe...
Important: kernel-livepatch-5.10.234-225.917
Issue Overview: In the Linux kernel, the following vulnerability has been resolved: x86/microcode/AMD: Fix out-of-bounds on systems with CPU-less NUMA nodes CVE-2025-21991 Affected Packages: kernel-livepatch-5.10.234-225.917 Issue Correction: Please ensure you have live patching enabled. Run yum...
Amazon Linux 2023 : valkey, valkey-devel (ALAS2023-2025-1025)
It is, therefore, affected by a vulnerability as referenced in the ALAS2023-2025-1025 advisory. setDeferredReply in networking.c in Valkey through 8.1.1 has an integer underflow for prev-size - prev-used. CVE-2025-49112 Tenable has extracted the preceding description block directly from the teste...