10130 matches found
Amazon Linux 2023 : cargo, clippy, rust (ALAS2023-2025-1162)
It is, therefore, affected by a vulnerability as referenced in the ALAS2023-2025-1162 advisory. There exists a vulnerability in SQLite versions before 3.50.2 where the number of aggregate terms could exceed the number of columns available. This could lead to a memory corruption issue. We recommen...
Amazon Linux 2023 : gnome-remote-desktop (ALAS2023-2025-1160)
It is, therefore, affected by a vulnerability as referenced in the ALAS2023-2025-1160 advisory. A flaw was found in gnome-remote-desktop. Once gnome-remote-desktop listens for RDP connections, an unauthenticated attacker can exhaust system resources and repeatedly crash the process. There may be ...
Amazon Linux 2023 : libssh, libssh-config, libssh-devel (ALAS2023-2025-1155)
It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2023-2025-1155 advisory. The privatekeyfromfile uses an uninitialized variable under certainconditions, such as if the file specified by the filename argument doesn'texist. This causes the code to return an invalid...
Amazon Linux 2023 : bpftool6.12, kernel6.12, kernel6.12-devel (ALAS2023-2025-1170)
It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2023-2025-1170 advisory. In the Linux kernel, the following vulnerability has been resolved: jfs: fix array-index-out-of-bounds read in addmissingindices CVE-2025-38204 In the Linux kernel, the following vulnerability...
Amazon Linux 2023 : mod_security, mod_security-mlogc (ALAS2023-2025-1157)
It is, therefore, affected by a vulnerability as referenced in the ALAS2023-2025-1157 advisory. ModSecurity is an open source, cross platform web application firewall WAF engine for Apache, IIS and Nginx. In versions 2.9.11 and below, an attacker can override the HTTP response's Content-Type, whi...
Amazon Linux 2023 : krb5-devel, krb5-libs, krb5-pkinit (ALAS2023-2025-1173)
It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2023-2025-1173 advisory. krb5: overflow when calculating ulog block size CVE-2025-24528 A vulnerability in the MIT Kerberos implementation allows GSSAPI-protected messages using RC4-HMAC-MD5 to be spoofed due to...
Amazon Linux 2023 : cairo, cairo-devel, cairo-gobject (ALAS2023-2025-1172)
It is, therefore, affected by a vulnerability as referenced in the ALAS2023-2025-1172 advisory. An issue was discovered in freedesktop poppler v25.04.0. The heap memory containing PDF stream objects is not cleared upon program exit, allowing attackers to obtain sensitive PDF content via a memory...
Amazon Linux 2023 : bpftool, kernel, kernel-devel (ALAS2023-2025-1169)
It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2023-2025-1169 advisory. In the Linux kernel, the following vulnerability has been resolved: smb: client: Avoid race in opencacheddir with lease breaks CVE-2025-37954 In the Linux kernel, the following vulnerability h...
Amazon Linux 2 : mock, --advisory ALAS2MOCK-2025-001 (ALASMOCK-2025-001)
The version of mock installed on the remote host is prior to 1.4.19-1. It is, therefore, affected by a vulnerability as referenced in the ALAS2MOCK-2025-001 advisory. The Mock software contains a vulnerability wherein an attacker could potentially exploit privilege escalation, enabling the...
Amazon Linux 2 : memcached, --advisory ALAS2MEMCACHED1.5-2025-001 (ALASMEMCACHED1.5-2025-001)
The version of memcached installed on the remote host is prior to 1.5.17-1. It is, therefore, affected by a vulnerability as referenced in the ALAS2MEMCACHED1.5-2025-001 advisory. Buffer Overflow vulnerability in authfile.c memcached 1.6.9 allows attackers to cause a denial of service via crafted...
Amazon Linux 2 : kernel, --advisory ALAS2KERNEL-5.15-2025-088 (ALASKERNEL-5.15-2025-088)
The version of kernel installed on the remote host is prior to 5.15.189-131.211. It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2KERNEL-5.15-2025-088 advisory. In the Linux kernel, the following vulnerability has been resolved: dma-buf/dma-resv: check if the new...
Amazon Linux 2 : postgresql, --advisory ALAS2POSTGRESQL14-2025-019 (ALASPOSTGRESQL14-2025-019)
The version of postgresql installed on the remote host is prior to 14.19-1. It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2POSTGRESQL14-2025-019 advisory. PostgreSQL optimizer statistics allow a user to read sampled data within a view that the user cannot access...
Amazon Linux 2 : postgresql, --advisory ALAS2POSTGRESQL13-2025-012 (ALASPOSTGRESQL13-2025-012)
The version of postgresql installed on the remote host is prior to 13.22-1. It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2POSTGRESQL13-2025-012 advisory. PostgreSQL optimizer statistics allow a user to read sampled data within a view that the user cannot access...
Amazon Linux 2 : kernel, --advisory ALAS2KERNEL-5.10-2025-103 (ALASKERNEL-5.10-2025-103)
The version of kernel installed on the remote host is prior to 5.10.240-238.966. It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2KERNEL-5.10-2025-103 advisory. In the Linux kernel, the following vulnerability has been resolved: dma-buf/dma-resv: check if the new...
Amazon Linux 2 : tomcat, --advisory ALAS2TOMCAT9-2025-022 (ALASTOMCAT9-2025-022)
The version of tomcat installed on the remote host is prior to 9.0.108-1. It is, therefore, affected by a vulnerability as referenced in the ALAS2TOMCAT9-2025-022 advisory. Improper Resource Shutdown or Release vulnerability in Apache Tomcat made Tomcat vulnerable to the made you reset attack. Th...
Amazon Linux 2 : kernel, --advisory ALAS2KERNEL-5.10-2025-102 (ALASKERNEL-5.10-2025-102)
The version of kernel installed on the remote host is prior to 5.10.240-238.955. It is, therefore, affected by a vulnerability as referenced in the ALAS2KERNEL-5.10-2025-102 advisory. In the Linux kernel, the following vulnerability has been resolved: ACPICA: Refuse to evaluate a method if...
Low: samba
Issue Overview: All versions of Samba prior to 4.13.16 are vulnerable to a malicious client using an SMB1 or NFS race to allow a directory to be created in an area of the server file system not exported under the share definition. Note that SMB1 has to be enabled, or the share also available via...
Important: kernel
Issue Overview: In the Linux kernel, the following vulnerability has been resolved: dma-buf/dma-resv: check if the new fence is really later CVE-2022-49935 In the Linux kernel, the following vulnerability has been resolved: cifs: fix small mempool leak in SMB2negotiate CVE-2022-49938 In the Linux...
Medium: cairo
Issue Overview: An issue was discovered in freedesktop poppler v25.04.0. The heap memory containing PDF stream objects is not cleared upon program exit, allowing attackers to obtain sensitive PDF content via a memory dump. CVE-2025-50422 Affected Packages: cairo Note: This advisory is applicable ...
Medium: httpd
Issue Overview: A bug in Apache HTTP Server 2.4.64 results in all "RewriteCond expr ..." tests evaluating as "true". Users are recommended to upgrade to version 2.4.65, which fixes the issue. CVE-2025-54090 Affected Packages: httpd Note: This advisory is applicable to Amazon Linux 2 AL2 Core...