88 matches found
GLSA-202608-04 : Dnsmasq: Multiple Vulnerabilities
The remote host is affected by the vulnerability described in GLSA-202608-04 Dnsmasq: Multiple Vulnerabilities Multiple vulnerabilities have been discovered in Dnsmasq. Please review the CVE identifiers referenced below for details. Tenable has extracted the preceding description block directly...
Photon OS 5.0: Dnsmasq PHSA-2026-5.0-91-0866
An update of the dnsmasq package has been released. %NASLMINLEVEL 80900 C Tenable, Inc. The descriptive text and package checks in this plugin were extracted from VMware Security Advisory PHSA-2026-5.0-91-0866. The text itself is copyright C VMware, Inc. include'compat.inc'; if description...
fastrepl-client (0.0.1) potentially affected by CVE-2024-4890 via litellm (0.4.4)
litellm PYPI version 0.4.4 is affected by a known vulnerability. The following packages have a transitive dependency on litellm and may be impacted: - fastrepl-client 0.0.1 Source cves: CVE-2024-4890 Source advisory: OSV:PYSEC-2026-1544...
docindex (>=0.8.0, <=0.9.0) potentially affected by CVE-2024-4890 via litellm (0.1.2291)
litellm PYPI version 0.1.2291 is affected by a known vulnerability. The following packages have a transitive dependency on litellm and may be impacted: - docindex =0.8.0, =0.9.0 Source cves: CVE-2024-4890 Source advisory: OSV:PYSEC-2026-1544...
langstream (0.1.8) potentially affected by CVE-2024-4890 via litellm (0.1.450)
litellm PYPI version 0.1.450 is affected by a known vulnerability. The following packages have a transitive dependency on litellm and may be impacted: - langstream 0.1.8 Source cves: CVE-2024-4890 Source advisory: OSV:PYSEC-2026-1544...
autogpt-forge (>=0.1.0, <=0.1.3), cosmoai (>=0.6.0, <=0.6.6) +12 more potentially affected by CVE-2024-4890 via litellm (0.1.7713)
litellm PYPI version 0.1.7713 is affected by a known vulnerability. The following packages have a transitive dependency on litellm and may be impacted: - autogpt-forge =0.1.0, =0.6.0, =0.2.4, =0.1.11, =0.0.1, =0.1.7, =0.1.0, =0.1.2, =0.0.2, =0.0.3 - yival 0.1.0a4 Source cves: CVE-2024-4890 Source...
open-interpreter (>=0.1.12, <=0.1.17), promptmodel (>=0.0.25, <=0.0.31) potentially affected by CVE-2024-4890 via litellm (0.13.2)
litellm PYPI version 0.13.2 is affected by a known vulnerability. The following packages have a transitive dependency on litellm and may be impacted: - open-interpreter =0.1.12, =0.0.25, =0.0.31 Source cves: CVE-2024-4890 Source advisory: OSV:PYSEC-2026-1544...
ai-agents (>=0.0.4, <=0.0.52), aiflows (>=0.1.5, <=1.1.1) +16 more potentially affected by CVE-2024-4890 via litellm (>=1.0.0, <=1.14.4)
litellm PYPI version =1.0.0, =0.0.4, =0.1.5, =2.5.8, =2.5.8, =2.7.3, =0.7.0, =2.2.9, =0.4.7, =0.1.22, =0.1.0, =1.9.1, =1.10.1 and more Source cves: CVE-2024-4890 Source advisory: OSV:PYSEC-2026-1544...
promptulate (1.9.0) potentially affected by CVE-2024-4890 via litellm (0.12.12)
litellm PYPI version 0.12.12 is affected by a known vulnerability. The following packages have a transitive dependency on litellm and may be impacted: - promptulate 1.9.0 Source cves: CVE-2024-4890 Source advisory: OSV:PYSEC-2026-1544...
yival (>=0.1.0a5, <=0.1.0a10) potentially affected by CVE-2024-4890 via litellm (0.1.607)
litellm PYPI version 0.1.607 is affected by a known vulnerability. The following packages have a transitive dependency on litellm and may be impacted: - yival =0.1.0a5, =0.1.0a10 Source cves: CVE-2024-4890 Source advisory: OSV:PYSEC-2026-1544...
Important: Red Hat Security Advisory: dnsmasq security update
An update for dnsmasq is now available for Red Hat Enterprise Linux 9.6 Extended Update Support. Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System CVSS base score, which gives a detailed severity rating, is available for...
Oracle Linux 9 : dnsmasq (ELSA-2026-19373)
The remote Oracle Linux 9 host has packages installed that are affected by multiple vulnerabilities as referenced in the ELSA-2026-19373 advisory. - Prevent overflow in extractname function CVE-2026-2291 - Prevent DoS in DNSSEC validation CVE-2026-4890 - Prevent out-of-bounds read in DNSSEC...
CVE-2026-4890 vulnerabilities
Vulnerabilities for packages: dnsmasq...
dnsmasq-2.92rel2-1.1 on GA media (moderate)
dnsmasq-2.92rel2-1.1 on GA media Announcement ID: openSUSE-SU-2026:10821-1 Rating: moderate Cross-References: CVE-2026-2291 CVE-2026-4890 CVE-2026-4891 CVE-2026-4892 CVE-2026-4893 CVE-2026-5172 CVSS scores: CVE-2026-2291 SUSE : 8.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H CVE-2026-2291 SUSE :...
RHEL 9 : dnsmasq (RHSA-2026:19373)
The remote Redhat Enterprise Linux 9 host has packages installed that are affected by multiple vulnerabilities as referenced in the RHSA-2026:19373 advisory. The dnsmasq packages contain Dnsmasq, a lightweight DNS Domain Name Server forwarder and DHCP Dynamic Host Configuration Protocol server...
RHEL 10 : dnsmasq (RHSA-2026:19158)
The remote Redhat Enterprise Linux 10 host has packages installed that are affected by multiple vulnerabilities as referenced in the RHSA-2026:19158 advisory. The dnsmasq packages contain Dnsmasq, a lightweight DNS Domain Name Server forwarder and DHCP Dynamic Host Configuration Protocol server...
Fedora 43 : dnsmasq (2026-6384a3cf14)
The remote Fedora 43 host has a package installed that is affected by multiple vulnerabilities as referenced in the FEDORA-2026-6384a3cf14 advisory. Update to 2.92rel2 2.92 point release incorporating fixes for: - CVE-2026-2291 - CVE-2026-4890 - CVE-2026-4891 - CVE-2026-4892 - CVE-2026-4893 -...
CVE-2026-4890
...
Fedora 44 : dnsmasq (2026-ac5cceec13)
The remote Fedora 44 host has a package installed that is affected by multiple vulnerabilities as referenced in the FEDORA-2026-ac5cceec13 advisory. Update to 2.92rel2 2.92 point release incorporating fixes for: - CVE-2026-2291 - CVE-2026-4890 - CVE-2026-4891 - CVE-2026-4892 - CVE-2026-4893 -...
OPENSUSE-SU-2026:20748-1 Security update for dnsmasq
This update for dnsmasq fixes the following issues Security issues: - CVE-2026-2291: dnsmasq can be abused to record false cached data enabling DoS or attacker redirect bsc1258251. - CVE-2026-4890: DoS vulnerability in the DNSSEC validation bsc1265001. - CVE-2026-4891: heap-based out-of-bounds re...