3138 matches found
CVE-2020-1967
CVE-2020-1967 Proof of concept exploit about OpenSSL signaturealgorithmscert DoS flaw CVE-2020-1967. Credit for the original finding to Bernd Edlinger, additional analysis by Matt Caswell and Benjamin Kaduk, this demo by Imre Rad. Prerequisite Server or client applications that call the...
tls
ztls A TLS 1.3 implementation for QUIC written in Zig, strictly adhering to RFC 8446 TLS 1.3 and RFC 9001 QUIC-TLS. Status Aspect| Info ---|--- API Stability| Production Zig Version| 0.16.0 Platforms| Linux, macOS, Windows Performance note The 2 ms handshake target is validated on Ed25519 and...
CVE-2011-3192-apache-exploit
CVE-2011-3192 This exploit triggers a denial of service condition in Apache versions 1.3.x, 2.0.64 and below and 2.2.19 and below. Developed in 2011 by Antonius ev1lut10n / w1sdom...
PoC_TLS1_3_CVE-2020-13777
PoC TLS1.3 CVE-2020-13777 The purpose of this PoC This PoC and related article were created to apply for the project "Challenge CVE-2020-13777". CVE-2020-13777 is a GnuTLS vulnerability whose patch is widely distributed. This PoC aims to contribute to improving the information security literacy o...
macsurf
The modern web, on a 25-year-old Mac. A native browser for the Carbon era, Mac OS 8.6 through Mac OS X 10.6: real CSS, modern JavaScript, and HTTPS on the Mac itself. No proxy, no second machine. MacSurf 2.0.5 on a Power Mac G3 iMac, renderinghackaday.com at full desktop width over native HTTPS...
challenge_CVE-2020-13777
Chanllenge CVE-2020-13777 Try to prove if TLS 1.3 MITM is possible and decrypt 0-RTT early data in pcap here Server: 192.168.100.23:5556. See https://jovi0608.hatenablog.com/entry/2020/06/13/104905 and CVE-2020-13777 for details...
ssh3
!NOTE SSH3 is probably going to change its name. It is still the SSH Connection Protocol RFC4254 running on top of HTTP/3 Extended connect, but the required changes are heavy and too distant from the philosophy of popular SSH implementations to be considered for integration. The specification dra...
CVE-2024-36840-Exploit
CVE-2024-36840: SQL Injection Vulnerability in Boelter Blue System Management Version 1.3 Exploit Details Exploit Title : SQL Injection Vulnerability in Boelter Blue System Management version 1.3 Original Google Dork : inurl:"Powered by Boelter Blue" didn't workedzero url in search Google Dork By...
crypto/tls: golang: Go crypto/tls: Denial of Service via multiple TLS 1.3 key update messages
A flaw was found in the crypto/tls package within the Go golang standard library, specifically affecting TLS 1.3 connections. A remote attacker can exploit this vulnerability by sending multiple key update messages in a single record after the handshake. This can cause the connection to deadlock,...
crypto/tls: golang: Go crypto/tls: Denial of Service via multiple TLS 1.3 key update messages
A flaw was found in the crypto/tls package within the Go golang standard library, specifically affecting TLS 1.3 connections. A remote attacker can exploit this vulnerability by sending multiple key update messages in a single record after the handshake. This can cause the connection to deadlock,...
crypto/tls: golang: Go crypto/tls: Denial of Service via multiple TLS 1.3 key update messages
A flaw was found in the crypto/tls package within the Go golang standard library, specifically affecting TLS 1.3 connections. A remote attacker can exploit this vulnerability by sending multiple key update messages in a single record after the handshake. This can cause the connection to deadlock,...
crypto/tls: golang: Go crypto/tls: Denial of Service via multiple TLS 1.3 key update messages
A flaw was found in the crypto/tls package within the Go golang standard library, specifically affecting TLS 1.3 connections. A remote attacker can exploit this vulnerability by sending multiple key update messages in a single record after the handshake. This can cause the connection to deadlock,...
CVE-2025-23048-POC
CVE-2025-23048: Apache modssl TLS 1.3 Session Resumption Client Certificate Bypass Apache HTTP Server versions 2.4.35 – 2.4.62 are vulnerable to a client certificate authentication bypass when TLS 1.3 session resumption is used across virtual hosts with different SSLCACertificateFile directives. ...
crypto/tls: golang: Go crypto/tls: Denial of Service via multiple TLS 1.3 key update messages
A flaw was found in the crypto/tls package within the Go golang standard library, specifically affecting TLS 1.3 connections. A remote attacker can exploit this vulnerability by sending multiple key update messages in a single record after the handshake. This can cause the connection to deadlock,...
crypto/tls: golang: Go crypto/tls: Denial of Service via multiple TLS 1.3 key update messages
A flaw was found in the crypto/tls package within the Go golang standard library, specifically affecting TLS 1.3 connections. A remote attacker can exploit this vulnerability by sending multiple key update messages in a single record after the handshake. This can cause the connection to deadlock,...
camel-pqc-tls
Post-Quantum TLS with Apache Camel This repository contains three examples demonstrating Post-Quantum Cryptography PQC TLS 1.3 handshakes with Apache Camel, using the X25519MLKEM768 hybrid key exchange. X25519MLKEM768 combines classical X25519 elliptic curve Diffie-Hellman with ML-KEM-768 , a...
CVE-2026-93446
A flaw was found in Apache Tomcat. An incomplete cleanup vulnerability can cause Transport Layer Security TLS 1.3 connections to fail intermittently. This issue may prevent remote clients from establishing secure connections, resulting in an intermittent Denial of Service DoS. Mitigation Configur...
CVE-2026-92843
A missing bounds check in the TLS 1.3 Certificate-message parser of NetX Secure lets a malicious TLS 1.3 server trigger an unsigned-integer underflow and a subsequent heap out-of-bounds read in any peer that processes a remote Certificate message. It is reachable pre-authentication, during the...
CVE-2026-92853
The TLS 1.3 Certificate-message parser in NetX Secure decrements the message length to skip a context byte without first establishing that the message has a byte to skip. A zero-length Certificate message therefore wraps the unsigned length to 0xFFFFFFFF, which makes the bounds check that follows...
EUVD-2026-105140
A missing bounds check in the TLS 1.3 Certificate-message parser of NetX Secure lets a malicious TLS 1.3 server trigger an unsigned-integer underflow and a subsequent heap out-of-bounds read in any peer that processes a remote Certificate message. It is reachable pre-authentication, during the...