24124 matches found
hyperion-disassembler
Hyperion A native multi-architecture disassembler and binary analysis tool. Supports PE, ELF, Mach-O, and .NET binaries across x86, x64, ARM, ARM64, MIPS, and PPC. Built from scratch in C++20 with ImGui. Single statically-linked executable. No installer, no runtime dependencies. Under 3MB...
Codecepticon
!CAUTION This repo is unmaintained, visit https://github.com/sadreck/Codecepticon for the latest version. Codecepticon Table of Contents Introduction Read This First Prerequisites Visual Studio Roslyn Compiler Check to see if it works Using Codecepticon C VBA/VB6 PowerShell Obfuscating Command Li...
peeping-tom
peeping-tom Remote keylogger for Windows written in C++ Welcome to the peeping-tom project repo! Peeping-tom is a two-part program with a peeping-client deployed on a target and a toms-server listening for keylogs on the attacker machine. Getting up and running requires a decent amount of set up,...
OneNoteAnalyzer
OneNoteAnalyzer A C based tool for analyzing malicious OneNote documents Description Recently we came across few malicious OneNote Documents been distributed in-the-wild by various threat actors. This gave us an idea to develop "OneNoteAnalyzer" which would help in analysing such malicious OneNot...
deep-C
Deep-C Deep-C is an Android Deep Link Exploitation Framework that automatically decompiles APKs, identifies exposed and insecure deep link entry points, validates exploitability using static analysis and optional AI verification , and generates executable adb Proof-of-Concepts PoCs. Deep-C is...
Rubeus
Rubeus Rubeus is a C toolset for raw Kerberos interaction and abuses. It is heavily adapted from Benjamin Delpy's Kekeo project CC BY-NC-SA 4.0 license and Vincent LE TOUX's MakeMeEnterpriseAdmin project GPL v3.0 license. Full credit goes to Benjamin and Vincent for working out the hard component...
smack
SMACK is both a modular software verification toolchain and a self-contained software verifier. It can be used to verify the assertions in its input programs. In its default mode, assertions are verified up to a given bound on loop iterations and recursion depth; it contains experimental support...
EternalBlueC
EternalBlueC EternalBlue suite remade in C/C++ which includes: MS17-010 Exploit Contains DoublePulsar EternalBlue/MS17-010 vulnerability detector DoublePulsar detector DoublePulsar Upload DLL Doublepulsar Upload Shellcode DoublePulsar Upload DLL with SMB Structure Doublepulsar Upload Shellcode wi...
memoro
Memoro Memoro is a highly detailed heap profiler. Memoro not only shows you where and when your program makes heap allocations, but will show you how your program actually used that memory. Memoro collects detailed information on accesses to the heap, including reads and writes to memory and when...
cheat-engine
Cheat Engine Cheat Engine is a development environment focused on modding games and applications for personal use. Download Latest Version Older versions Links Website Forum Forum alternate Forum alternate Wiki Social Media Reddit Twitter Donate Patreon PayPal Basic Build Instructions 1. Download...
ProxyBridge
ProxyBridge ProxyBridge is a lightweight, open-source universal proxy client Proxifier alternative that provides transparent proxy routing for applications on Windows , macOS , and Linux. It redirects TCP and UDP traffic from specific processes through SOCKS5 or HTTP proxies, with the ability to...
resiprocate
Overview The reSIProcate repository contains the following C++ libraries and applications: resip library: comprehensive RFC3261 SIP stack dum Dialog Usage Manager library: high level SIP library for creating SIP user agents no media stack recon library: high level SIP UA library with media stack...
mssqlbof
mssqlbof A Beacon Object File suite for Microsoft SQL Server that speaks TDS 7.4 on the wire itself, in C. No msodbcsql.dll, no sqloledb.dll, no .NET CLR, no PowerShell. One COFF per arch, loads into every beacon that honors the canonical Beacon API. Why SQL Server shows up on nearly every...
SharpNamedPipePTH
SharpNamedPipePTH This project is a C tool to use Pass-the-Hash for authentication on a local Named Pipe for user Impersonation. You need a local administrator or SEImpersonate rights to use this. There is a blog post for explanation: https://s3cur3th1ssh1t.github.io/Named-Pipe-PTH/ It is heavily...
MCPDebugger
Fatmike's MCP Debugger Server Introduction This project is a self-made, lightweight MCP Debugger Server developed for learning and experimentation. The MCP Debugger Server exposes debugger functionality as MCP tools, enabling external MCP clients to control execution, inspect memory, and analyze...
wolfCOSE
wolfCOSE wolfCOSE is a lightweight and fast C library implementing core CBOR and COSE standards, backed by wolfSSL for cryptography. Supported Standards & RFCs Core Specifications: RFC 8949 - Concise Binary Object Representation CBOR RFC 9052 - CBOR Object Signing and Encryption COSE RFC 9053 -...
sbox
sbox - Compile-time AES string obfuscation for C++ Standard solutions rely on length + "" + string. That is trivial to reverse. sbox utilizes a constexpr AES-128 block cipher to mutate strings into high-entropy noise. The Story During the Neetcode "Encode and Decode Strings" challenge, I ported t...
Cryptolocker
DISCLAIMER : OUR TOOLS ARE FOR EDUCATIONAL PURPOSES ONLY. DON'T USE THEM FOR ILLEGAL ACTIVITIES. YOU ARE THE ONLY RESPONSABLE FOR YOUR ACTIONS! OUR TOOLS ARE OPEN SOURCE WITH NO WARRANTY AND AS ARE. Cryptolocker Crypto is open source Crypto-Locker. Crypto is developed in Visual C++. It has featur...
pbtk
pbtk - Reverse engineering Protobuf apps Protobuf is a serialization format developed by Google and used in an increasing number of Android, web, desktop and more applications. It consists of a language for declaring data structures , which is then compiled to code or another kind of structure...
dll-injector
About As the name suggests, the application primarily performs injecting a DLL into any process running on Windows. With the power of this, it is able to perform several operations on a process such as loading a DLL, unloading a DLL, and hooking primary WinAPI functions e.g., CreateFileW, ReadFil...