14793 matches found
CVE-2024-9504: Unrestricted Upload of File with Dangerous Type
The Booking calendar, Appointment Booking System plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads in all versions up to, and including, 3.2.15 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to...
WordPress plugin supports SVG cross-site scripting vulnerabilities
WordPress and WordPress plugin are both products of the WordPress Foundation.WordPress is a blogging platform developed in the PHP language. The platform supports personal blog sites on servers running PHP and MySQL. WordPress plugin is an application plugin. A cross-site scripting vulnerability...
WordPress Support SVG <= 1.1.0 - Authenticated (Author+) Stored Cross-site Scripting via SVG File Upload vulnerability
Authenticated Author+ Stored Cross-site Scripting via SVG File Upload vulnerability discovered by Francesco Carlucci in WordPress Plugin Support SVG versions = 1.1.0...
WordPress Booking calendar, Appointment Booking System plugin <= 3.2.15 - Unauthenticated Stored Cross-Site Scripting via SVG File Upload vulnerability
Unauthenticated Stored Cross-Site Scripting via SVG File Upload vulnerability discovered by Rein Daelman trein in WordPress Plugin Booking calendar, Appointment Booking System versions = 3.2.15...
WordPress Support SVG Plugin <= 1.1.0 is vulnerable to Cross Site Scripting (XSS)
Software Support SVG Type Plugin Vulnerable versions = 1.1.0 Fixed in 1.1.1 OWASP Top 10 A7: Cross-Site Scripting XSS Classification Cross Site Scripting XSS CVE CVE-2024-11091 Patch priority Low CVSS severity Low 5.9 Developer Claim ownership PSID 7d70333b5396 Credits Francesco Carlucci Required...
CVE-2024-11509
IrfanView SVG File Parsing Heap-based Buffer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of IrfanView. User interaction is required to exploit this vulnerability in that the target must visit a...
CVE-2024-11509
IrfanView SVG File Parsing Heap-based Buffer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of IrfanView. User interaction is required to exploit this vulnerability in that the target must visit a...
CVE-2024-11509
CVE-2024-11509 affects IrfanView and is a heap-based buffer overflow in SVG parsing that allows remote code execution. The issue stems from insufficient validation of the length of user-supplied data before copying to a heap buffer. Exploitation requires user interaction (the target must visit a ...
CVE-2024-11509 IrfanView SVG File Parsing Heap-based Buffer Overflow Remote Code Execution Vulnerability
IrfanView SVG File Parsing Heap-based Buffer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of IrfanView. User interaction is required to exploit this vulnerability in that the target must visit a...
CVE-2024-11509 IrfanView SVG File Parsing Heap-based Buffer Overflow Remote Code Execution Vulnerability
IrfanView SVG File Parsing Heap-based Buffer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of IrfanView. User interaction is required to exploit this vulnerability in that the target must visit a...
Security Bulletin: BM Sterling Connect:Direct Web Services is affected by DOMPurify vulnerability (CVE-2024-47875)
Summary IBM Sterling Connect:Direct Web Services uses DOMPurify as a DOM-only, super-fast, uber-tolerant XSS sanitizer for HTML, MathML and SVG. DOMpurify was vulnerable to nesting-based mXSS. Vulnerability Details CVEID:CVE-2024-47875 DESCRIPTION: DOMPurify is a DOM-only, super-fast, uber-tolera...
Malicious code in webpack-svg-spirit-import (npm)
--- -= Per source details. Do not edit below this line.=- Source: ghsa-malware e06e486295eccd406df5d378ae3d70ad72e5be5dad6bd5d99fde1d16e324f5af Any computer that has this package installed or running should be considered fully compromised. All secrets and keys stored on that computer should be...
MAL-2024-10890 Malicious code in webpack-svg-spirit-import (npm)
--- -= Per source details. Do not edit below this line.=- Source: ghsa-malware e06e486295eccd406df5d378ae3d70ad72e5be5dad6bd5d99fde1d16e324f5af Any computer that has this package installed or running should be considered fully compromised. All secrets and keys stored on that computer should be...
SUSE CVE-2024-52595
lxmlhtmlclean is a project for HTML cleaning functionalities copied from lxml.html.clean. Prior to version 0.4.0, the HTML Parser in lxml does not properly handle context-switching for special HTML tags such as , and . This behavior deviates from how web browsers parse and interpret such tags...
CVE-2024-11509: Heap-based Buffer Overflow
IrfanView SVG File Parsing Heap-based Buffer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of IrfanView. User interaction is required to exploit this vulnerability in that the target must visit a...
WordPress Media Library Tools plugin < 1.5.0 - Author+ Stored XSS via SVG vulnerability
Author+ Stored XSS via SVG vulnerability discovered by Bob Matyas in WordPress Plugin Media Library Tools versions 1.5.0...
CVE-2024-9851
The LSX Tour Operator plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads in all versions up to, and including, 1.4.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and...
CVE-2024-9442
The F4 Improvements plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads in all versions up to, and including, 1.9.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above...
CVE-2024-9442
The F4 Improvements plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads in all versions up to, and including, 1.9.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above...
CVE-2024-9111
The Product Designer plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads in all versions up to, and including, 1.0.36 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and...