Lucene search
+L

19519 matches found

Chainguard
Chainguard
•added 2025/03/03 10:05 p.m.•14 views

GHSA-MHWM-JH88-3GJF vulnerabilities

Vulnerabilities for packages: jruby, elasticsearch, ruby, logstash...

5.9AI score
SaveExploits0
Wolfi
Wolfi
•added 2025/03/03 10:05 p.m.•12 views

GHSA-MHWM-JH88-3GJF vulnerabilities

Vulnerabilities for packages: ruby, jruby...

5.9AI score
SaveExploits0
Chainguard
Chainguard
•added 2025/03/03 8:53 p.m.•11 views

GHSA-GH9Q-2XRM-X6QV vulnerabilities

Vulnerabilities for packages: jruby, elasticsearch, ruby, logstash...

5.9AI score
SaveExploits0
Wolfi
Wolfi
•added 2025/03/03 8:53 p.m.•10 views

GHSA-GH9Q-2XRM-X6QV vulnerabilities

Vulnerabilities for packages: ruby, jruby...

5.9AI score
SaveExploits0
osv_cve
osv_cve
•added 2025/03/03 12:00 a.m.•30 views

CVE-2025-27221

In the URI gem before 1.0.3 for Ruby, the URI handling methods URI.join, URImerge, URI+ have an inadvertent leakage of authentication credentials because userinfo is retained even after changing the host...

3.2CVSS3.8AI score
SaveExploits0References6
CVE
CVE
•added 2025/03/03 12:00 a.m.•375 views

CVE-2025-27219

CVE-2025-27219 : In the CGI gem for Ruby, the CGI::Cookie.parse method (Ruby CGI library) has a Denial of Service vulnerability due to no limit on the length of the raw cookie value processed. This can lead to excessive resource consumption when parsing extremely large cookies. Connected referenc...

7.5CVSS6.4AI score0.00849EPSS
SaveExploits0References3Affected Software1
Cvelist
Cvelist
•added 2025/03/03 12:00 a.m.•39 views

CVE-2025-27219

In the CGI gem before 0.4.2 for Ruby, the CGI::Cookie.parse method in the CGI library contains a potential Denial of Service DoS vulnerability. The method does not impose any limit on the length of the raw cookie value it processes. This oversight can lead to excessive resource consumption when...

5.8CVSS0.00849EPSS
SaveExploits0References2
osv_cve
osv_cve
•added 2025/03/03 12:00 a.m.•31 views

CVE-2025-27219

In the CGI gem before 0.4.2 for Ruby, the CGI::Cookie.parse method in the CGI library contains a potential Denial of Service DoS vulnerability. The method does not impose any limit on the length of the raw cookie value it processes. This oversight can lead to excessive resource consumption when...

5.8CVSS6.4AI score0.00849EPSS
SaveExploits0References5
Vulnrichment
Vulnrichment
•added 2025/03/03 12:00 a.m.•15 views

CVE-2025-27221

In the URI gem before 1.0.3 for Ruby, the URI handling methods URI.join, URImerge, URI+ have an inadvertent leakage of authentication credentials because userinfo is retained even after changing the host...

3.2CVSS6.1AI score0.00511EPSS
SaveExploits0References2
Mend
Mend
•added 2025/03/03 12:00 a.m.•14 views

CVE-2025-27221

In the URI gem before 1.0.3 for Ruby, the URI handling methods URI.join, URImerge, URI+ have an inadvertent leakage of authentication credentials because userinfo is retained even after changing the host...

5.3CVSS6.1AI score0.00511EPSS
SaveExploits0References14
Mend
Mend
•added 2025/03/03 12:00 a.m.•10 views

CVE-2025-27219

In the CGI gem before 0.4.2 for Ruby, the CGI::Cookie.parse method in the CGI library contains a potential Denial of Service DoS vulnerability. The method does not impose any limit on the length of the raw cookie value it processes. This oversight can lead to excessive resource consumption when...

7.5CVSS6.4AI score0.00849EPSS
SaveExploits0References12
Mend
Mend
•added 2025/03/03 12:00 a.m.•11 views

CVE-2025-27220

In the CGI gem before 0.4.2 for Ruby, a Regular Expression Denial of Service ReDoS vulnerability exists in the UtilescapeElement method...

7.5CVSS6.2AI score0.0076EPSS
SaveExploits0References12
CVE
CVE
•added 2025/03/03 12:00 a.m.•374 views

CVE-2025-27221

CVE-2025-27221 affects the Ruby URI module (URI.join, URI#merge, URI#+). The root issue is leakage of userinfo credentials when the host is changed, as userinfo is retained. This impacts versions of the URI gem prior to 1.0.3; the issue is fixed in 1.0.3 and later. If exploited, credential exposu...

5.3CVSS6.1AI score0.00511EPSS
SaveExploits0References4Affected Software1
CVE
CVE
•added 2025/03/03 12:00 a.m.•333 views

CVE-2025-27220

CVE-2025-27220 affects the CGI gem in Ruby, with a Regular Expression DoS in CGI::Util#escapeElement present in versions prior to 0.4.2. Documents indicate a DoS risk due to unbounded processing of input during cookie handling; no exploit details or affected environments are provided beyond this....

7.5CVSS6.2AI score0.0076EPSS
SaveExploits0References3Affected Software1
Vulnrichment
Vulnrichment
•added 2025/03/03 12:00 a.m.•14 views

CVE-2025-27220

In the CGI gem before 0.4.2 for Ruby, a Regular Expression Denial of Service ReDoS vulnerability exists in the UtilescapeElement method...

4CVSS6.2AI score0.0076EPSS
SaveExploits0References2
osv_cve
osv_cve
•added 2025/03/03 12:00 a.m.•38 views

CVE-2025-27220

In the CGI gem before 0.4.2 for Ruby, a Regular Expression Denial of Service ReDoS vulnerability exists in the UtilescapeElement method...

4CVSS6.2AI score0.0076EPSS
SaveExploits0References5
OpenVAS
OpenVAS
•added 2025/03/03 12:00 a.m.•13 views

openSUSE Security Advisory (SUSE-SU-2025:0736-1)

The remote host is missing an update for the SPDX-FileCopyrightText: 2025 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...

8.7CVSS7AI score0.0142EPSS
SaveExploits0References5
AlpineLinux
AlpineLinux
•added 2025/03/03 12:00 a.m.•29 views

CVE-2025-27219

In the CGI gem before 0.4.2 for Ruby, the CGI::Cookie.parse method in the CGI library contains a potential Denial of Service DoS vulnerability. The method does not impose any limit on the length of the raw cookie value it processes. This oversight can lead to excessive resource consumption when...

7.5CVSS6.4AI score0.00849EPSS
SaveExploits0
OpenVAS
OpenVAS
•added 2025/03/03 12:00 a.m.•21 views

Ubuntu: Security Advisory (USN-7309-1)

The remote host is missing an update for the SPDX-FileCopyrightText: 2025 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...

10CVSS8.1AI score0.10684EPSS
SaveExploits5References2
Tenable Nessus
Tenable Nessus
•added 2025/03/03 12:00 a.m.•13 views

Linux Distros Unpatched Vulnerability : CVE-2009-5147

The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - DL::dlopen in Ruby 1.8, 1.9.0, 1.9.2, 1.9.3, 2.0.0 before patchlevel 648, and 2.1 before 2.1.8 opens libraries with tainted names. CVE-2009-5147 Note that Nessu...

7.5CVSS6.5AI score0.07829EPSS
SaveExploits0References2
Rows per page
Query Builder