253087 matches found
Malicious code in devplatform-react-scripts (npm)
Source: amazon-inspector b482d551faa8ecb3cb337bd8bacfe5ec193f1bc2cad69b3998e935fbaf413efa The package's index.js requires./init on load. init.js reconstructs Cloudflare Workers hostnames via split-and-join obfuscation oob-worker.cf99-9b3.workers.dev, oob-worker.cf103-070.workers.dev,...
Malicious code in devplatform-api-v2-endpoint (npm)
Source: amazon-inspector 6f78874e3ff64b85f64b75f0481a7cadc00f15dea7b4f0eb85c1728a65ee2020 On require, index.js loads./vendor, whose top-level init fetches a platform-specific native binary from runtime-assembled Cloudflare Workers hosts oob-worker.cf99-9b3.workers.dev,...
Malicious code in ded-ps-ded-ps-core (npm)
Source: amazon-inspector cfe3941502d9792a1ad46ba7ed447227ef74d1c45cce8e9996005218d47f0f51 On require, index.js loads init.js, which selects a platform-specific endpoint and fetches an opaque native binary from Cloudflare Workers hosts whose names are assembled at runtime by joining split string...
Malicious code in dateuuidv2 (npm)
Source: amazon-inspector a15649ce278832166c0fc4b80206329a54347bf748b207c088308e72a31f72f1 The package advertises itself as a UUID v7 generator, but its main entry loads lib/bootstrap.js which unconditionally invokes extractDateISO at require time. That function reads a PORT= value from README.md ...
Adobe ColdFusion - Pre-Auth Remote Code Execution
Adobe ColdFusion versions 2018u16 and earlier, 2021u6 and earlier and 2023.0.0.330468 and earlier are affected by a Deserialization of Untrusted Data vulnerability that could result in Arbitrary code execution. Exploitation of this issue does not require user interaction. id: CVE-2023-29300 info:...
SUSE-SU-2026:23635-1 Security update for php-composer2
This update for php-composer2 fixes the following issue: - CVE-2026-84361: Arbitrary code execution via malicious Perforce source URL bsc1278257...
OPENSUSE-SU-2026:21778-1 Security update for php-composer2
This update for php-composer2 fixes the following issue: - CVE-2026-84361: Arbitrary code execution via malicious Perforce source URL bsc1278257...
libxml2: libxml2: Arbitrary code execution via heap-based buffer overflow
A flaw was found in libxml2, a software library for parsing XML documents. An integer overflow within the xmlDictAddQString function can lead to a heap-based buffer overflow. This vulnerability could allow a local attacker to execute arbitrary code on the system, potentially compromising its...
CVE-2026-83534 PostgreSQL Anonymizer: Privilege escalation to superuser via anon.anonymize_database_parallel()
PostgreSQL Anonymizer contains a vulnerability in the anon.anonymizedatabaseparallel function that allows the owner of a table to run arbitrary code with superuser privilege. The issue is fixed in PostgreSQL Anonymizer 3.2.0 and later versions...
EUVD-2026-72143
PostgreSQL Anonymizer contains a vulnerability in the anon.anonymizedatabaseparallel function that allows the owner of a table to run arbitrary code with superuser privilege. The issue is fixed in PostgreSQL Anonymizer 3.2.0 and later versions...
CVE-2026-83534
PostgreSQL Anonymizer contains a privilege escalation vulnerability in the anon.anonymize_database_parallel() function, allowing the owner of a table to execute arbitrary code with superuser privileges. The CVSS 3.1 score is 6.4 (MEDIUM) , with a network attack vector, high complexity, high privi...
CVE-2026-19633 PostgreSQL Anonymizer: unprivileged masked users can execute code via operators, domain casts and view subqueries
PostgreSQL Anonymizer contains a vulnerability that allows unprivileged masked users to execute arbitrary code by abusing operators, domain casts, or view subqueries that carry untrusted expressions. When these objects are evaluated in the context of the extension’s masking mechanisms, the...
CVE-2026-19633 PostgreSQL Anonymizer: unprivileged masked users can execute code via operators, domain casts and view subqueries
PostgreSQL Anonymizer contains a vulnerability that allows unprivileged masked users to execute arbitrary code by abusing operators, domain casts, or view subqueries that carry untrusted expressions. When these objects are evaluated in the context of the extension’s masking mechanisms, the...
EUVD-2026-72141
PostgreSQL Anonymizer contains a vulnerability that allows unprivileged masked users to execute arbitrary code by abusing operators, domain casts, or view subqueries that carry untrusted expressions. When these objects are evaluated in the context of the extension’s masking mechanisms, the...
CVE-2026-19633
PostgreSQL Anonymizer is a PostgreSQL extension for data masking. This vulnerability allows unprivileged masked users to execute arbitrary code by abusing operators, domain casts, or view subqueries that carry untrusted expressions. When these objects are evaluated within the extension's masking ...
PT-2026-86535
Name of the Vulnerable Software and Affected Versions PostgreSQL Anonymizer versions prior to 3.1.4 Description Unprivileged masked users can execute arbitrary code by abusing operators, domain casts, or view subqueries that contain untrusted expressions. This occurs when these objects are...
CVE-2026-83534: Execution with Unnecessary Privileges
PostgreSQL Anonymizer contains a vulnerability in the anon.anonymizedatabaseparallel function that allows the owner of a table to run arbitrary code with superuser privilege. The issue is fixed in PostgreSQL Anonymizer 3.2.0 and later versions...
CVE-2026-19633: Improper Neutralization of Special Elements used in an SQL Command
PostgreSQL Anonymizer contains a vulnerability that allows unprivileged masked users to execute arbitrary code by abusing operators, domain casts, or view subqueries that carry untrusted expressions. When these objects are evaluated in the context of the extension’s masking mechanisms, the...
PT-2026-86537
PostgreSQL Anonymizer contains a vulnerability in the anon.anonymize database parallel function that allows the owner of a table to run arbitrary code with superuser privilege. The issue is fixed in PostgreSQL Anonymizer 3.2.0 and later versions...
Debian dla-4774 : aom-tools - security update
The remote Debian 12 host has packages installed that are affected by multiple vulnerabilities as referenced in the dla-4774 advisory. ------------------------------------------------------------------------- Debian LTS Advisory DLA-4774-1 [email protected]...