72625 matches found
EulerOS 2.0 SP11 : python-pygments (EulerOS-SA-2026-3096)
According to the versions of the python-pygments packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : A security flaw has been discovered in pygments up to 2.19.2. The impacted element is the function AdlLexer of the file...
EulerOS 2.0 SP11 : python-pip (EulerOS-SA-2026-3094)
According to the versions of the python-pip packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : pip would treat consolescripts and guiscripts as paths instead of file names without sanitizing the resolved absolute path to the installation...
python313-Django4-4.2.30-5.1 on GA media (moderate)
python313-Django4-4.2.30-5.1 on GA media Announcement ID: openSUSE-SU-2026:11465-1 Rating: moderate Cross-References: CVE-2026-15307 CVE-2026-15337 CVE-2026-15830 CVE-2026-15920 CVSS scores: CVE-2026-15307 SUSE : 9.9 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H CVE-2026-15307 SUSE : 9.3...
GHSA-FP3F-MC75-235C pypdf: Possible large memory usage for large /ToUnicode streams
Impact An attacker who uses this vulnerability can craft a PDF which leads to large memory consumption. This requires parsing the /ToUnicode entry of a font with unusually large values, for example during text extraction. Patches This has been fixed in pypdf==6.15.0. Workarounds If you cannot...
cewler (1.2.0.post1), python-xdoc (>=0.1.0, <=0.1.1) potentially affected by CVE-2026-71870 via pypdf (4.0.1)
pypdf PYPI version 4.0.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - cewler 1.2.0.post1 - python-xdoc =0.1.0, =0.1.1 Source cves: CVE-2026-71870 Source advisory: OSV:GHSA-FP3F-MC75-235C...
genai-4-dps-helper (0.2.31), news-scraper-pdf (1.1.6) +6 more potentially affected by CVE-2026-71870 via pypdf (5.3.0)
pypdf PYPI version 5.3.0 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - genai-4-dps-helper 0.2.31 - news-scraper-pdf 1.1.6 - polytext =0.1.0, =0.1.0, =0.1.10 - python-pdf-toolkit 0.1.1 - synforge 0.1.0 - ta-using-llms 0.0....
cewler (1.2.0.post1), python-xdoc (>=0.1.0, <=0.1.1) potentially affected by CVE-2026-71852 via pypdf (4.0.1)
pypdf PYPI version 4.0.1 is affected by a known vulnerability. The following packages have a transitive dependency on pypdf and may be impacted: - cewler 1.2.0.post1 - python-xdoc =0.1.0, =0.1.1 Source cves: CVE-2026-71852 Source advisory: OSV:GHSA-FWG2-594C-JP42...
EUVD-2025-27054
Frappe is a full-stack web application framework. Versions 14.96.9 and below, and 15.0.0 through 15.71.0 have an insecure endpoint parameter that is vulnerable to error-based SQL Injection through lack of validation. Sensitive information such as versioning can be retrieved. This issue is fixed i...
Malicious code in atlas-internal (PyPI)
--- -= Per source details. Do not edit below this line.=- Source: amazon-inspector cdd4a17504623add1ff4f374ea9c2283d1eb5a863265e012592142b169cd9d90 setup.py overrides the egginfo command to execute automatically during pip install. The overridden command collects the installer's hostname, current...
MAL-2026-13619 Malicious code in atlas-internal (PyPI)
--- -= Per source details. Do not edit below this line.=- Source: amazon-inspector cdd4a17504623add1ff4f374ea9c2283d1eb5a863265e012592142b169cd9d90 setup.py overrides the egginfo command to execute automatically during pip install. The overridden command collects the installer's hostname, current...
GitPython: Unsafe git option guard bypass via split_single_char_options=False short-option token smuggling enables command execution
Summary The checkunsafeoptions guard can be bypassed on every guarded method clone/clonefrom, fetch/pull/push, lsremote, itercommits, blame, archive by combining a single-character kwarg with splitsinglecharoptions=False. The guard's candidate list omits the smuggled option, but transformkwarg...
cabrita (>=2.2.2b1, <=2.2.2b2), cico (>=0.1.0, <=0.1.8) +4 more potentially affected by CVE-2026-76220 via gitpython (2.1.10)
gitpython PYPI version 2.1.10 is affected by a known vulnerability. The following packages have a transitive dependency on gitpython and may be impacted: - cabrita =2.2.2b1, =0.1.0, =0.1.0, =3.11.1, =0.9.0, =0.9.7.2 Source cves: CVE-2026-76220 Source advisory: OSV:GHSA-WVPP-8HX9-P66J...
sealights-python-agent (>=0.2.213, <=0.2.247) potentially affected by CVE-2026-76220 via gitpython (2.1.13)
gitpython PYPI version 2.1.13 is affected by a known vulnerability. The following packages have a transitive dependency on gitpython and may be impacted: - sealights-python-agent =0.2.213, =0.2.247 Source cves: CVE-2026-76220 Source advisory: OSV:GHSA-WVPP-8HX9-P66J...
cabrita (>=2.2.2b1, <=2.2.2b2), cico (>=0.1.0, <=0.1.8) +4 more potentially affected by CVE-2026-76221 via gitpython (2.1.10)
gitpython PYPI version 2.1.10 is affected by a known vulnerability. The following packages have a transitive dependency on gitpython and may be impacted: - cabrita =2.2.2b1, =0.1.0, =0.1.0, =3.11.1, =0.9.0, =0.9.7.2 Source cves: CVE-2026-76221 Source advisory: OSV:GHSA-JM78-9FVV-MHGR...
sealights-python-agent (>=0.2.213, <=0.2.247) potentially affected by CVE-2026-76221 via gitpython (2.1.13)
gitpython PYPI version 2.1.13 is affected by a known vulnerability. The following packages have a transitive dependency on gitpython and may be impacted: - sealights-python-agent =0.2.213, =0.2.247 Source cves: CVE-2026-76221 Source advisory: OSV:GHSA-JM78-9FVV-MHGR...
cabrita (>=2.2.2b1, <=2.2.2b2), cico (>=0.1.0, <=0.1.8) +4 more potentially affected by CVE-2026-76222 via gitpython (2.1.10)
gitpython PYPI version 2.1.10 is affected by a known vulnerability. The following packages have a transitive dependency on gitpython and may be impacted: - cabrita =2.2.2b1, =0.1.0, =0.1.0, =3.11.1, =0.9.0, =0.9.7.2 Source cves: CVE-2026-76222 Source advisory: OSV:GHSA-HMQ2-W58F-27JC...
sealights-python-agent (>=0.2.213, <=0.2.247) potentially affected by CVE-2026-76222 via gitpython (2.1.13)
gitpython PYPI version 2.1.13 is affected by a known vulnerability. The following packages have a transitive dependency on gitpython and may be impacted: - sealights-python-agent =0.2.213, =0.2.247 Source cves: CVE-2026-76222 Source advisory: OSV:GHSA-HMQ2-W58F-27JC...
sealights-python-agent (>=0.2.213, <=0.2.247) potentially affected by CVE-2026-76217 via gitpython (2.1.13)
gitpython PYPI version 2.1.13 is affected by a known vulnerability. The following packages have a transitive dependency on gitpython and may be impacted: - sealights-python-agent =0.2.213, =0.2.247 Source cves: CVE-2026-76217 Source advisory: OSV:GHSA-HH9P-6WH2-4MFC...
cabrita (>=2.2.2b1, <=2.2.2b2), cico (>=0.1.0, <=0.1.8) +4 more potentially affected by CVE-2026-76217 via gitpython (2.1.10)
gitpython PYPI version 2.1.10 is affected by a known vulnerability. The following packages have a transitive dependency on gitpython and may be impacted: - cabrita =2.2.2b1, =0.1.0, =0.1.0, =3.11.1, =0.9.0, =0.9.7.2 Source cves: CVE-2026-76217 Source advisory: OSV:GHSA-HH9P-6WH2-4MFC...
sealights-python-agent (>=0.2.213, <=0.2.247) potentially affected by CVE-2026-76218 via gitpython (2.1.13)
gitpython PYPI version 2.1.13 is affected by a known vulnerability. The following packages have a transitive dependency on gitpython and may be impacted: - sealights-python-agent =0.2.213, =0.2.247 Source cves: CVE-2026-76218 Source advisory: OSV:GHSA-9RJ7-RF2P-W77R...