34 matches found
CLSA-2026-1792162218 TuxCare security update for @babel/traverse (1 CVE)
TuxCare rebuilt @babel/traverse to address 1 CVE. Fixed in 7.11.5-tuxcare.1...
CLSA-2026-1792162217 TuxCare security update for @babel/traverse (1 CVE)
TuxCare rebuilt @babel/traverse to address 1 CVE. Fixed in 7.12.13-tuxcare.1...
CLSA-2026-1792162216 TuxCare security update for @babel/traverse (1 CVE)
TuxCare rebuilt @babel/traverse to address 1 CVE. Fixed in 7.16.7-tuxcare.2...
CLSA-2026-1792162215 TuxCare security update for @babel/traverse (1 CVE)
TuxCare rebuilt @babel/traverse to address 1 CVE. Fixed in 7.18.9-tuxcare.3...
CLSA-2026-1792162213 TuxCare security update for @babel/traverse (1 CVE)
TuxCare rebuilt @babel/traverse to address 1 CVE. Fixed in 7.21.0-tuxcare.4...
CLSA-2026-1792162212 TuxCare security update for @babel/traverse (1 CVE)
TuxCare rebuilt @babel/traverse to address 1 CVE. Fixed in 7.21.5-tuxcare.1...
ROOT-APP-NPM-CVE-2023-45133 CVE-2023-45133 in babel-traverse - Patched by Root
Root has patched CVE-2023-45133 in the babel-traverse package for Root:npm. Multiple fixed versions available...
Arbitrary code execution (RCE) @babel/traverse dependency in Jira Software Data Center
This is a vulnerability in a non-Atlassian Jira Software Data Cente dependency. Atlassian's application of this dependency presents a lower, non-critical assessed risk. This vulnerability affects certain versions of Atlassian Jira Software Data Center. The @babel/traverse dependency is affected b...
Linux Distros Unpatched Vulnerability : CVE-2023-45133
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - Babel is a compiler for writingJavaScript. In @babel/traverse prior to versions 7.23.2 and 8.0.0-alpha.4 and all versions of babel-traverse, using Babel to...
Security Bulletin: IBM Storage Fusion HCI may be vulnerable to Injection, Regular Expression Denial of Service (ReDoS), and Arbitrary Code Execution and via use of postcss, semver, babel-traverse (CVE-2023-45133, CVE-2022-25883, CVE-2023-44270)
Summary JavaScript libraries postcss, semver, and babel-traverse are used by IBM Storage Fusion HCI's Web Interface. Vulnerabilities in these libraries could lead to Denial of Service and Arbitrary Code Injection as described the the CVEs listed in the "Vulnerability Details" section. Vulnerabili...
Security Bulletin: Babel-traverse is vulnerable to CVE-2023-45133 used in IBM Maximo Application Suite - Monitor Component
Summary IBM Maximo Application Suite - Monitor Component uses babel-traverse which is vulnerable to CVE-2023-45133. This bulletin identifies the steps to take to address the vulnerability. Vulnerability Details CVEID:CVE-2023-45133 DESCRIPTION: Babel could allow a local attacker to execute...
Security Bulletin: IBM Storage Fusion may be vulnerable to Injection, Regular Expression Denial of Service (ReDoS), and Arbitrary Code Execution and via use of postcss, semver, babel-traverse (CVE-2023-45133, CVE-2022-25883, CVE-2023-44270)
Summary JavaScript libraries postcss, semver, and babel-traverse are used by IBM Storage Fusion's Web Interface. Vulnerabilities in these libraries could lead to Denial of Service and Arbitrary Code Injection as described the the CVEs listed in the "Vulnerability Details" section. Vulnerability...
SUSE CVE-2023-45133
Babel is a compiler for writingJavaScript. In @babel/traverse prior to versions 7.23.2 and 8.0.0-alpha.4 and all versions of babel-traverse, using Babel to compile code that was specifically crafted by an attacker can lead to arbitrary code execution during compilation, when using plugins that re...
Debian DSA-5528-1 : node-babel7 - security update
The remote Debian 11 / 12 host has packages installed that are affected by a vulnerability as referenced in the dsa-5528 advisory. - Babel is a compiler for writingJavaScript. In @babel/traverse prior to versions 7.23.2 and 8.0.0-alpha.4 and all versions of babel-traverse, using Babel to compile...
@alexbeck2911/componentx (>=0.1.0, <=0.1.5), @amraneze/react-instagram-login (>=2.0.0, <=2.0.1) +296 more potentially affected by CVE-2023-45133 via babel-traverse (>=7.0.0-alpha.1, <=7.0.0-beta.3)
babel-traverse NPM version =7.0.0-alpha.1, =0.1.0, =2.0.0, =0.1.0, =1.0.0, =1.0.0, =0.1.0, =6.0.0-rc1, =0.3.0, =0.19.0, =1.0.0, =1.0.0, =5.0.20, =6.0.6 and more Source cves: CVE-2023-45133 Source advisory: OSV:GHSA-67HX-6X53-JW92...
@alexbeck2911/componentx (>=0.1.0, <=0.1.5), @amraneze/react-instagram-login (>=2.0.0, <=2.0.1) +296 more potentially affected by CVE-2023-45133 via babel-traverse (>=7.0.0-alpha.1, <=7.0.0-beta.3)
babel-traverse NPM version =7.0.0-alpha.1, =0.1.0, =2.0.0, =0.1.0, =1.0.0, =1.0.0, =0.1.0, =6.0.0-rc1, =0.3.0, =0.19.0, =1.0.0, =1.0.0, =5.0.20, =6.0.6 and more Source cves: CVE-2023-45133 Source advisory: GHSA-67HX-6X53-JW92...
1st (>=0.1.0, <=0.1.45), 20190403-utils (1.0.0) +6739 more potentially affected by CVE-2023-45133 via @babel/traverse (>=7.0.0-beta.4, <=7.23.0)
@babel/traverse NPM version =7.0.0-beta.4, =0.1.0, =0.0.1, =0.0.0, =0.0.2, =0.0.1, =0.6.0, =0.0.1, =0.0.2, =0.0.1, =0.0.0-manual.7283bbad, =0.28.1, =0.37.0-beta-5 and more Source cves: CVE-2023-45133 Source advisory: OSV:GHSA-67HX-6X53-JW92...
1st (>=0.1.0, <=0.1.45), 20190403-utils (1.0.0) +6739 more potentially affected by CVE-2023-45133 via @babel/traverse (>=7.0.0-beta.4, <=7.23.0)
@babel/traverse NPM version =7.0.0-beta.4, =0.1.0, =0.0.1, =0.0.0, =0.0.2, =0.0.1, =0.6.0, =0.0.1, =0.0.2, =0.0.1, =0.0.0-manual.7283bbad, =0.28.1, =0.37.0-beta-5 and more Source cves: CVE-2023-45133 Source advisory: GHSA-67HX-6X53-JW92...
vite-plugin-vue-css-modules (3.1.4) potentially affected by CVE-2023-45133 via @babel/traverse (8.0.0-alpha.2)
@babel/traverse NPM version 8.0.0-alpha.2 is affected by a known vulnerability. The following packages have a transitive dependency on @babel/traverse and may be impacted: - vite-plugin-vue-css-modules 3.1.4 Source cves: CVE-2023-45133 Source advisory: OSV:GHSA-67HX-6X53-JW92...
vite-plugin-vue-css-modules (3.1.4) potentially affected by CVE-2023-45133 via @babel/traverse (8.0.0-alpha.2)
@babel/traverse NPM version 8.0.0-alpha.2 is affected by a known vulnerability. The following packages have a transitive dependency on @babel/traverse and may be impacted: - vite-plugin-vue-css-modules 3.1.4 Source cves: CVE-2023-45133 Source advisory: GHSA-67HX-6X53-JW92...