136439 matches found
CLEANSTART-2026-LJ66214 llhttp parser in the http module in Node v20
Security vulnerability affects the openjdk17 package. The llhttp parser in the http module in Node v20...
CLEANSTART-2026-BM42059 HTTP/2 protocol allows a denial of service (server resource consumption) because request cancellation can reset many streams quickly, as exploited in the wild in August through October 2023
Security vulnerability affects the openjdk21 package. The HTTP/2 protocol allows a denial of service server resource consumption because request cancellation can reset many streams quickly, as exploited in the wild in August through October 2023...
CVE-2025-55182-Lab
CVE-2025-55182 Lab A hands-on lab to exploit CVE-2025-55182 React2Shell - Remote Code Execution in React Server Components. โ ๏ธ Disclaimer Educational purposes only. Only test on systems you own. Quick Start Clone and start git clone https://github.com/dhananjayakumarn/CVE-2025-55182-Lab.git cd...
CLEANSTART-2026-CO30211 malicious HTTP/2 peer can cause excessive CPU consumption in the client or server by opening a large number of streams and then sending many small SETTINGS frames containing SETTINGS_INITIAL_WINDOW...
CVE-2026-78669 affects multiple packages. A malicious HTTP/2 peer can cause excessive CPU consumption in the client or server by opening a large number of streams and then sending many small SETTINGS frames containing SETTINGSINITIALWINDOWSIZE values. See references for individual vulnerability...
CLEANSTART-2026-QI90513 HTTP/2 servers could end up crashing due to inadvertently modifying its HPACK encoder concurrently
CVE-2026-97032 affects multiple packages. HTTP/2 servers could end up crashing due to inadvertently modifying its HPACK encoder concurrently. See references for individual vulnerability details...
CLEANSTART-2026-QG19683 Historically, we have been rather lax about malformed framing-related headers in our HTTP/2 implementation, as they cannot interfere with HTTP/2 framing
CVE-2026-78660 affects multiple packages. Historically, we have been rather lax about malformed framing-related headers in our HTTP/2 implementation, as they cannot interfere with HTTP/2 framing. See references for individual vulnerability details...
proxify
Features โข Installation โข Usage โข Running Proxify โข Installing SSL Certificate โข Applications of Proxify โข Join Discord Swiss Army Knife Proxy for rapid deployments. Supports multiple operations such as request/response dump, filtering and manipulation via DSL language, upstream HTTP/Socks5 proxy...
CLEANSTART-2026-IE92648 client may issue specially crafted HTTP/1
Security vulnerability affects the solr package. A client may issue specially crafted HTTP/1...
CVE-2021-31166-exploit
CVE-2021-31166 HTTP Protocol Stack Remote Code Execution Vulnerability Attacked version๏ผ Microsoft:Windows 10: version 2004 for 32-bit Systems version 2004 for x64-based Systems version 2004 for ARM64-based Systems version 20H2 for 32-bit Systems version 20H2 for x64-based Systems version 20H2 fo...
web-traffic-generator
web-traffic-generator A quick and dirty HTTP/S "organic" traffic generator. About Just a simple poorly written Python script that aimlessly "browses" the internet by starting at pre-defined ROOTURLS and randomly "clicking" links on pages until the pre-defined MAXDEPTH is met. I created this as a...
http-desync-guardian
Overview HTTP/1.1 went through a long evolution since 1991 to 2014: HTTP/0.9 โ 1991 HTTP/1.0 โ 1996 HTTP/1.1 RFC 2068 โ 1997 RFC 2616 - 1999 RFC 7230 - 2014 This means there is a variety of servers and clients, which might have different views on request boundaries, creating opportunities for...
CVE-2019-12725-Command-Injection
POC CVE-2019-12725-Remote-Command-Execution ZeroShell 3.9.0 Remote Command Injection Zeroshell 3.9.0 is prone to a remote command execution vulnerability. Specifically, this issue occurs because the web application mishandles a few HTTP parameters. An unauthenticated attacker can exploit this iss...
CVE-2025-31650
TomcatKiller - CVE-2025-31650 ๐จ Proof of Concept PoC for Apache Tomcat HTTP/2 DoS vulnerability CVE-2025-31650 This script triggers a memory exhaustion condition in Apache Tomcat by sending malformed priority headers over HTTP/2. ๐ฏ Affected Versions Apache Tomcat 9.0.76 โ 9.0.102 Apache Tomcat...
Security Bulletin: IBM HTTP Server is affected by multiple vulnerabilities due to the included Apache HTTP Server and libexpat
Summary IBM HTTP Server used by IBM WebSphere Application Server is affected by multiple vulnerabilities due to libexpat and the included Apache HTTP Server. Vulnerability Details CVEID:CVE-2026-66046 DESCRIPTION: Expat through 2.8.3 contains a denial of service vulnerability caused by quadratic...
ProxyBroker
ProxyBroker .. image:: https://img.shields.io/pypi/v/proxybroker.svg?style=flat-square :target: https://pypi.python.org/pypi/proxybroker/ .. image:: https://img.shields.io/travis/constverum/ProxyBroker.svg?style=flat-square :target: https://travis-ci.org/constverum/ProxyBroker .. image::...
Envoy-CPU-Exhaustion-Vulnerability-PoC
Envoy CPU Exhaustion Vulnerability PoC This repository contains a proof-of-concept PoC Python script to demonstrate the CPU exhaustion vulnerability in Envoy caused by a flood of CONTINUATION frames. Author: blackmagic 2024 Description Envoy is a cloud-native, open-source edge and service proxy...
n00bRAT
n00bRAT v0.7 It's a tiny C program which emulates a bare minimum HTTP server for fingerprinting security scanners. It let's one control the machine over this faked HTTPv0.1 protocol. This n00b server was created as RAT during college for Ethical Hacking course. What is it / Why it is / etc. Read...
CVE-2022-29337
CVE-2022-29337 C-DATA FD702XW-X-R430 v2.1.13X001 was discovered to contain a command injection vulnerability via the vacmd parameter in formlanipv6. This vulnerability allows attackers to execute arbitrary commands via a crafted HTTP request...
CVE-2025-4679-SecureOAuth-Demo---Enfoque-educativo
๐ OAuth Security Laboratory: CVE-2025-4679 Educational Simulator A safe, isolated environment to learn about OAuth vulnerabilities without risking real systems ๐ Quick Start | ๐ Learning Path | ๐ก๏ธ Safe Environment | ๐ฅ Contributors ๐ Overview This educational laboratory simulates the CVE-2025-4679...
phishery
phishery Phishery is a Simple SSL Enabled HTTP server with the primary purpose of phishing credentials via Basic Authentication. Phishery also provides the ability easily to inject the URL into a .docx Word document. The power of phishery is best demonstrated by setting a Word document's template...