438 matches found
GP Premium <= 2.4.0 - Cross-Site Scripting
The GP Premium plugin for WordPress up to 2.4.0 is vulnerable to reflected XSS via the 'message' parameter in inc/verify.php lines 95-101, where a message passed with slactivation=false is URL-decoded and used unsanitized in addsettingserror, allowing XSS payloads to be reflected in admin notices...
CVE-2024-0710
CVE-2024-0710 Vulnerability: CVE-2024-0710 Unauthenticated Form Submission Unique ID Modification CVSS: 5.3 Medium Software: GP Unique ID gp-unique-id Affected versions: = 1.5.5 Patched version: 1.5.6 Developer: Gravity Wiz Researcher: Karl Emil Nikka, Nikka Systems Publicly published: 2024-04-10...
PT-2026-120610
WarehousePG WHPG 6.27.1 through 6.27.6 and 7.2.1 through 7.6.0 are affected by a missing authorization vulnerability CWE-862 in gp add coordinator standby. The function is named gp add master standby in WHPG 6, and WHPG 7 keeps that name as an alias. Unlike the other segment add and remove...
PT-2026-120609
WarehousePG WHPG 6.27.1 through 6.27.6 and 7.2.1 through 7.6.0 are affected by a missing authorization vulnerability CWE-862 in the built-in cluster expansion functions gp expand lock catalog and gp expand bump version. Any authenticated database role can run them, and neither checks privileges. ...
PT-2026-120608
WarehousePG WHPG 7.2.1 through 7.6.0 is affected by a missing authorization vulnerability CWE-862 in the built-in function gp log backend memory contexts. Any authenticated database role can run this function without a GRANT. It also gets around the superuser restriction that PostgreSQL places on...
Mal-AAEGAN: Adversarial Autoencoder with Double-Critic WGAN-GP for Malware Generation
Machine-learning ML malware detectors are known to be vulnerable to adversarial samples. Generative adversarial networks GANs such as MalGAN, Mal-LSGAN, and our previous Mal-D2GAN can craft adversarial malware to probe and harden these detectors, yet they operate directly on a high-dimensional,...
A GAN-Based Framework for Robust DDoS Attack Detection
The availability and consistency of online services remain vulnerable due to Distributed Denial of Service DDoS attacks. These attacks are evolving by adopting more complex strategies to evade traditional network security systems. Despite the effectiveness of machine learning models in detecting...
Malicious code in gp-actions (npm)
Source: ossf-package-analysis 0af07f18bec84cba6878dd345ea1281728e0257d285118a40d835d7c9a2985a6 The OpenSSF Package Analysis project identified 'gp-actions' @ 1.0.0 npm as malicious. It is considered malicious because: - The package communicates with a domain associated with malicious activity. --...
Malicious code in gp-logger (npm)
The package gp-logger was found to contain malicious code. --- Credit: OpenSSF source...
Malicious code in gp-screens (npm)
Source: ossf-package-analysis cd47b7e0b82292eb8e0cf4de06de3b9027df37daa726f014751598535afdacaf The OpenSSF Package Analysis project identified 'gp-screens' @ 1.0.0 npm as malicious. It is considered malicious because: - The package communicates with a domain associated with malicious activity. --...
Malicious code in gp-analytics (npm)
--- Credit: OpenSSF source...
Malicious code in gp-colors (npm)
--- Credit: OpenSSF source...
Malicious code in gp-assets (npm)
--- Credit: OpenSSF source...
Malicious code in gp-comps (npm)
--- Credit: OpenSSF source...
Malicious code in gp-db-models (npm)
The package gp-db-models was found to contain malicious code. --- Credit: OpenSSF source...
Malicious code in gp-constants (npm)
--- Credit: OpenSSF source...
CVE-2026-66627
Unrestricted Upload of File with Dangerous Type vulnerability in EDGE22 Studios Ltd. GP Premium allows Remote Code Inclusion. This issue affects GP Premium: from n/a through 2.5.5...
EUVD-2026-60916
Contributor Arbitrary File Upload in GP Premium = 2.5.5 versions...
CVE-2026-66627 WordPress GP Premium plugin <= 2.5.5 - Arbitrary File Upload vulnerability
Unrestricted Upload of File with Dangerous Type vulnerability in EDGE22 Studios Ltd. GP Premium allows Remote Code Inclusion. This issue affects GP Premium: from n/a through 2.5.5...
CVE-2026-66627 WordPress GP Premium plugin <= 2.5.5 - Arbitrary File Upload vulnerability
Unrestricted Upload of File with Dangerous Type vulnerability in EDGE22 Studios Ltd. GP Premium allows Remote Code Inclusion. This issue affects GP Premium: from n/a through 2.5.5...