Lucene search

K
rockyRockylinux Product ErrataRLSA-2023:5683
HistoryOct 14, 2023 - 2:08 a.m.

mariadb:10.5 security update

2023-10-1402:08:04
Rockylinux Product Errata
errata.rockylinux.org
32
mariadb 10.5
galera module
security update
cve-2023-5157
cve-2022-32081
cve-2022-32082
cve-2022-32084
cve-2022-32089
cve-2022-32091
cve-2022-38791
cve-2022-47015
rocky linux 8
cvss score

7.5 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

NONE

Integrity Impact

NONE

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

7.5 High

CVSS2

Access Vector

Access Complexity

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:L/Au:N/C:P/I:P/A:P

0.003 Low

EPSS

Percentile

67.8%

An update is available for mariadb, galera, module.Judy, module.mariadb, Judy, module.galera.
This update affects Rocky Linux 8.
A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE list
MariaDB is a multi-user, multi-threaded SQL database server that is binary compatible with MySQL.

The following packages have been upgraded to a later upstream version: galera
(26.4.14), mariadb (10.5.22).

Security Fix(es):

  • mariadb: node crashes with Transport endpoint is not connected mysqld got signal 6 (CVE-2023-5157)

  • mariadb: use-after-poison in prepare_inplace_add_virtual in handler0alter.cc (CVE-2022-32081)

  • mariadb: assertion failure at table->get_ref_count() == 0 in dict0dict.cc (CVE-2022-32082)

  • mariadb: segmentation fault via the component sub_select (CVE-2022-32084)

  • mariadb: server crash in st_select_lex_unit::exclude_level (CVE-2022-32089)

  • mariadb: server crash in JOIN_CACHE::free or in copy_fields (CVE-2022-32091)

  • mariadb: compress_write() fails to release mutex on failure (CVE-2022-38791)

  • mariadb: NULL pointer dereference in spider_db_mbase::print_warnings() (CVE-2022-47015)

For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

7.5 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

NONE

Integrity Impact

NONE

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

7.5 High

CVSS2

Access Vector

Access Complexity

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:L/Au:N/C:P/I:P/A:P

0.003 Low

EPSS

Percentile

67.8%