Lucene search

K
redosRedosROS-2-544
HistoryDec 24, 2021 - 12:00 a.m.

ROS-2-544

2021-12-2400:00:00
redos.red-soft.ru
8

8.4 High

AI Score

Confidence

Low

0.007 Low

EPSS

Percentile

80.4%

2.544 Multiple vulnerabilities in PostgreSQL (CVE-2021-32027, CVE-2021-32028, CVE-2021-32029)

1. Vulnerability Description:

CVE-2021-32027 The vulnerability allows a remote attacker to execute arbitrary code on the target system. CVE-2021-32028, CVE-2021-32029 Vulnerability allows a remote user to gain access to confidential information.Identifier of the Information Security Threat Data Bank of the FSTEC of Russia: BDU:2021-02776, BDU:2021-02775, BDU:2021-02774

2. Possible measures to eliminate the vulnerability

Refuse to use the Postgresql DBMS or - install security updates for the package: Postgresql**Installing updates is possible in the following ways:**a) If the computer with the installed OS version has access to the vendor’s official repository, run the update as administrator with the command:# yum updateAfter the list of updated packages is displayed, agree to apply the updates by pressing the Y key on the keyboard. Wait until the update installation is complete and make sure that there are no errors during its installation.b)If the computer with the installed OS version does not have access to the vendor’s official repository, you should perform the following actions: - download the updated package (with dependencies if necessary): http://repo.red-soft.ru/redos/7.2c/x86_64/updates/postgresql-static-11.12-1.el7.x86_64.rpm Check the integrity and authenticity of the package according to instructionsInstall the downloaded package(s) with the command:# yum localinstall *.rpmWhen the list of updated packages is displayed, agree to apply the updates by pressingY on the keyboard. Wait for the updates to finish installing and make sure there are no errors during the installation.

Date of last modification: 08.09.2021

OSVersionArchitecturePackageVersionFilename
redosunknown<=Β UNKNOWN