Lucene search

K
redhatRedHatRHSA-2021:2375
HistoryJun 10, 2021 - 9:54 a.m.

(RHSA-2021:2375) Important: postgresql:13 security update

2021-06-1009:54:30
access.redhat.com
81

6.5 Medium

CVSS2

Attack Vector

NETWORK

Attack Complexity

LOW

Authentication

SINGLE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:L/Au:S/C:P/I:P/A:P

8.8 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

0.007 Low

EPSS

Percentile

80.4%

PostgreSQL is an advanced object-relational database management system (DBMS).

The following packages have been upgraded to a later upstream version: postgresql (13.3).

Security Fix(es):

  • postgresql: Buffer overrun from integer overflow in array subscripting calculations (CVE-2021-32027)

  • postgresql: Memory disclosure in INSERT … ON CONFLICT … DO UPDATE (CVE-2021-32028)

  • postgresql: Memory disclosure in partitioned-table UPDATE … RETURNING (CVE-2021-32029)

For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

OSVersionArchitecturePackageVersionFilename
RedHatanyx86_64postgresql-plpython3-debuginfo< 13.3-1.module+el8.4.0+11254+85259292postgresql-plpython3-debuginfo-13.3-1.module+el8.4.0+11254+85259292.x86_64.rpm
RedHatanyppc64lepostgresql-upgrade-devel-debuginfo< 13.3-1.module+el8.4.0+11254+85259292postgresql-upgrade-devel-debuginfo-13.3-1.module+el8.4.0+11254+85259292.ppc64le.rpm
RedHatanys390xpostgresql-plpython3< 13.3-1.module+el8.4.0+11254+85259292postgresql-plpython3-13.3-1.module+el8.4.0+11254+85259292.s390x.rpm
RedHatanys390xpostgresql-docs< 13.3-1.module+el8.4.0+11254+85259292postgresql-docs-13.3-1.module+el8.4.0+11254+85259292.s390x.rpm
RedHatanyaarch64pgaudit< 1.5.0-1.module+el8.4.0+8873+b821c30apgaudit-1.5.0-1.module+el8.4.0+8873+b821c30a.aarch64.rpm
RedHatanys390xpostgresql-plperl-debuginfo< 13.3-1.module+el8.4.0+11254+85259292postgresql-plperl-debuginfo-13.3-1.module+el8.4.0+11254+85259292.s390x.rpm
RedHatanyx86_64postgresql-contrib< 13.3-1.module+el8.4.0+11254+85259292postgresql-contrib-13.3-1.module+el8.4.0+11254+85259292.x86_64.rpm
RedHatanyx86_64postgresql-server< 13.3-1.module+el8.4.0+11254+85259292postgresql-server-13.3-1.module+el8.4.0+11254+85259292.x86_64.rpm
RedHatanys390xpostgresql-test-debuginfo< 13.3-1.module+el8.4.0+11254+85259292postgresql-test-debuginfo-13.3-1.module+el8.4.0+11254+85259292.s390x.rpm
RedHatanyppc64lepostgresql-plpython3-debuginfo< 13.3-1.module+el8.4.0+11254+85259292postgresql-plpython3-debuginfo-13.3-1.module+el8.4.0+11254+85259292.ppc64le.rpm
Rows per page:
1-10 of 1211

6.5 Medium

CVSS2

Attack Vector

NETWORK

Attack Complexity

LOW

Authentication

SINGLE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:L/Au:S/C:P/I:P/A:P

8.8 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

0.007 Low

EPSS

Percentile

80.4%