(RHSA-2019:1636) Important: OpenShift Container Platform 4.1 jenkins-2-plugins security update

2019-07-03T15:47:24
ID RHSA-2019:1636
Type redhat
Reporter RedHat
Modified 2019-07-03T15:49:54

Description

This advisory contains the jenkins-2-plugins RPM packages for Red Hat OpenShift Container Platform 4.1.4. See the following advisory for the container images for this release:

https://access.redhat.com/errata/RHBA-2019:1635

Security Fix(es):

  • jenkins-plugin-workflow-remote-loader: Unsafe Script Security whitelist entry in Pipeline Remote Loader Plugin (CVE-2019-10328)

  • jenkins-credentials-plugin: Certificate file read vulnerability in Credentials Plugin (CVE-2019-10320)

  • jenkins-plugin-token-macro: XML External Entity processing the ${XML} macro (CVE-2019-10337)

For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

You may download the oc tool and use it to inspect release image metadata as follows:

$ oc adm release info quay.io/openshift-release-dev/ocp-release:4.1.4

The image digest is sha256:a6c177eb007d20bb00bfd8f829e99bd40137167480112bd5ae1c25e40a4a163a

All OpenShift Container Platform 4.1 users are advised to upgrade to these updated packages and images.