(RHSA-2010:0581) Important: tomcat5 and tomcat6 security update

2010-08-02T04:00:00
ID RHSA-2010:0581
Type redhat
Reporter RedHat
Modified 2016-04-04T18:31:38

Description

Apache Tomcat is a servlet container for the Java Servlet and JavaServer Pages (JSP) technologies.

A flaw was found in the way Tomcat handled the Transfer-Encoding header in HTTP requests. A specially-crafted HTTP request could prevent Tomcat from sending replies, or cause Tomcat to return truncated replies, or replies containing data related to the requests of other users, for all subsequent HTTP requests. (CVE-2010-2227)

Users of Tomcat should upgrade to these updated packages, which contain a backported patch to resolve this issue. Tomcat must be restarted for this update to take effect.