(RHSA-2007:1117) Critical: samba security update

2007-12-10T05:00:00
ID RHSA-2007:1117
Type redhat
Reporter RedHat
Modified 2017-09-08T11:55:26

Description

Samba is a suite of programs used by machines to share files, printers, and other information.

A stack buffer overflow flaw was found in the way Samba authenticates remote users. A remote unauthenticated user could trigger this flaw to cause the Samba server to crash, or execute arbitrary code with the permissions of the Samba server. (CVE-2007-6015)

Red Hat would like to thank Alin Rad Pop of Secunia Research for responsibly disclosing this issue.

Users of Samba are advised to upgrade to these updated packages, which contain a backported patch to resolve this issue.